Quantcast

4Store and SMW 1.8 (Error: Malformed query)

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

4Store and SMW 1.8 (Error: Malformed query)

peterk
Hi, I am trying to configure 4Store's triple-store and SPARQL endpoint (
http://4store.org/) with SMW 1.8

I have followed the configuration from
http://semantic-mediawiki.org/wiki/Help:Using_SPARQL_and_RDF_stores#4Store

$smwgDefaultStore = 'SMWSparqlStore';
$smwgSparqlDatabase = 'SMWSparqlDatabase4Store';
$smwgSparqlQueryEndpoint = 'http://localhost:8080/sparql/';
$smwgSparqlUpdateEndpoint = 'http://localhost:8080/update/';
$smwgSparqlDataEndpoint = '';
$smwgSparqlDefaultGraph = '';
enableSemantics('mywiki');

I have tried a few tweaks but I keep getting the "Error: Malformed query"
with the following error-trail:
=================
Unexpected non-MediaWiki exception encountered, of type
"SMWSparqlDatabaseError"
exception 'SMWSparqlDatabaseError' with message 'A SPARQL query error has
occurred
Query: PREFIX wiki: <http://mywiki/wiki/index.php/Special:URIResolver/>
PREFIX rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
PREFIX owl: <http://www.w3.org/2002/07/owl#>
PREFIX swivt: <http://semantic-mediawiki.org/swivt/1.0#>
PREFIX property: <
http://mywiki/wiki/index.php/Special:URIResolver/Property-3A>
PREFIX xsd: <http://www.w3.org/2001/XMLSchema#>
DELETE { property:Last_editor_is ?p ?o } WHERE { property:Last_editor_is ?p
?o }
Error: Malformed query
Endpoint: http://localhost:8080/update/
HTTP response code: 400
' in
/Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php:590
Stack trace:
#0
/Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(500):
SMWSparqlDatabase->throwSparqlErrors('http://localhos...', 'PREFIX wiki:
<h...')
#1
/Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(351):
SMWSparqlDatabase->doUpdate('PREFIX wiki: <h...')
#2
/Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(357):
SMWSparqlDatabase->delete('property:Last_e...', 'property:Last_e...', Array)
#3
/Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(105):
SMWSparqlStore->deleteSparqlData(Object(SMWExpNsResource))
#4
/Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/jobs/SMW_UpdateJob.php(45):
SMWSparqlStore->deleteSubject(Object(Title))
#5 /Users/peterk/Projects/MAMP/wiki/includes/Wiki.php(435):
SMWUpdateJob->run()
...
=================

I managed to configure 4Store with SMW 1.7.1 in the past.

Is there a known bug or change with configuring this triple-store in V1.8?

Thanks, Peter
------------------------------------------------------------------------------
Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
MVPs and experts. ON SALE this month only -- learn more at:
http://p.sf.net/sfu/learnmore_122712
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 4Store and SMW 1.8 (Error: Malformed query)

Daniel Clark
On Thu, Jan 3, 2013 at 5:04 PM, Peter Kovari <[hidden email]> wrote:

> Hi, I am trying to configure 4Store's triple-store and SPARQL endpoint (
> http://4store.org/) with SMW 1.8
>
> I have followed the configuration from
> http://semantic-mediawiki.org/wiki/Help:Using_SPARQL_and_RDF_stores#4Store
>
> $smwgDefaultStore = 'SMWSparqlStore';
> $smwgSparqlDatabase = 'SMWSparqlDatabase4Store';
> $smwgSparqlQueryEndpoint = 'http://localhost:8080/sparql/';
> $smwgSparqlUpdateEndpoint = 'http://localhost:8080/update/';
> $smwgSparqlDataEndpoint = '';
> $smwgSparqlDefaultGraph = '';
> enableSemantics('mywiki');
>
> I have tried a few tweaks but I keep getting the "Error: Malformed query"
> with the following error-trail:
> =================
> Unexpected non-MediaWiki exception encountered, of type
> "SMWSparqlDatabaseError"
> exception 'SMWSparqlDatabaseError' with message 'A SPARQL query error has
> occurred
> Query: PREFIX wiki: <http://mywiki/wiki/index.php/Special:URIResolver/>
> PREFIX rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#>
> PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
> PREFIX owl: <http://www.w3.org/2002/07/owl#>
> PREFIX swivt: <http://semantic-mediawiki.org/swivt/1.0#>
> PREFIX property: <
> http://mywiki/wiki/index.php/Special:URIResolver/Property-3A>
> PREFIX xsd: <http://www.w3.org/2001/XMLSchema#>
> DELETE { property:Last_editor_is ?p ?o } WHERE { property:Last_editor_is ?p
> ?o }
> Error: Malformed query
> Endpoint: http://localhost:8080/update/
> HTTP response code: 400
> ' in
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php:590
> Stack trace:
> #0
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(500):
> SMWSparqlDatabase->throwSparqlErrors('http://localhos...', 'PREFIX wiki:
> <h...')
> #1
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(351):
> SMWSparqlDatabase->doUpdate('PREFIX wiki: <h...')
> #2
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(357):
> SMWSparqlDatabase->delete('property:Last_e...', 'property:Last_e...', Array)
> #3
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(105):
> SMWSparqlStore->deleteSparqlData(Object(SMWExpNsResource))
> #4
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/jobs/SMW_UpdateJob.php(45):
> SMWSparqlStore->deleteSubject(Object(Title))
> #5 /Users/peterk/Projects/MAMP/wiki/includes/Wiki.php(435):
> SMWUpdateJob->run()
> ...
> =================
>
> I managed to configure 4Store with SMW 1.7.1 in the past.
>
> Is there a known bug or change with configuring this triple-store in V1.8?

I'm getting exactly the same error; I actually missed this email, and
just sent another email to the list with the exact same problem.

So I can at least tell you it's not just you. I'm going to try SMW
1.7.1 and see if that works for me as you say it has worked for you.

If anyone has a more recent (MediaWiki, SMW, 4store) version set that
works for them, please tell us :-)

------------------------------------------------------------------------------
Master HTML5, CSS3, ASP.NET, MVC, AJAX, Knockout.js, Web API and
much more. Get web development skills now with LearnDevNow -
350+ hours of step-by-step video tutorials by Microsoft MVPs and experts.
SALE $99.99 this month only -- learn more at:
http://p.sf.net/sfu/learnmore_122812
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 4Store and SMW 1.8 (Error: Malformed query)

peterk
Good to know... we just need a fix/workaround for this then. I can confirm
that SMW 1.7.1 works with 4Store just fine.

On 4 January 2013 19:12, Daniel Clark <[hidden email]> wrote:

> On Thu, Jan 3, 2013 at 5:04 PM, Peter Kovari <[hidden email]>
> wrote:
> > Hi, I am trying to configure 4Store's triple-store and SPARQL endpoint (
> > http://4store.org/) with SMW 1.8
> >
> > I have followed the configuration from
> >
> http://semantic-mediawiki.org/wiki/Help:Using_SPARQL_and_RDF_stores#4Store
> >
> > $smwgDefaultStore = 'SMWSparqlStore';
> > $smwgSparqlDatabase = 'SMWSparqlDatabase4Store';
> > $smwgSparqlQueryEndpoint = 'http://localhost:8080/sparql/';
> > $smwgSparqlUpdateEndpoint = 'http://localhost:8080/update/';
> > $smwgSparqlDataEndpoint = '';
> > $smwgSparqlDefaultGraph = '';
> > enableSemantics('mywiki');
> >
> > I have tried a few tweaks but I keep getting the "Error: Malformed query"
> > with the following error-trail:
> > =================
> > Unexpected non-MediaWiki exception encountered, of type
> > "SMWSparqlDatabaseError"
> > exception 'SMWSparqlDatabaseError' with message 'A SPARQL query error has
> > occurred
> > Query: PREFIX wiki: <http://mywiki/wiki/index.php/Special:URIResolver/>
> > PREFIX rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#>
> > PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
> > PREFIX owl: <http://www.w3.org/2002/07/owl#>
> > PREFIX swivt: <http://semantic-mediawiki.org/swivt/1.0#>
> > PREFIX property: <
> > http://mywiki/wiki/index.php/Special:URIResolver/Property-3A>
> > PREFIX xsd: <http://www.w3.org/2001/XMLSchema#>
> > DELETE { property:Last_editor_is ?p ?o } WHERE { property:Last_editor_is
> ?p
> > ?o }
> > Error: Malformed query
> > Endpoint: http://localhost:8080/update/
> > HTTP response code: 400
> > ' in
> >
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php:590
> > Stack trace:
> > #0
> >
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(500):
> > SMWSparqlDatabase->throwSparqlErrors('http://localhos...', 'PREFIX wiki:
> > <h...')
> > #1
> >
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(351):
> > SMWSparqlDatabase->doUpdate('PREFIX wiki: <h...')
> > #2
> >
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(357):
> > SMWSparqlDatabase->delete('property:Last_e...', 'property:Last_e...',
> Array)
> > #3
> >
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(105):
> > SMWSparqlStore->deleteSparqlData(Object(SMWExpNsResource))
> > #4
> >
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/jobs/SMW_UpdateJob.php(45):
> > SMWSparqlStore->deleteSubject(Object(Title))
> > #5 /Users/peterk/Projects/MAMP/wiki/includes/Wiki.php(435):
> > SMWUpdateJob->run()
> > ...
> > =================
> >
> > I managed to configure 4Store with SMW 1.7.1 in the past.
> >
> > Is there a known bug or change with configuring this triple-store in
> V1.8?
>
> I'm getting exactly the same error; I actually missed this email, and
> just sent another email to the list with the exact same problem.
>
> So I can at least tell you it's not just you. I'm going to try SMW
> 1.7.1 and see if that works for me as you say it has worked for you.
>
> If anyone has a more recent (MediaWiki, SMW, 4store) version set that
> works for them, please tell us :-)
>
------------------------------------------------------------------------------
Master HTML5, CSS3, ASP.NET, MVC, AJAX, Knockout.js, Web API and
much more. Get web development skills now with LearnDevNow -
350+ hours of step-by-step video tutorials by Microsoft MVPs and experts.
SALE $99.99 this month only -- learn more at:
http://p.sf.net/sfu/learnmore_122812
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 4Store and SMW 1.8 (Error: Malformed query)

Daniel Clark
Opened a bug for this:
https://bugzilla.wikimedia.org/show_bug.cgi?id=43708

On Fri, Jan 4, 2013 at 5:04 PM, Peter Kovari <[hidden email]> wrote:

> Good to know... we just need a fix/workaround for this then. I can confirm
> that SMW 1.7.1 works with 4Store just fine.
>
>
> On 4 January 2013 19:12, Daniel Clark <[hidden email]> wrote:
>
>> On Thu, Jan 3, 2013 at 5:04 PM, Peter Kovari <[hidden email]>
>> wrote:
>> > Hi, I am trying to configure 4Store's triple-store and SPARQL endpoint (
>> > http://4store.org/) with SMW 1.8
>> >
>> > I have followed the configuration from
>> >
>> http://semantic-mediawiki.org/wiki/Help:Using_SPARQL_and_RDF_stores#4Store
>> >
>> > $smwgDefaultStore = 'SMWSparqlStore';
>> > $smwgSparqlDatabase = 'SMWSparqlDatabase4Store';
>> > $smwgSparqlQueryEndpoint = 'http://localhost:8080/sparql/';
>> > $smwgSparqlUpdateEndpoint = 'http://localhost:8080/update/';
>> > $smwgSparqlDataEndpoint = '';
>> > $smwgSparqlDefaultGraph = '';
>> > enableSemantics('mywiki');
>> >
>> > I have tried a few tweaks but I keep getting the "Error: Malformed
>> query"
>> > with the following error-trail:
>> > =================
>> > Unexpected non-MediaWiki exception encountered, of type
>> > "SMWSparqlDatabaseError"
>> > exception 'SMWSparqlDatabaseError' with message 'A SPARQL query error
>> has
>> > occurred
>> > Query: PREFIX wiki: <http://mywiki/wiki/index.php/Special:URIResolver/>
>> > PREFIX rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#>
>> > PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
>> > PREFIX owl: <http://www.w3.org/2002/07/owl#>
>> > PREFIX swivt: <http://semantic-mediawiki.org/swivt/1.0#>
>> > PREFIX property: <
>> > http://mywiki/wiki/index.php/Special:URIResolver/Property-3A>
>> > PREFIX xsd: <http://www.w3.org/2001/XMLSchema#>
>> > DELETE { property:Last_editor_is ?p ?o } WHERE {
>> property:Last_editor_is ?p
>> > ?o }
>> > Error: Malformed query
>> > Endpoint: http://localhost:8080/update/
>> > HTTP response code: 400
>> > ' in
>> >
>> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php:590
>> > Stack trace:
>> > #0
>> >
>> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(500):
>> > SMWSparqlDatabase->throwSparqlErrors('http://localhos...', 'PREFIX
>> wiki:
>> > <h...')
>> > #1
>> >
>> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(351):
>> > SMWSparqlDatabase->doUpdate('PREFIX wiki: <h...')
>> > #2
>> >
>> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(357):
>> > SMWSparqlDatabase->delete('property:Last_e...', 'property:Last_e...',
>> Array)
>> > #3
>> >
>> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(105):
>> > SMWSparqlStore->deleteSparqlData(Object(SMWExpNsResource))
>> > #4
>> >
>> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/jobs/SMW_UpdateJob.php(45):
>> > SMWSparqlStore->deleteSubject(Object(Title))
>> > #5 /Users/peterk/Projects/MAMP/wiki/includes/Wiki.php(435):
>> > SMWUpdateJob->run()
>> > ...
>> > =================
>> >
>> > I managed to configure 4Store with SMW 1.7.1 in the past.
>> >
>> > Is there a known bug or change with configuring this triple-store in
>> V1.8?
>>
>> I'm getting exactly the same error; I actually missed this email, and
>> just sent another email to the list with the exact same problem.
>>
>> So I can at least tell you it's not just you. I'm going to try SMW
>> 1.7.1 and see if that works for me as you say it has worked for you.
>>
>> If anyone has a more recent (MediaWiki, SMW, 4store) version set that
>> works for them, please tell us :-)
>>
>
>
------------------------------------------------------------------------------
Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
MVPs and experts. SALE $99.99 this month only -- learn more at:
http://p.sf.net/sfu/learnmore_122412
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 4Store and SMW 1.8 (Error: Malformed query)

doug b.
In reply to this post by peterk
After some experimentation, I have gotten 4store to work with SMW 1.8.0.

To make this work I had to modify the file
"extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php".

The key is to comment out two (identical) lines that were added from
version 1.7.1, in the functions doQuery() and doUpdate(). The line to
comment out is:

curl_setopt( $this->m_curlhandle, CURLOPT_HTTPHEADER, array('Content-Type:
application/x-www-form-urlencoded;charset=UTF-8'));

I am running 4store version 1.14 and am not sure whether this fix will
survive an update to 1.15.

I also am not sure exactly why this fix works. When I query my 4store with
curl, I use the --data-urlencoded option which, in theory, sends POST data
with the header Content-Type: application/x-www-form-urlencoded, as above.
And it works fine. Why the same header causes 4store to reject the query
from SMW is puzzling.

Developers?




On Thu, Jan 3, 2013 at 5:04 PM, Peter Kovari <[hidden email]> wrote:

> Hi, I am trying to configure 4Store's triple-store and SPARQL endpoint (
> http://4store.org/) with SMW 1.8
>
> I have followed the configuration from
> http://semantic-mediawiki.org/wiki/Help:Using_SPARQL_and_RDF_stores#4Store
>
> $smwgDefaultStore = 'SMWSparqlStore';
> $smwgSparqlDatabase = 'SMWSparqlDatabase4Store';
> $smwgSparqlQueryEndpoint = 'http://localhost:8080/sparql/';
> $smwgSparqlUpdateEndpoint = 'http://localhost:8080/update/';
> $smwgSparqlDataEndpoint = '';
> $smwgSparqlDefaultGraph = '';
> enableSemantics('mywiki');
>
> I have tried a few tweaks but I keep getting the "Error: Malformed query"
> with the following error-trail:
> =================
> Unexpected non-MediaWiki exception encountered, of type
> "SMWSparqlDatabaseError"
> exception 'SMWSparqlDatabaseError' with message 'A SPARQL query error has
> occurred
> Query: PREFIX wiki: <http://mywiki/wiki/index.php/Special:URIResolver/>
> PREFIX rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#>
> PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
> PREFIX owl: <http://www.w3.org/2002/07/owl#>
> PREFIX swivt: <http://semantic-mediawiki.org/swivt/1.0#>
> PREFIX property: <
> http://mywiki/wiki/index.php/Special:URIResolver/Property-3A>
> PREFIX xsd: <http://www.w3.org/2001/XMLSchema#>
> DELETE { property:Last_editor_is ?p ?o } WHERE { property:Last_editor_is ?p
> ?o }
> Error: Malformed query
> Endpoint: http://localhost:8080/update/
> HTTP response code: 400
> ' in
>
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php:590
> Stack trace:
> #0
>
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(500):
> SMWSparqlDatabase->throwSparqlErrors('http://localhos...', 'PREFIX wiki:
> <h...')
> #1
>
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/sparql/SMW_SparqlDatabase.php(351):
> SMWSparqlDatabase->doUpdate('PREFIX wiki: <h...')
> #2
>
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(357):
> SMWSparqlDatabase->delete('property:Last_e...', 'property:Last_e...',
> Array)
> #3
>
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/storage/SMW_SparqlStore.php(105):
> SMWSparqlStore->deleteSparqlData(Object(SMWExpNsResource))
> #4
>
> /Users/peterk/Projects/MAMP/wiki/extensions/SemanticMediaWiki/includes/jobs/SMW_UpdateJob.php(45):
> SMWSparqlStore->deleteSubject(Object(Title))
> #5 /Users/peterk/Projects/MAMP/wiki/includes/Wiki.php(435):
> SMWUpdateJob->run()
> ...
> =================
>
> I managed to configure 4Store with SMW 1.7.1 in the past.
>
> Is there a known bug or change with configuring this triple-store in V1.8?
>
> Thanks, Peter
>
> ------------------------------------------------------------------------------
> Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
> MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
> with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
> MVPs and experts. ON SALE this month only -- learn more at:
> http://p.sf.net/sfu/learnmore_122712
> _______________________________________________
> Semediawiki-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/semediawiki-user
>
------------------------------------------------------------------------------
Free Next-Gen Firewall Hardware Offer
Buy your Sophos next-gen firewall before the end March 2013
and get the hardware for free! Learn more.
http://p.sf.net/sfu/sophos-d2d-feb
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 4Store and SMW 1.8 (Error: Malformed query)

peterk
I can confirm that the "fix" worked. Although the original bug/issue still remains with SMW 1.8.0.4.

I slightly modified the fix, kept the culr_setop line and only removed the ;charset=UTF-8' part of the content-type setting. It seems that UTF-8 causes the problem with 4Store.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 4Store and SMW 1.8 (Error: Malformed query)

Yury Katkov
The fix doesn't work for me (Ubuntu, 4store1.1.4, mw 1.20, SMW 1.8.0.4). It
seems odd that there is WITH keyword before the SPARQL DELETE query. It
isn't mentioned in SPARQL UPDATE standard.

I tried replacing WITH "<uri> DELETE {smth} WHERE {smth} " with "DELETE
FROM <uri> {smth} WHERE {smth}" but I still get the message

"Malformed query"

-----
Yury Katkov, WikiVote



On Wed, Mar 13, 2013 at 2:54 AM, peterk <[hidden email]> wrote:

> I can confirm that the "fix" worked. Although the original bug/issue still
> remains with SMW 1.8.0.4.
>
> I slightly modified the fix, kept the /culr_setop/ line and only removed
> the
> /;charset=UTF-8'/ part of the content-type setting. It seems that UTF-8
> causes the problem with 4Store.
>
>
>
> --
> View this message in context:
> http://wikimedia.7.n6.nabble.com/4Store-and-SMW-1-8-Error-Malformed-query-tp4992768p4999183.html
> Sent from the Semantic Mediawiki - User mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Everyone hates slow websites. So do we.
> Make your web apps faster with AppDynamics
> Download AppDynamics Lite for free today:
> http://p.sf.net/sfu/appdyn_d2d_mar
> _______________________________________________
> Semediawiki-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/semediawiki-user
>
------------------------------------------------------------------------------
Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and
their applications. This 200-page book is written by three acclaimed
leaders in the field. The early access version is available now.
Download your free book today! http://p.sf.net/sfu/neotech_d2d_may
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 4Store and SMW 1.8 (Error: Malformed query)

Yury Katkov
Gotcha! It work with the fix. I'll try to commit it.
-----
Yury Katkov, WikiVote



On Sat, May 11, 2013 at 10:12 PM, Yury Katkov <[hidden email]>wrote:

> The fix doesn't work for me (Ubuntu, 4store1.1.4, mw 1.20, SMW 1.8.0.4).
> It seems odd that there is WITH keyword before the SPARQL DELETE query. It
> isn't mentioned in SPARQL UPDATE standard.
>
> I tried replacing WITH "<uri> DELETE {smth} WHERE {smth} " with "DELETE
> FROM <uri> {smth} WHERE {smth}" but I still get the message
>
> "Malformed query"
>
> -----
> Yury Katkov, WikiVote
>
>
>
> On Wed, Mar 13, 2013 at 2:54 AM, peterk <[hidden email]> wrote:
>
>> I can confirm that the "fix" worked. Although the original bug/issue still
>> remains with SMW 1.8.0.4.
>>
>> I slightly modified the fix, kept the /culr_setop/ line and only removed
>> the
>> /;charset=UTF-8'/ part of the content-type setting. It seems that UTF-8
>> causes the problem with 4Store.
>>
>>
>>
>> --
>> View this message in context:
>> http://wikimedia.7.n6.nabble.com/4Store-and-SMW-1-8-Error-Malformed-query-tp4992768p4999183.html
>> Sent from the Semantic Mediawiki - User mailing list archive at
>> Nabble.com.
>>
>>
>> ------------------------------------------------------------------------------
>> Everyone hates slow websites. So do we.
>> Make your web apps faster with AppDynamics
>> Download AppDynamics Lite for free today:
>> http://p.sf.net/sfu/appdyn_d2d_mar
>> _______________________________________________
>> Semediawiki-user mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/semediawiki-user
>>
>
>
------------------------------------------------------------------------------
Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and
their applications. This 200-page book is written by three acclaimed
leaders in the field. The early access version is available now.
Download your free book today! http://p.sf.net/sfu/neotech_d2d_may
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Loading...