Best way to upgrade mw+smw+sf from quite old versions to last stable versions ?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Best way to upgrade mw+smw+sf from quite old versions to last stable versions ?

mbenard
Dear all,

my current smw+mw is currently :
MW 1.26.3 (no more supported)
SMW 2.4.1
Semantic Forms 3.6
PHP 5.3.3
Redhat 6

Some extensions were installed with tarballs, other with composer


I'm planning to go for :
MW 1.28
SMW 2.5
Page forms 4.1
PHP 5.6
Debian 8

What would the best way to upgrade ?

I was thinking of :

doing a fresh install of MW
doing fresh installs of semantic extensions using composer
dropping the semantic tables of the original wiki
dump / restore the mysql tables of the original wiki , copy the uploaded
files, Localsettings.php etc
running the update script of Mediawiki/maintenance
rebuild the semantic tables

Moreover, will the semantic pages, prorpertiees, queries, ... created with
SMW 2.4.1/SF 3.6 work witthout modifications with SMW 2.5/Page forms 4.1 ?



Thanks for your insights

MB


----------------------------- Disclaimer ------------------------------
--- Ce message ainsi que les éventuelles pièces jointes constituent une
correspondance privée et confidentielle à l'attention exclusive du
destinataire désigné ci-dessus. Si vous n'êtes pas le destinataire du
présent message ou une personne susceptible de pouvoir le lui délivrer,
il vous est signifié que toute divulgation, distribution ou copie,
totale ou partielle, sur un quelconque support de cette transmission
est strictement interdite. Si vous avez recu ce message par erreur,
nous vous remercions d'en informer l'expéditeur par téléphone ou de lui
retourner le présent message, puis d'effacer immédiatement ce message
de votre systeme. Tout message électronique est susceptible
d'altération. Le "groupement des Mousquetaires" décline toute
responsabilité au titre de ce message s'il a été altéré, déformé ou
falsifié.---
--- This e-mail and any attachments is a confidential correspondence
intended only for use of the individual or entity named above. If you
are not the intended recipient or the agent responsible for delivering
the message to the intended recipient, you are hereby notified that any
disclosure, distribution or copying, either whole or partial, in any
medium of this communication is strictly prohibited. If you have
received this communication by mistake, please notify the sender by
phone or by replying this message, and then delete this message from
your system. E-mails are susceptible of alteration. The
"Mousquetaires' group" shall not therefore be liable for the message
if altered, changed or falsified.---
-----------------------------------------------------------------------

 

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Best way to upgrade mw+smw+sf from quite old versions to last stable versions ?

Tobias Oetterer-2
Hey

I would make a backup of the database (to have a fallback in case of
something going wrong), do a fresh installation but use the old database.
After finished installation, run some maintenance scripts
(mw/maintenance/update.php and
/extensions/smw/mainteanance/rebuildData.php). Should work...

Regards,
Tobias

--
If this email is rather brief, it is not meant to be impolite but to respect
your time.
http://five.sentenc.es
No trees were killed to send this message, but a large number of electrons
were terribly inconvenienced

University of Paderborn
Zentrum IMT
Warburger Straße 100
33098 Paderborn

Office: N5.338
Phone: 05251/60-2194
Internet: http://imt.uni-paderborn.de
-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]]
Gesendet: Mittwoch, 29. März 2017 15:33
An: [hidden email]
Betreff: [Semediawiki-user] Best way to upgrade mw+smw+sf from quite old
versions to last stable versions ?

Dear all,

my current smw+mw is currently :
MW 1.26.3 (no more supported)
SMW 2.4.1
Semantic Forms 3.6
PHP 5.3.3
Redhat 6

Some extensions were installed with tarballs, other with composer


I'm planning to go for :
MW 1.28
SMW 2.5
Page forms 4.1
PHP 5.6
Debian 8

What would the best way to upgrade ?

I was thinking of :

doing a fresh install of MW
doing fresh installs of semantic extensions using composer dropping the
semantic tables of the original wiki dump / restore the mysql tables of the
original wiki , copy the uploaded files, Localsettings.php etc running the
update script of Mediawiki/maintenance rebuild the semantic tables

Moreover, will the semantic pages, prorpertiees, queries, ... created with
SMW 2.4.1/SF 3.6 work witthout modifications with SMW 2.5/Page forms 4.1 ?



Thanks for your insights

MB


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Best way to upgrade mw+smw+sf from quite old versions to last stable versions ?

kghbln
Heiya,

and also depending on how often you would like to make big updates you
could jump from LTS version to LTS version 1.27 to 1.31 etc. Semantic
MediaWiki data are basically secondary data, so you may drop and
recreate the tables. The syntax as such is on the page itself.

Cheers Karsten

Am 29.03.2017 um 15:41 schrieb Tobias Oetterer:

> Hey
>
> I would make a backup of the database (to have a fallback in case of
> something going wrong), do a fresh installation but use the old database.
> After finished installation, run some maintenance scripts
> (mw/maintenance/update.php and
> /extensions/smw/mainteanance/rebuildData.php). Should work...
>
> Regards,
> Tobias
>
> --
> If this email is rather brief, it is not meant to be impolite but to respect
> your time.
> http://five.sentenc.es
> No trees were killed to send this message, but a large number of electrons
> were terribly inconvenienced
>
> University of Paderborn
> Zentrum IMT
> Warburger Straße 100
> 33098 Paderborn
>
> Office: N5.338
> Phone: 05251/60-2194
> Internet: http://imt.uni-paderborn.de
> -----Ursprüngliche Nachricht-----
> Von: [hidden email] [mailto:[hidden email]]
> Gesendet: Mittwoch, 29. März 2017 15:33
> An: [hidden email]
> Betreff: [Semediawiki-user] Best way to upgrade mw+smw+sf from quite old
> versions to last stable versions ?
>
> Dear all,
>
> my current smw+mw is currently :
> MW 1.26.3 (no more supported)
> SMW 2.4.1
> Semantic Forms 3.6
> PHP 5.3.3
> Redhat 6
>
> Some extensions were installed with tarballs, other with composer
>
>
> I'm planning to go for :
> MW 1.28
> SMW 2.5
> Page forms 4.1
> PHP 5.6
> Debian 8
>
> What would the best way to upgrade ?
>
> I was thinking of :
>
> doing a fresh install of MW
> doing fresh installs of semantic extensions using composer dropping the
> semantic tables of the original wiki dump / restore the mysql tables of the
> original wiki , copy the uploaded files, Localsettings.php etc running the
> update script of Mediawiki/maintenance rebuild the semantic tables
>
> Moreover, will the semantic pages, prorpertiees, queries, ... created with
> SMW 2.4.1/SF 3.6 work witthout modifications with SMW 2.5/Page forms 4.1 ?
>
>
>
> Thanks for your insights
>
> MB
>
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>
>
> _______________________________________________
> Semediawiki-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/semediawiki-user

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Loading...