Bump of minimum required PHP version to 5.3 for MediaWiki 1.20

classic Classic list List threaded Threaded
23 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Re: Bump of minimum required PHP version to 5.3 for MediaWiki 1.20

Platonides
On 23/02/12 22:23, Chad wrote:
>> Under the hood performance improvements
>> Optional garbage collection for cyclic references
>
> This is my favorite part of 5.3 <3
>
> -Chad

You don't need 5.2 incompatible code for that.


_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l
Reply | Threaded
Open this post in threaded view
|

Re: Bump of minimum required PHP version to 5.3 for MediaWiki 1.20

Arthur Richards-2
There does not seem to have been a decision made here - is there even a
process for making a decision like this?

We already have some extension code in production that requires PHP >= 5.3 (
https://www.mediawiki.org/wiki/Special:Code/MediaWiki/111691). I assume
that's not the case for core, but it seems a slippery road for us to go
down allowing code that requires PHP 5.3 into production if we intend to
support PHP >= 5.2.

While we await some sort of decision about this, what is the appropriate
thing to do when we see PHP code that's only compatible with PHP >= 5.3 in
code review? I went ahead and tagged a couple of revisions I saw making use
of late static bindings with 'php5.3' and left them as 'new' pending some
sort of decision/guidance.

Arthur

On Thu, Feb 23, 2012 at 10:56 PM, Platonides <[hidden email]> wrote:

> On 23/02/12 22:23, Chad wrote:
> >> Under the hood performance improvements
> >> Optional garbage collection for cyclic references
> >
> > This is my favorite part of 5.3 <3
> >
> > -Chad
>
> You don't need 5.2 incompatible code for that.
>
>
> _______________________________________________
> Wikitech-l mailing list
> [hidden email]
> https://lists.wikimedia.org/mailman/listinfo/wikitech-l
>



--
Arthur Richards
Software Engineer, Mobile
[[User:Awjrichards]]
IRC: awjr
+1-415-839-6885 x6687
_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l
Reply | Threaded
Open this post in threaded view
|

Re: Bump of minimum required PHP version to 5.3 for MediaWiki 1.20

Chad
On Fri, Mar 9, 2012 at 6:11 PM, Arthur Richards <[hidden email]> wrote:
> There does not seem to have been a decision made here - is there even a
> process for making a decision like this?
>

We kind of just bikeshed it around on the list for a few weeks then
somebody finally bumps it in trunk. That's what happened when
we began requiring 5.2.3

> While we await some sort of decision about this, what is the appropriate
> thing to do when we see PHP code that's only compatible with PHP >= 5.3 in
> code review? I went ahead and tagged a couple of revisions I saw making use
> of late static bindings with 'php5.3' and left them as 'new' pending some
> sort of decision/guidance.
>

Personally, I'd suggest reverting 5.3-isms until the minimum version
is bumped. But I'm not about to start a holy war over it.

-Chad

_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l
12