Quantcast

Extension compatibility policy can now be declared in infobox - please update!

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Extension compatibility policy can now be declared in infobox - please update!

Gergo Tisza
Hi all,

you can now declare in the extension infobox what compatibility policy is
being followed. Most extensions follow one of two policies:
* The master branch of the extension should remain compatible with older
versions of MediaWiki core (supported versions, maybe even older ones).
Developers updating the extension after a core change are expected to leave
B/C code so that the extension keeps working with both versions of core.
Users of the extension should use the master branch no matter what core
version they are running (unless it is really old, in which case they are
on their own).
* Extension release branches (REL1_XX branches, which are created
automatically if the extension is hosted on gerrit) are compatible with
matching core branches. Developers updating the extension after a core
change are free to remove old logic, but should backport security fixes to
supported branches. Users of the extension should use master with MediaWiki
master, and the corresponding branch with a MediaWiki release (e.g. the
REL1_27 extension branch if they use MediaWiki 1.27).

For extensions you maintain, please add the right template parameter to
{{Extension}}:

|compatibility policy = master

or

|compatibility policy = rel

This will be a great help to developers who are doing mass extension
changes after a breaking core change.

For more details, see https://phabricator.wikimedia.org/T156500
_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l
Loading...