Getting strange characters at action_parse

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Getting strange characters at action_parse

Rainer Terhart
Hello,

i don not know, if i am right here, but i got a strange parse-response from wikiparser today.

Maybe one can have a look on it. (i am from germany and i used wikis api.php for parsing the entry("Baum");
here is the request i used:
http://de.wikipedia.org/w/api.php?action=parse&prop=text&format=xml&page=baum

this should be the last parsed text: "<p><span id="interwiki-he-fa" class="FA"></span></p>"

actually, api.php adds more text at the end of the response.
<p><a href="/w/index.php?title=Af:Boom&....................class="new" title="Zh-yue:&#27193; (Seite nicht vorhanden)">zh-yue:&#27193;</a></p>

In the browser, this is shown as very strange HTML-Text.

Did i made something wrong?
This only happens at the page=Baum

Greetings
Raenaet

_______________________________________________________________________
Jetzt neu! Sch├╝tzen Sie Ihren PC mit McAfee und WEB.DE. 30 Tage
kostenlos testen. http://www.pc-sicherheit.web.de/startseite/?mc=022220


_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: Getting strange characters at action_parse

Roan Kattouw
Rainer Terhart schreef:

> Hello,
>
> i don not know, if i am right here, but i got a strange parse-response from wikiparser today.
>
> Maybe one can have a look on it. (i am from germany and i used wikis api.php for parsing the entry("Baum");
> here is the request i used:
> http://de.wikipedia.org/w/api.php?action=parse&prop=text&format=xml&page=baum
>
> this should be the last parsed text: "<p><span id="interwiki-he-fa" class="FA"></span></p>"
>
> actually, api.php adds more text at the end of the response.
> <p><a href="/w/index.php?title=Af:Boom&....................class="new" title="Zh-yue:&#27193; (Seite nicht vorhanden)">zh-yue:&#27193;</a></p>
>
> In the browser, this is shown as very strange HTML-Text.
>
> Did i made something wrong?
> This only happens at the page=Baum
Strangely, this works for me. I just clicked the link and got an HTML
response ending in

<p><span id="interwiki-he-fa" class="FA"></span></p>

<!--
NewPP limit report
Preprocessor node count: 221/1000000
Post-expand include size: 1819/2048000 bytes
Template argument size: 278/2048000 bytes
Expensive parser function count: 0/500
-->

<!-- Saved in stable version parser cache with key
dewiki:stable-pcache:idhash:11447-0!1!0!!de!2 and timestamp
20081023205212 -->
<!-- Saved in parser cache with key
dewiki:pcache:idhash:11447-0!1!0!!de!2 and timestamp 20081023205212 -->

Roan Kattouw (Catrope)


_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: Getting strange characters at action_parse

Russell Blau
"Roan Kattouw" <[hidden email]> wrote:

> Rainer Terhart schreef:
>> Hello,
>>
>> i don not know, if i am right here, but i got a strange parse-response
>> from wikiparser today.
>>
>> Maybe one can have a look on it. (i am from germany and i used wikis
>> api.php for parsing the entry("Baum");
>> here is the request i used:
>> http://de.wikipedia.org/w/api.php?action=parse&prop=text&format=xml&page=baum
>>
>> this should be the last parsed text: "<p><span id="interwiki-he-fa"
>> class="FA"></span></p>"
>>
>> actually, api.php adds more text at the end of the response.
>> <p><a href="/w/index.php?title=Af:Boom&....................class="new"
>> title="Zh-yue:&#27193; (Seite nicht vorhanden)">zh-yue:&#27193;</a></p>
>>
> Strangely, this works for me. I just clicked the link and got an HTML
> response ending in
>
> <p><span id="interwiki-he-fa" class="FA"></span></p>
>
> <!--
> NewPP limit report
> Preprocessor node count: 221/1000000
> Post-expand include size: 1819/2048000 bytes
> Template argument size: 278/2048000 bytes
> Expensive parser function count: 0/500
> -->
>
> <!-- Saved in stable version parser cache with key
> dewiki:stable-pcache:idhash:11447-0!1!0!!de!2 and timestamp
> 20081023205212 -->
> <!-- Saved in parser cache with key
> dewiki:pcache:idhash:11447-0!1!0!!de!2 and timestamp 20081023205212 -->
>

What you see when you click the OP's link
http://de.wikipedia.org/w/api.php?action=parse&prop=text&format=xml&page=baum 
probably depends on what browser you are using, because of differences in
how browsers react to "format=xml". When I click the link I get the same
text reported by the OP; however, this is also the same thing you will see
if you go to http://de.wikipedia.org/wiki/Baum and select "View Source" or
the equivalent in your web browser.

That page has a lot of improperly formatted interwiki links at the end of
the text.  (I would go in and fix them, but then this thread wouldn't make
sense to anyone....)

Russ


_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: Getting strange characters at action_parse

Roan Kattouw
Russell Blau schreef:
>
> What you see when you click the OP's link
> http://de.wikipedia.org/w/api.php?action=parse&prop=text&format=xml&page=baum 
> probably depends on what browser you are using, because of differences in
> how browsers react to "format=xml".
I don't think so. Using a different format like xmlfm or yamlfm still
doesn't show broken interwiki links. Even after purging the page's
cache, they still don't show up.

Roan Kattouw (Catrope)

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: Getting strange characters at action_parse

Brion Vibber-3
In reply to this post by Rainer Terhart
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Rainer Terhart wrote:

> Hello,
>
> i don not know, if i am right here, but i got a strange parse-response from wikiparser today.
>
> Maybe one can have a look on it. (i am from germany and i used wikis api.php for parsing the entry("Baum");
> here is the request i used:
> http://de.wikipedia.org/w/api.php?action=parse&prop=text&format=xml&page=baum
>
> this should be the last parsed text: "<p><span id="interwiki-he-fa" class="FA"></span></p>"
>
> actually, api.php adds more text at the end of the response.
> <p><a href="/w/index.php?title=Af:Boom&....................class="new" title="Zh-yue:&#27193; (Seite nicht vorhanden)">zh-yue:&#27193;</a></p>

Sounds like a server has or had a broken interwiki cache.

I did a quick check... all reachable Apaches currently have the dba
module (used to read the cache)... and they have a current copy of the
cache file... and correctly read out entries when I test them.

If it recurs, please provide the complete output, might be an old parser
cache entry that hit in the middle of an update or something.

- -- brion
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkkIqNkACgkQwRnhpk1wk46OqQCgxNREJCTN3mROy9rdHZRoo/Jn
X24AoNnAOqwdVHgnoahloYORhravNXEV
=ZYH4
-----END PGP SIGNATURE-----

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api