Having issue with Subversion

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Having issue with Subversion

Hersfold Wikipedia
Hello all,

I'm trying to get my bot's code onto the toolserver's subversion thing,
but when I try to commit my code I keep getting a weird error. Earwig
was very helpful in trying to work out the cause or a solution, but
unfortunately to no avail.

Regardless of what login server I use, or if I try to commit files
through SSH or through Eclipse's Subversion plugin, I get this error:

Transmitting file data .svn: Commit failed (details follow):

svn: Couldn't perform atomic initialization


I've tried looking for a solution online, but most either refer to a bad
SVN version (which isn't the case, since Earwig isn't having issues
committing) or fail to provide a solution at all. Does anyone have any
ideas?

----
User:Hersfold
[hidden email]


_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Having issue with Subversion

Dr. Trigon
> Regardless of what login server I use, or if I try to commit files
> through SSH or through Eclipse's Subversion plugin, I get this error:

Did you try manual commit with the command: 'svn ci' ? Does this works?



_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Changing public key

Rich Farmbrough
In reply to this post by Hersfold Wikipedia
I need to change my public key, not having access to the old private
key.  What's the best way to do this?

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Changing public key

cngxzl
Replace ~/.ssh/authorized_keys with your new public key?

2011/7/26 Richard Farmbrough <[hidden email]>
I need to change my public key, not having access to the old private
key.  What's the best way to do this?

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette


_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Changing public key

Steef389
Hi,

If he hasn't the old key, it will be difficult to log in.
Richard, you have to file a ticket in JIRA [1].

Steef

[1] <https://jira.toolserver.org/>

> Replace ~/.ssh/authorized_keys with your new public key?
>
> 2011/7/26 Richard Farmbrough <[hidden email]
> <mailto:[hidden email]>>
>
>     I need to change my public key, not having access to the old private
>     key.  What's the best way to do this?
>
>     _______________________________________________
>     Toolserver-l mailing list ([hidden email]
>     <mailto:[hidden email]>)
>     https://lists.wikimedia.org/mailman/listinfo/toolserver-l
>     Posting guidelines for this list:
>     https://wiki.toolserver.org/view/Mailing_list_etiquette
>
>
>
>
> _______________________________________________
> Toolserver-l mailing list ([hidden email])
> https://lists.wikimedia.org/mailman/listinfo/toolserver-l
> Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Having issue with Subversion

Hydriz Wikipedia
In reply to this post by Dr. Trigon
I do get the same error as what the original person has stated, even when using svn ci. Had this issue for almost 4-5 months now...

Regards,
Hydriz


> Date: Tue, 26 Jul 2011 10:09:19 +0200

> From: [hidden email]
> To: [hidden email]
> Subject: Re: [Toolserver-l] Having issue with Subversion
>
> > Regardless of what login server I use, or if I try to commit files
> > through SSH or through Eclipse's Subversion plugin, I get this error:
>
> Did you try manual commit with the command: 'svn ci' ? Does this works?
>
>
>
> _______________________________________________
> Toolserver-l mailing list ([hidden email])
> https://lists.wikimedia.org/mailman/listinfo/toolserver-l
> Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Having issue with Subversion

Jan Luca
In reply to this post by Hersfold Wikipedia
Hi,

Does the commit work some time ago? Do you use
https://svn.toolserver.org/svnroot/<username>?

Best regards,
Jan

-----Ursprüngliche Nachricht-----
Von: [hidden email]
[mailto:[hidden email]] Im Auftrag von Hersfold
Gesendet: Dienstag, 26. Juli 2011 03:53
An: [hidden email]
Betreff: [Toolserver-l] Having issue with Subversion

Hello all,

I'm trying to get my bot's code onto the toolserver's subversion thing,
but when I try to commit my code I keep getting a weird error. Earwig
was very helpful in trying to work out the cause or a solution, but
unfortunately to no avail.

Regardless of what login server I use, or if I try to commit files
through SSH or through Eclipse's Subversion plugin, I get this error:

Transmitting file data .svn: Commit failed (details follow):

svn: Couldn't perform atomic initialization


I've tried looking for a solution online, but most either refer to a bad
SVN version (which isn't the case, since Earwig isn't having issues
committing) or fail to provide a solution at all. Does anyone have any
ideas?

----
User:Hersfold
[hidden email]


_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list:
https://wiki.toolserver.org/view/Mailing_list_etiquette


_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Having issue with Subversion

Hersfold Wikipedia
In reply to this post by Hersfold Wikipedia
In response to an earlier question, svn ci gets the same error. I have
not been able to commit, but I have been able to create a directory
using eclipse (despite getting the same error). I am using
https://svn.toolserver.org/svnroot/hersfold

----
User:Hersfold
[hidden email]

Sent from my Windows Phone From: Jan Luca
Sent: Tuesday, July 26, 2011 11:32
To: [hidden email]
Subject: Re: [Toolserver-l] Having issue with Subversion
Hi,

Does the commit work some time ago? Do you use
https://svn.toolserver.org/svnroot/<username>?

Best regards,
Jan

-----Ursprüngliche Nachricht-----
Von: [hidden email]
[mailto:[hidden email]] Im Auftrag von Hersfold
Gesendet: Dienstag, 26. Juli 2011 03:53
An: [hidden email]
Betreff: [Toolserver-l] Having issue with Subversion

Hello all,

I'm trying to get my bot's code onto the toolserver's subversion thing,
but when I try to commit my code I keep getting a weird error. Earwig
was very helpful in trying to work out the cause or a solution, but
unfortunately to no avail.

Regardless of what login server I use, or if I try to commit files
through SSH or through Eclipse's Subversion plugin, I get this error:

Transmitting file data .svn: Commit failed (details follow):

svn: Couldn't perform atomic initialization


I've tried looking for a solution online, but most either refer to a bad
SVN version (which isn't the case, since Earwig isn't having issues
committing) or fail to provide a solution at all. Does anyone have any
ideas?

----
User:Hersfold
[hidden email]


_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list:
https://wiki.toolserver.org/view/Mailing_list_etiquette


_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list:
https://wiki.toolserver.org/view/Mailing_list_etiquette

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Having issue with Subversion

Bryan Tong Minh
In reply to this post by Hersfold Wikipedia
On Tue, Jul 26, 2011 at 3:53 AM, Hersfold <[hidden email]> wrote:
> Transmitting file data .svn: Commit failed (details follow):
>
> svn: Couldn't perform atomic initialization
>
I had this problem a year or two ago, which was fixed by Dab on the
server side. So I would file a bug in JIRA, because the problem is
probably not at your end.


Bryan

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Having issue with Subversion

Hersfold Wikipedia
Where would I file the bug? I didn't see any option for Subversion issues.

----
User:Hersfold
[hidden email]


On 7/26/2011 3:32 PM, Bryan Tong Minh wrote:

> On Tue, Jul 26, 2011 at 3:53 AM, Hersfold<[hidden email]>  wrote:
>> Transmitting file data .svn: Commit failed (details follow):
>>
>> svn: Couldn't perform atomic initialization
>>
> I had this problem a year or two ago, which was fixed by Dab on the
> server side. So I would file a bug in JIRA, because the problem is
> probably not at your end.
>
>
> Bryan
>
> _______________________________________________
> Toolserver-l mailing list ([hidden email])
> https://lists.wikimedia.org/mailman/listinfo/toolserver-l
> Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette