Internal Server Error when using action=edit

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Internal Server Error when using action=edit

Elena Moreno
Hi,


I´m using the action=edit and the response I get from the server seems ok when it returns a code error, like:

- if the query doesn´t identify the user  (code: cantcreate-anon)
- if it is trying to create a page that already exists and the createonly parameter is set (code: articleexists)

But when the request seems to be all right I get an Internal Server Error (Http code 500). The parameters I send are the following:

- title
- section
- text
- token
- summary
- minor
- createonly
- sessionid
- lguserid
- lgtoken



Regards,
Elena Moreno

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: Internal Server Error when using action=edit

Roan Kattouw
Elena Moreno schreef:

> Hi,
>
>
> I´m using the action=edit and the response I get from the server seems
> ok when it returns a code error, like:
>
> - if the query doesn´t identify the user  (code: cantcreate-anon)
> - if it is trying to create a page that already exists and the
> createonly parameter is set (code: articleexists)
>
> But when the request seems to be all right I get an Internal Server
> Error (Http code 500).
We've had more reports about that [1].
> - lguserid
> - lgtoken
Does it matter whether you use lgtoken or cookies?

Roan Kattouw (Catrope)

[1] https://bugzilla.wikimedia.org/show_bug.cgi?id=15420

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: Internal Server Error when using action=edit

Roan Kattouw
Roan Kattouw schreef:

> Elena Moreno schreef:
>  
>> Hi,
>>
>>
>> I´m using the action=edit and the response I get from the server seems
>> ok when it returns a code error, like:
>>
>> - if the query doesn´t identify the user  (code: cantcreate-anon)
>> - if it is trying to create a page that already exists and the
>> createonly parameter is set (code: articleexists)
>>
>> But when the request seems to be all right I get an Internal Server
>> Error (Http code 500).
>>    
> We've had more reports about that [1].
...which was fixed just now. It can take a few days for the fix to go
live on WMF servers.

Roan Kattouw (Catrope)

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api