Massive image loss

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Massive image loss

Tim Starling-2
This is a triple-crosspost. I suggest you reply to wikitech-l only.

A mistake I made caused the loss of 496 full-resolution images from
Wikimedia servers.

I have recovered as many images as I can, drawing on the following sources:

* Squid cache (pmtpa, knams and yaseo)
* May 8 backup of some wikis on storage1
* Duplicates with the same signature, found on the same or other wikis

That brought the number lost down from about 3000 to the current 496. For
the remaining files, I made a copy of their thumbnail directories:

http://upload.wikimedia.org/lost-image-thumb-backup/

A list of missing images can be found here:

http://noc.wikimedia.org/~tstarling/missing-images-2008-09

If anyone has any ideas about where to find more backup files, I'd be
willing to hear them. Otherwise, the community will just have to reupload
as many as possible.

The technical details were as follows: I fixed a bug in File.php, and
without checking what other changes were made to it, deployed the most
recent version of the file on the Wikimedia servers, without also updating
the rest of MediaWiki. Because FileRepo::$thumbDir was unset,
LocalFile::migrateThumbFile() had the effect of deleting the source image
for any thumbnail request which reached the backend. I reverted the change
after about 20 minutes, following a report on IRC.

My sincere apologies.

-- Tim Starling

_______________________________________________
foundation-l mailing list
[hidden email]
Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l
Reply | Threaded
Open this post in threaded view
|

Re: Massive image loss

John at Darkstar
Shit happens! I'm sure there are some backups floating around.
John

Tim Starling skrev:

> This is a triple-crosspost. I suggest you reply to wikitech-l only.
>
> A mistake I made caused the loss of 496 full-resolution images from
> Wikimedia servers.
>
> I have recovered as many images as I can, drawing on the following sources:
>
> * Squid cache (pmtpa, knams and yaseo)
> * May 8 backup of some wikis on storage1
> * Duplicates with the same signature, found on the same or other wikis
>
> That brought the number lost down from about 3000 to the current 496. For
> the remaining files, I made a copy of their thumbnail directories:
>
> http://upload.wikimedia.org/lost-image-thumb-backup/
>
> A list of missing images can be found here:
>
> http://noc.wikimedia.org/~tstarling/missing-images-2008-09
>
> If anyone has any ideas about where to find more backup files, I'd be
> willing to hear them. Otherwise, the community will just have to reupload
> as many as possible.
>
> The technical details were as follows: I fixed a bug in File.php, and
> without checking what other changes were made to it, deployed the most
> recent version of the file on the Wikimedia servers, without also updating
> the rest of MediaWiki. Because FileRepo::$thumbDir was unset,
> LocalFile::migrateThumbFile() had the effect of deleting the source image
> for any thumbnail request which reached the backend. I reverted the change
> after about 20 minutes, following a report on IRC.
>
> My sincere apologies.
>
> -- Tim Starling
>
> _______________________________________________
> foundation-l mailing list
> [hidden email]
> Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l
>

_______________________________________________
foundation-l mailing list
[hidden email]
Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l
Reply | Threaded
Open this post in threaded view
|

Re: Massive image loss

Magnus Manske-2
In reply to this post by Tim Starling-2
On Fri, Sep 5, 2008 at 11:11 AM, Tim Starling <[hidden email]> wrote:

> This is a triple-crosspost. I suggest you reply to wikitech-l only.
>
> A mistake I made caused the loss of 496 full-resolution images from
> Wikimedia servers.
>
> I have recovered as many images as I can, drawing on the following sources:
>
> * Squid cache (pmtpa, knams and yaseo)
> * May 8 backup of some wikis on storage1
> * Duplicates with the same signature, found on the same or other wikis
>
> That brought the number lost down from about 3000 to the current 496. For
> the remaining files, I made a copy of their thumbnail directories:
>
> http://upload.wikimedia.org/lost-image-thumb-backup/
>
> A list of missing images can be found here:
>
> http://noc.wikimedia.org/~tstarling/missing-images-2008-09
>
> If anyone has any ideas about where to find more backup files, I'd be
> willing to hear them. Otherwise, the community will just have to reupload
> as many as possible.

At least one of them ( Clan_member_crest_badge_-_Clan_MacTavish.svg )
was reuploaded in a coincidence :-)

How about a script adding a message to the talk page of the respective uploader?

Magnus

_______________________________________________
foundation-l mailing list
[hidden email]
Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l
Reply | Threaded
Open this post in threaded view
|

Re: Massive image loss

John at Darkstar
Perhaps also add which pages the image was used at on the image list?
That way you increase the chance of people noticing images they have
uploaded. Also, could there be a split on which projects the images was
used at?
John

Magnus Manske skrev:

> On Fri, Sep 5, 2008 at 11:11 AM, Tim Starling <[hidden email]> wrote:
>> This is a triple-crosspost. I suggest you reply to wikitech-l only.
>>
>> A mistake I made caused the loss of 496 full-resolution images from
>> Wikimedia servers.
>>
>> I have recovered as many images as I can, drawing on the following sources:
>>
>> * Squid cache (pmtpa, knams and yaseo)
>> * May 8 backup of some wikis on storage1
>> * Duplicates with the same signature, found on the same or other wikis
>>
>> That brought the number lost down from about 3000 to the current 496. For
>> the remaining files, I made a copy of their thumbnail directories:
>>
>> http://upload.wikimedia.org/lost-image-thumb-backup/
>>
>> A list of missing images can be found here:
>>
>> http://noc.wikimedia.org/~tstarling/missing-images-2008-09
>>
>> If anyone has any ideas about where to find more backup files, I'd be
>> willing to hear them. Otherwise, the community will just have to reupload
>> as many as possible.
>
> At least one of them ( Clan_member_crest_badge_-_Clan_MacTavish.svg )
> was reuploaded in a coincidence :-)
>
> How about a script adding a message to the talk page of the respective uploader?
>
> Magnus
>
> _______________________________________________
> foundation-l mailing list
> [hidden email]
> Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l
>

_______________________________________________
foundation-l mailing list
[hidden email]
Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l
Reply | Threaded
Open this post in threaded view
|

Re: Massive image loss

Yaroslav M. Blanter
In reply to this post by Magnus Manske-2
> How about a script adding a message to the talk page of the respective
> uploader?
>

This would be great of course but many uploadres can be inactive for a
long time or they may have left their home projects. Putting lists of lost
figures to the corresponding village pumps may be more efficient.

Cheers
Yaroslav


_______________________________________________
foundation-l mailing list
[hidden email]
Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l
Reply | Threaded
Open this post in threaded view
|

Re: [Commons-l] Massive image loss

Gregory Maxwell
In reply to this post by Tim Starling-2
On Fri, Sep 5, 2008 at 6:11 AM, Tim Starling <[hidden email]> wrote:
> This is a triple-crosspost. I suggest you reply to wikitech-l only.
>
> A mistake I made caused the loss of 496 full-resolution images from
> Wikimedia servers.
[snip]
> http://noc.wikimedia.org/~tstarling/missing-images-2008-09
>
> If anyone has any ideas about where to find more backup files, I'd be
> willing to hear them. Otherwise, the community will just have to reupload
> as many as possible.
[snip]

I have 30 of the 496 images in that list based on an exact path match.
 It's possible that I have more based on hash matches for image which
were moved between sites or 'renamed' after my last sync.

I have some chores to run, but I will later pull the hashes from the
database and check for hash matches.

I would likely have had nearly all of them if the rsync push to me had
not been down most of the year.

:(

_______________________________________________
foundation-l mailing list
[hidden email]
Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l
Reply | Threaded
Open this post in threaded view
|

Re: Massive image loss

Waerth
In reply to this post by Tim Starling-2
Woops .... it is actually a miracle big mistakes like this haven't
occured before over the years! Which says a lot about the high quality
of the developers and maintainers of the site. Don't worry to much Tim,
it will work itself out. No more 24 our days behind the computer though ;)

Walter van Kalken (waerth)

> This is a triple-crosspost. I suggest you reply to wikitech-l only.
>
> A mistake I made caused the loss of 496 full-resolution images from
> Wikimedia servers.
>
> I have recovered as many images as I can, drawing on the following sources:
>
> * Squid cache (pmtpa, knams and yaseo)
> * May 8 backup of some wikis on storage1
> * Duplicates with the same signature, found on the same or other wikis
>
> That brought the number lost down from about 3000 to the current 496. For
> the remaining files, I made a copy of their thumbnail directories:
>
> http://upload.wikimedia.org/lost-image-thumb-backup/
>
> A list of missing images can be found here:
>
> http://noc.wikimedia.org/~tstarling/missing-images-2008-09
>
> If anyone has any ideas about where to find more backup files, I'd be
> willing to hear them. Otherwise, the community will just have to reupload
> as many as possible.
>
> The technical details were as follows: I fixed a bug in File.php, and
> without checking what other changes were made to it, deployed the most
> recent version of the file on the Wikimedia servers, without also updating
> the rest of MediaWiki. Because FileRepo::$thumbDir was unset,
> LocalFile::migrateThumbFile() had the effect of deleting the source image
> for any thumbnail request which reached the backend. I reverted the change
> after about 20 minutes, following a report on IRC.
>
> My sincere apologies.
>
> -- Tim Starling
>
> _______________________________________________
> foundation-l mailing list
> [hidden email]
> Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l
>
>
>
>  



_______________________________________________
foundation-l mailing list
[hidden email]
Unsubscribe: https://lists.wikimedia.org/mailman/listinfo/foundation-l