MediaWiki 1.31 branch (and PHP versions)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

MediaWiki 1.31 branch (and PHP versions)

Chad
Hi,

I meant to send this Tuesday but I forgot.

MediaWiki 1.31 has been branched from master! You should now see a REL1_31
branch where appropriate items should be backported to.

Core was branched at 69257de17fc899c447c9f1229b6ed319bc05d316.
All extensions & skins were branched from their respective masters at about
the same time as core. I plan to cut rc.0 sometime next week.

PHP versions
The current plan of action is to leave master as compatible with 5.5 for
now. This is because Wikimedia production isn't ready quite yet. This is
being tracked at T172165[0]. We will be moving the REL1_31 branch to 7.0+
as the required minimum version. Once production is ready, we'll
forward-port this change to master. It should be a little inconvenient, but
not too terribly bad (and notably, makes life less stressful for our SREs).
In the meantime, please do NOT introduce changes to master that require
7.0+ for core, vendor, or WMF-deployed extensions & skins. Doing so will
make me sad :(

Otherwise, great job on 1.31.x everyone! I'm rather pleased with what I'm
seeing so far. Check out the workboard[1] for ways you can contribute to
getting it wrapped up (and as always, tag issues with that tag if they
should absolutely block release).

Have a fantastic weekend!

-Chad

[0] https://phabricator.wikimedia.org/T172165
[1] https://phabricator.wikimedia.org/project/view/3011/
_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki 1.31 branch (and PHP versions)

Brion Vibber-4
Exciting times! Looking forward to our PHP 7 future, if not just yet. :D

-- brion

On Fri, Apr 20, 2018 at 4:54 PM, Chad <[hidden email]> wrote:

> Hi,
>
> I meant to send this Tuesday but I forgot.
>
> MediaWiki 1.31 has been branched from master! You should now see a REL1_31
> branch where appropriate items should be backported to.
>
> Core was branched at 69257de17fc899c447c9f1229b6ed319bc05d316.
> All extensions & skins were branched from their respective masters at about
> the same time as core. I plan to cut rc.0 sometime next week.
>
> PHP versions
> The current plan of action is to leave master as compatible with 5.5 for
> now. This is because Wikimedia production isn't ready quite yet. This is
> being tracked at T172165[0]. We will be moving the REL1_31 branch to 7.0+
> as the required minimum version. Once production is ready, we'll
> forward-port this change to master. It should be a little inconvenient, but
> not too terribly bad (and notably, makes life less stressful for our SREs).
> In the meantime, please do NOT introduce changes to master that require
> 7.0+ for core, vendor, or WMF-deployed extensions & skins. Doing so will
> make me sad :(
>
> Otherwise, great job on 1.31.x everyone! I'm rather pleased with what I'm
> seeing so far. Check out the workboard[1] for ways you can contribute to
> getting it wrapped up (and as always, tag issues with that tag if they
> should absolutely block release).
>
> Have a fantastic weekend!
>
> -Chad
>
> [0] https://phabricator.wikimedia.org/T172165
> [1] https://phabricator.wikimedia.org/project/view/3011/
> _______________________________________________
> Wikitech-l mailing list
> [hidden email]
> https://lists.wikimedia.org/mailman/listinfo/wikitech-l
_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l