MediaWiki Language Extension Bundle 2019.10 release

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

MediaWiki Language Extension Bundle 2019.10 release

Kartik Mistry
Hello all,

I would like to announce the release of MediaWiki Language Extension
Bundle 2019.10. This bundle is compatible with MediaWiki 1.32 or above
and requires PHP 7.1 or above.

Next MLEB is expected to be released in 3 months. If there are very
important bug fixes, we will do an intermediate release. Please give
us your feedback at
[[Talk:MLEB|https://www.mediawiki.org/wiki/Talk:MLEB]].

* Download: https://translatewiki.net/mleb/MediaWikiLanguageExtensionBundle-2019.10.tar.bz2
* sha256sum: b7d6afdb365c7333829ab5b4e286c2f28e3a5f6f48d1584c1f43439e74a60de6
* Signature: https://translatewiki.net/mleb/MediaWikiLanguageExtensionBundle-2019.10.tar.bz2.asc

Quick links:
* Installation instructions are at: https://www.mediawiki.org/wiki/MLEB
* Announcements of new releases will be posted to a mailing list:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-i18n
* Report bugs to: https://phabricator.wikimedia.org/
* Talk with us at: #mediawiki-i18n @ Freenode

Release notes for each extension are below.

-- Kartik Mistry

== Highlights and upgrade notes ==
MLEB 2019.10 now requires PHP 7.1. There are plans to move to PHP 7.2
for the next MLEB release.

== Babel, CleanChanges and cldr ==
* Localisation and maintenance updates only.

== LocalisationUpdate ==
* Dropped PHP message file support, since MediaWiki > 1.30 is now required.

== Translate ==
* Translate extension now requires PHP 7.1.x and has dropped support for HHVM.
* PHP entry point has been deprecated. To load the Translate
extension, please use the following,
<pre>
wfLoadExtension( 'Translate' );
</pre>

=== Noteworthy changes ===
* Removed deprecated and unmaintained SolrTTMServer. Recommendation is
to migrate to ElasticSearch. ([https://phabricator.wikimedia.orgT87985
Phab:T87985])
* Universal Language Selector is no longer listed as composer
dependency. Make sure you have Universal Language Selector installed
by other means.
* Fixed regression that broke saving translations.
([https://phabricator.wikimedia.org/T233200 Phab:T233200])
* Fixed an issue that prevented moving translatable pages in namespace
without subpages. ([https://phabricator.wikimedia.org/T215202
Phab:T215202])
* Dropped support for HHVM.
* Avoid usage of deprecated <code>$wgContLang</code> global
([https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Translate/+/533738
Gerrit Patch])
* Fix expanding of multiple times nested groups on
Special:LanguageStats
([https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Translate/+/543459
Gerrit Patch])
* Removed <code>hr</code> element from page translation header
([https://phabricator.wikimedia.org/T220841 Phab:T220841])
* Implemented used X times in translation memory suggestions
([https://phabricator.wikimedia.org/T47686 Phab:T47686])
* Convert Translate to use extension registration
([https://phabricator.wikimedia.org/T87985 Phab:T87985])
* Page translation section names can no longer contain underscore or dash.
* Addition of new types of validators to check quality of translations
([https://phabricator.wikimedia.org/T231181 Phab:T231181],
[https://phabricator.wikimedia.org/T231707 Phab:T231707])
* Special:ManageMessageGroups gained support for renaming message keys.
* Various stability and performance improvements
([https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Translate/+/534571
1][https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Translate/+/538892
2])

== UniversalLanguageSelector ==
* Localisation and maintenance updates only.

--
Kartik Mistry | કાર્તિક મિસ્ત્રી
kartikm.wordpress.com

_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l