[MediaWiki-l] 1.26.2 : web updater displays index.php without styles and can't find an existing installation

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] 1.26.2 : web updater displays index.php without styles and can't find an existing installation

A. Johannsen, vij Koordination
Dear all,

I have a problem with updating mediawiki 1.18.1 to the current version
1.26.2.  Since I have no access to the command line, I am using the web
browser instead.

The problem is that index.php in mw-config is read, but it is displayed
without styles.  I am still able to select a language. But when I click
"continue", the next page is white.  The procedure doesn't find an
existing installation, even though a Localsettings.php exists in the
root directory.

Please help.

Many thanks,

Andreas


--
------------------------------------------------------------------------

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: 1.26.2 : web updater displays index.php without styles and can't find an existing installation

Benjamin Lees
Maybe your URL configuration is tripping it up.

What does the error log say? https://www.mediawiki.org/wiki/Manual:How_to_debug

On Wed, Apr 6, 2016 at 1:36 PM, A. Johannsen, vij Koordination
<[hidden email]> wrote:

> Dear all,
>
> I have a problem with updating mediawiki 1.18.1 to the current version
> 1.26.2.  Since I have no access to the command line, I am using the web
> browser instead.
>
> The problem is that index.php in mw-config is read, but it is displayed
> without styles.  I am still able to select a language. But when I click
> "continue", the next page is white.  The procedure doesn't find an existing
> installation, even though a Localsettings.php exists in the root directory.
>
> Please help.
>
> Many thanks,
>
> Andreas
>
>
> --
> ------------------------------------------------------------------------
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: 1.26.2 : web updater displays index.php without styles and can't find an existing installation

Tobias Oetterer
Also, skin handling has changed since 1.24.

See https://www.mediawiki.org/wiki/Manual:Skin_configuration
And https://www.mediawiki.org/wiki/Manual:Skin_autodiscovery


Regards,
Tobias

--
If this email is rather brief, it is not meant to be impolite but to respect your time.
http://five.sentenc.es
No trees were killed to send this message, but a large number of electrons were terribly inconvenienced

University of Paderborn
Zentrum IMT
Warburger Straße 100
33098 Paderborn

Office: N5.341
Phone: 05251/60-2194
Internet: http://imt.uni-paderborn.de
-----Ursprüngliche Nachricht-----
Von: MediaWiki-l [mailto:[hidden email]] Im Auftrag von Benjamin Lees
Gesendet: Donnerstag, 7. April 2016 08:38
An: MediaWiki announcements and site admin list
Betreff: Re: [MediaWiki-l] 1.26.2 : web updater displays index.php without styles and can't find an existing installation

Maybe your URL configuration is tripping it up.

What does the error log say? https://www.mediawiki.org/wiki/Manual:How_to_debug

On Wed, Apr 6, 2016 at 1:36 PM, A. Johannsen, vij Koordination <[hidden email]> wrote:

> Dear all,
>
> I have a problem with updating mediawiki 1.18.1 to the current version
> 1.26.2.  Since I have no access to the command line, I am using the
> web browser instead.
>
> The problem is that index.php in mw-config is read, but it is
> displayed without styles.  I am still able to select a language. But
> when I click "continue", the next page is white.  The procedure
> doesn't find an existing installation, even though a Localsettings.php exists in the root directory.
>
> Please help.
>
> Many thanks,
>
> Andreas
>
>
> --
> ----------------------------------------------------------------------
> --
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] 1.26.2 : web updater displays index.php without styles and can't find an existing installation

A. Johannsen, vij Koordination
Benjamin and Tobias: thanks for your replies.

This is the first time that I do an update of my wiki and therefore I am
still not clear about what really goes on when I run index.php in
mw-config.  To my mind there are two problems in my case, which may or
may not be related:

1. index.php is displayed without styles
2. the routine doesn't see the existing installation

1. Styles:
Does it really matter, what skins are in defined in LocalSettings.php?
As far as I understand it, LocalSettings.php is not executed during the
upgrade process.  Only its existence matters, as it implies that I want
to upgrade my existing wiki.  If it were read, why would I have to
supply information about the database, when this information is stored
in LocalSettings.php and the upgrader could read it itself.  I thought
that the styles needed to display index.php properly were stored in
mw-config and in its subdirectory, images.

2. locating files
Again, I am not clear about what the routine does. To my mind, the
upgrader should look into the parent-directory of mw-config, ie. the
root directory, and should look for LocalSettings.php.  The file is
there, I can see it, but the routine can't.  Why?

And finally, are the two problems related?

Thanks,
Andreas



Am 07.04.2016 um 09:20 schrieb Tobias Oetterer:

> Also, skin handling has changed since 1.24.
>
> See https://www.mediawiki.org/wiki/Manual:Skin_configuration
> And https://www.mediawiki.org/wiki/Manual:Skin_autodiscovery
>
>
> Regards,
> Tobias
>
> --
> If this email is rather brief, it is not meant to be impolite but to respect your time.
> http://five.sentenc.es
> No trees were killed to send this message, but a large number of electrons were terribly inconvenienced
>
> University of Paderborn
> Zentrum IMT
> Warburger Straße 100
> 33098 Paderborn
>
> Office: N5.341
> Phone: 05251/60-2194
> Internet: http://imt.uni-paderborn.de
> -----Ursprüngliche Nachricht-----
> Von: MediaWiki-l [mailto:[hidden email]] Im Auftrag von Benjamin Lees
> Gesendet: Donnerstag, 7. April 2016 08:38
> An: MediaWiki announcements and site admin list
> Betreff: Re: [MediaWiki-l] 1.26.2 : web updater displays index.php without styles and can't find an existing installation
>
> Maybe your URL configuration is tripping it up.
>
> What does the error log say? https://www.mediawiki.org/wiki/Manual:How_to_debug
>
> On Wed, Apr 6, 2016 at 1:36 PM, A. Johannsen, vij Koordination <[hidden email]> wrote:
>> Dear all,
>>
>> I have a problem with updating mediawiki 1.18.1 to the current version
>> 1.26.2.  Since I have no access to the command line, I am using the
>> web browser instead.
>>
>> The problem is that index.php in mw-config is read, but it is
>> displayed without styles.  I am still able to select a language. But
>> when I click "continue", the next page is white.  The procedure
>> doesn't find an existing installation, even though a Localsettings.php exists in the root directory.
>>
>> Please help.
>>
>> Many thanks,
>>
>> Andreas
>>
>>
>> --
>> ----------------------------------------------------------------------
>> --
>>
>> _______________________________________________
>> MediaWiki-l mailing list
>> To unsubscribe, go to:
>> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

--
------------------------------------------------------------------------
i.A.
Andreas Johannsen,
Koordination

Verein für Internationale Jugendarbeit
Frankfurt am Main e.V.

Lindenstraße 16
61440 Oberursel

Telefon: 06171 - 508 2012
Fax: 06171 - 508 2016
E-Mail: [hidden email] <mailto:[hidden email]>
Internet: www.vij-frankfurt.de <http://www.vij-frankfurt.de>



_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] 1.26.2 : web updater displays index.php without styles and can't find an existing installation -- solved

A. Johannsen, vij Koordination
I found two errors in my LocalSettings.php:

1. I tried to load an extension, whose files I hadn't downloaded. This
was the reason for the updater to stop at the second page.

2. the following line was commented out:
     $wgCacheDirectory = "$IP/cache";
     for an explanation, see:
http://serverfault.com/questions/743898/mediawiki-not-displaying-style-internal-error 


Best wishes,
Andreas



_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l