[MediaWiki-l] Email problem following 1.16 to 1.25 conversion

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Email problem following 1.16 to 1.25 conversion

Cal Frye
Hi,

We did a migration and conversion from v.1.16 to 1.25.3 on a new server,
using XAMPP as our base. Generally, it worked well, thanks for that!

We have a lingering problem, however, in sending email, including
confirmation messages, password resets, etc. No mail is sent, and the
error, "Unknown error in PHP's mail() function." is returned.

Google suggests two small changes in the UserMailer.php file, both
having to do with the $headers variable. Neither fix works, however, in
our case. I've scanned the archives of this list back to January, and
didn't see anything there that seemed like this problem.

Can anyone point me in the right direction? Many thanks!

Cal Frye

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Email problem following 1.16 to 1.25 conversion

Paladox
Hi quick questions did you also update xampp since updating that may fix problem. Also what php version are you using. MediaWiki 1.25 supports php 5.3 or higher. And also in your local settings.php file you may need to either regenerate it so that it is much easier to update meaning you re generate the local settings file then copying it over to the localsettings.php file. Also removed when regenerating it by going to the sub folder w-config that localsettings.php should be temporary renamed so localsettings.php can be regenerated. Then rename file back and copy over from the new file to the old.
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Email problem following 1.16 to 1.25 conversion

Platonides
In reply to this post by Cal Frye
Cal Frye wrote:
> Hi,
>
> We did a migration and conversion from v.1.16 to 1.25.3 on a new server,
> using XAMPP as our base. Generally, it worked well, thanks for that!
>
> We have a lingering problem, however, in sending email, including
> confirmation messages, password resets, etc. No mail is sent, and the
> error, "Unknown error in PHP's mail() function." is returned.

Is php mail() working on your new server?
Maybe there's some package/configuration missing in your _server_
configuration.

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l