[MediaWiki-l] HTTP ERROR 500" error on "&redirect=no" link

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] HTTP ERROR 500" error on "&redirect=no" link

rkevans
Hey guys,

I have a fresh install of MW 1.30 on a RHEL7 system that works great in every way except that clicking on a redirect link (page with &redirect=no) results in an Apache "HTTP ERROR 500" error.

The page actually redirects fine when visited normally. The problem is only when I try to click on the page link page which suppresses the actual redirect function (ala the &redirect=no parameter).

Interestingly... through tinkering in MySQL, I have discovered that if I set the wiki database "page" table column "page_is_redirect" from '1' to '0' the page works fine (albeit with no redirect). So the suppressed redirect ability is possible.

My guess is that some php code parses the "redirect=no" data from the URL and masks the value of the "page_is_redirect" to "0" no matter what value it actually is.. So what could cause this "HTTP ERROR 500" error then?

Everything else works perfectly. What file or folder would be unique to a link processed  with a "&redirect=no" in the URL?

Thanks!
-Rich


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: HTTP ERROR 500" error on "&redirect=no" link

Huji Lee
Whenever you see a 500 error, you need to look at the error trace to see
what went wrong where. See
https://www.mediawiki.org/wiki/Manual:How_to_debug to learn how to make
your web server show you the error details, and where to find the error log
file. Then report back here so we can help you fix the bug.

On Thu, May 24, 2018 at 2:36 PM, Evans, Richard K. (GRC-H000) <
[hidden email]> wrote:

> Hey guys,
>
> I have a fresh install of MW 1.30 on a RHEL7 system that works great in
> every way except that clicking on a redirect link (page with &redirect=no)
> results in an Apache "HTTP ERROR 500" error.
>
> The page actually redirects fine when visited normally. The problem is
> only when I try to click on the page link page which suppresses the actual
> redirect function (ala the &redirect=no parameter).
>
> Interestingly... through tinkering in MySQL, I have discovered that if I
> set the wiki database "page" table column "page_is_redirect" from '1' to
> '0' the page works fine (albeit with no redirect). So the suppressed
> redirect ability is possible.
>
> My guess is that some php code parses the "redirect=no" data from the URL
> and masks the value of the "page_is_redirect" to "0" no matter what value
> it actually is.. So what could cause this "HTTP ERROR 500" error then?
>
> Everything else works perfectly. What file or folder would be unique to a
> link processed  with a "&redirect=no" in the URL?
>
> Thanks!
> -Rich
>
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: HTTP ERROR 500" error on "&redirect=no" link

rkevans
Indeed. What was I thinking.. Thank you!

The source of the HTTP 500 error is:
Fatal error: Class 'WhoIsWatching\Article' not found in /opt/htdocs/mediawiki/extensions/WhoIsWatching/src/Hook.php on line 40

I will handle it from here. Thank you!
-Rich

-----Original Message-----
From: MediaWiki-l [mailto:[hidden email]] On Behalf Of Huji Lee
Sent: Thursday, May 24, 2018 2:45 PM
To: MediaWiki announcements and site admin list
Subject: Re: [MediaWiki-l] HTTP ERROR 500" error on "&redirect=no" link

Whenever you see a 500 error, you need to look at the error trace to see what went wrong where. See https://www.mediawiki.org/wiki/Manual:How_to_debug to learn how to make your web server show you the error details, and where to find the error log file. Then report back here so we can help you fix the bug.

On Thu, May 24, 2018 at 2:36 PM, Evans, Richard K. (GRC-H000) < [hidden email]> wrote:

> Hey guys,
>
> I have a fresh install of MW 1.30 on a RHEL7 system that works great
> in every way except that clicking on a redirect link (page with
> &redirect=no) results in an Apache "HTTP ERROR 500" error.
>
> The page actually redirects fine when visited normally. The problem is
> only when I try to click on the page link page which suppresses the
> actual redirect function (ala the &redirect=no parameter).
>
> Interestingly... through tinkering in MySQL, I have discovered that if
> I set the wiki database "page" table column "page_is_redirect" from
> '1' to '0' the page works fine (albeit with no redirect). So the
> suppressed redirect ability is possible.
>
> My guess is that some php code parses the "redirect=no" data from the
> URL and masks the value of the "page_is_redirect" to "0" no matter
> what value it actually is.. So what could cause this "HTTP ERROR 500" error then?
>
> Everything else works perfectly. What file or folder would be unique
> to a link processed  with a "&redirect=no" in the URL?
>
> Thanks!
> -Rich
>
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l