[MediaWiki-l] Highest PHP version with MW v1.26.3

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Highest PHP version with MW v1.26.3

Daryl Rose
What is the highest version of php I can use with MW v1.26.3?

Thank you.

Daryl
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Highest PHP version with MW v1.26.3

Bartosz Dziewoński
On 2018-01-04 14:42, Daryl Rose wrote:
> What is the highest version of php I can use with MW v1.26.3?

According to https://www.mediawiki.org/wiki/Compatibility#PHP ,
PHP 5.6.x is the highest compatible version.

Only MediaWiki 1.27 and later is supported on PHP 7+.


--
Bartosz Dziewoński

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Highest PHP version with MW v1.26.3

Daryl Rose
Thank you for the link and the reply.

I finally found that link myself after I posted this question.  I'll be
honest, finding information on mediawiki.org is rather difficult. Sometimes
I have to look for information under FAQ, sometimes in Technical Manual,
sometimes in User Help and sometimes there is no direct entry in either of
those and I have to drill to what I'm looking for via another section.
 For example, migrating from one environment to another I find "How do I
move my wiki to a different server?".  I click on that link, then I have to
follow "Manual:Moving a wiki".  It took me a long time to find the
compatibility list.  I finally looked in "Upgrade" which took me to "Check
Requirements" where I finally found a compatibility list.  I personally
would think that the compatibility list should be very prominent in the
user manual, or FAQ.  Not something a person should have to dig for.

Just my 2 cents.

Thank you.

Daryl

On Sun, Jan 7, 2018 at 7:22 AM, Bartosz Dziewoński <[hidden email]>
wrote:

> On 2018-01-04 14:42, Daryl Rose wrote:
>
>> What is the highest version of php I can use with MW v1.26.3?
>>
>
> According to https://www.mediawiki.org/wiki/Compatibility#PHP ,
> PHP 5.6.x is the highest compatible version.
>
> Only MediaWiki 1.27 and later is supported on PHP 7+.
>
>
> --
> Bartosz Dziewoński
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l