Quantcast

[MediaWiki-l] Increase MediaWiki minimum supported MySQL version to 5.5

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[MediaWiki-l] Increase MediaWiki minimum supported MySQL version to 5.5

Sam Reed-2
[Crossposted to wikitech-l and mediawiki-l]

MediaWiki supports MySQL 5.0.3 (which was released back in 2005-03-23), and this is somewhat of a blocker to MediaWiki development, and is also meaning we're missing out on taking for granted that various features will be there for use. Or having to do conditional support, with more potential drawbacks.

I started a discussion [1] as to bumping the MySQL version, and it seems that selecting the 5.5 branch of MySQL (specifically, 5.5.8, released 2010-12-03 [2]) is gathering support.

This should hopefully be less of a controversial "bump" than the PHP 5.5 bump was, as hosting providers seem to keep more up to date with MySQL versions. From data gathered from wikiapiary, 90% of wikis running PHP 5.5 (ie new enough to run the latest and greatest MediaWiki release) are running MySQL 5.5 or newer.

This email serves as the initial announcement of taking this forward, and feedback is requested on [1] before this is taken forward to an RfC meeting in the near future


-- Reedy


[1] https://phabricator.wikimedia.org/T161232
[2] https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-8.html

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Loading...