[MediaWiki-l] MediaWiki 1.33 is End of Life

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] MediaWiki 1.33 is End of Life

reedy
As per the MediaWiki version lifecycle [1], I would like to announce the
formal end of life (EOL) of MediaWiki 1.33 as of next week, Tuesday June
30, 2020.

This means that MediaWiki 1.33 will no longer receive maintenance or
security backports (barring an unforseen issues with the 1.33.4 release
today). It is therefore strongly discouraged that you continue to use it.

It is recommended to upgrade to MediaWiki 1.34 (due to become EOL in
November 2020). The current Long Term Support (LTS) version of MediaWiki,
MediaWiki 1.31, is however older (and downgrading is not supported. The
delayed next LTS (MediaWiki 1.35) is currently due to be released in early
August 2020, and will be supported until at least June 2023.

MediaWiki 1.34 bumps the required PHP version from 7.0 in 1.33 (which is
unsupported upstream), to PHP 7.2.9 or later.

Thanks!


Sam Reed

[1] https://www.mediawiki.org/wiki/Version_lifecycle
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l