[MediaWiki-l] MediaWiki is not running

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] MediaWiki is not running

Brenton Horne
Hi,

I'm presently running Ubuntu 14.04 32 bit and I installed MediaWiki 1.24.1
via bitnami and it worked fine until I restarted my PC and now, even with
my servers (Apache & MySQL, respectively) running (which I checked were
running by running the manager-linux.run file in the MediaWiki directory. I
even restarted them both manually) whenever I open up
http://localhost:8080/mediawiki/ I get a blank page. Going to
http://localhost:8080/ or http://localhost:8080/phpmyadmin works fine and
these pages load perfectly.

Thanks for your time,
Brenton
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki is not running

John Doe-27
Odds are bitnami broke something.

Many Linux distributions provide MediaWiki in a packaged format for that
distro. These packages typically contain obsolete & unsupported versions of
MediaWiki; they also like to move around & change files, & do other
super-counterproductive things. You'll get the best support here if you
install MediaWiki directly from one of our tarballs -
https://www.mediawiki.org/ - or Git
https://www.mediawiki.org/wiki/Download_from_Git

On Wed, Feb 4, 2015 at 8:50 AM, Brenton Horne <[hidden email]>
wrote:

> Hi,
>
> I'm presently running Ubuntu 14.04 32 bit and I installed MediaWiki 1.24.1
> via bitnami and it worked fine until I restarted my PC and now, even with
> my servers (Apache & MySQL, respectively) running (which I checked were
> running by running the manager-linux.run file in the MediaWiki directory. I
> even restarted them both manually) whenever I open up
> http://localhost:8080/mediawiki/ I get a blank page. Going to
> http://localhost:8080/ or http://localhost:8080/phpmyadmin works fine and
> these pages load perfectly.
>
> Thanks for your time,
> Brenton
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki is not running

Brenton Horne
I'd love to but every time I've installed it from the tarballs in the past
I end up failing miserably. I installed LAMP, I followed all the
instructions online I could find but I failed on Windows and Ubuntu. This
is why I used bitnami as a last resort.

On 5 February 2015 at 01:33, John <[hidden email]> wrote:

> Odds are bitnami broke something.
>
> Many Linux distributions provide MediaWiki in a packaged format for that
> distro. These packages typically contain obsolete & unsupported versions of
> MediaWiki; they also like to move around & change files, & do other
> super-counterproductive things. You'll get the best support here if you
> install MediaWiki directly from one of our tarballs -
> https://www.mediawiki.org/ - or Git
> https://www.mediawiki.org/wiki/Download_from_Git
>
> On Wed, Feb 4, 2015 at 8:50 AM, Brenton Horne <[hidden email]>
> wrote:
>
> > Hi,
> >
> > I'm presently running Ubuntu 14.04 32 bit and I installed MediaWiki
> 1.24.1
> > via bitnami and it worked fine until I restarted my PC and now, even with
> > my servers (Apache & MySQL, respectively) running (which I checked were
> > running by running the manager-linux.run file in the MediaWiki
> directory. I
> > even restarted them both manually) whenever I open up
> > http://localhost:8080/mediawiki/ I get a blank page. Going to
> > http://localhost:8080/ or http://localhost:8080/phpmyadmin works fine
> and
> > these pages load perfectly.
> >
> > Thanks for your time,
> > Brenton
> > _______________________________________________
> > MediaWiki-l mailing list
> > To unsubscribe, go to:
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki is not running

Jonathan Aquilina
I use MAMP (mac equivalent) and the reason you have to put in a port number
is that the default port 80 is used your web browser and if I am not
mistaken you wont be able to do any day to day browsing. Putting apache on
a particular non standard port allows you to run the site on ones local
machine for testing and development.

On Wed, Feb 4, 2015 at 4:53 PM, Brenton Horne <[hidden email]>
wrote:

> I'd love to but every time I've installed it from the tarballs in the past
> I end up failing miserably. I installed LAMP, I followed all the
> instructions online I could find but I failed on Windows and Ubuntu. This
> is why I used bitnami as a last resort.
>
> On 5 February 2015 at 01:33, John <[hidden email]> wrote:
>
> > Odds are bitnami broke something.
> >
> > Many Linux distributions provide MediaWiki in a packaged format for that
> > distro. These packages typically contain obsolete & unsupported versions
> of
> > MediaWiki; they also like to move around & change files, & do other
> > super-counterproductive things. You'll get the best support here if you
> > install MediaWiki directly from one of our tarballs -
> > https://www.mediawiki.org/ - or Git
> > https://www.mediawiki.org/wiki/Download_from_Git
> >
> > On Wed, Feb 4, 2015 at 8:50 AM, Brenton Horne <[hidden email]>
> > wrote:
> >
> > > Hi,
> > >
> > > I'm presently running Ubuntu 14.04 32 bit and I installed MediaWiki
> > 1.24.1
> > > via bitnami and it worked fine until I restarted my PC and now, even
> with
> > > my servers (Apache & MySQL, respectively) running (which I checked were
> > > running by running the manager-linux.run file in the MediaWiki
> > directory. I
> > > even restarted them both manually) whenever I open up
> > > http://localhost:8080/mediawiki/ I get a blank page. Going to
> > > http://localhost:8080/ or http://localhost:8080/phpmyadmin works fine
> > and
> > > these pages load perfectly.
> > >
> > > Thanks for your time,
> > > Brenton
> > > _______________________________________________
> > > MediaWiki-l mailing list
> > > To unsubscribe, go to:
> > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> > >
> > _______________________________________________
> > MediaWiki-l mailing list
> > To unsubscribe, go to:
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>



--
Jonathan Aquilina
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki is not running

John Doe-27
In reply to this post by Brenton Horne
I am currently walking someone thru the install process if you want to hop
on to  irc://freenode/mediawiki

On Wed, Feb 4, 2015 at 10:53 AM, Brenton Horne <[hidden email]>
wrote:

> I'd love to but every time I've installed it from the tarballs in the past
> I end up failing miserably. I installed LAMP, I followed all the
> instructions online I could find but I failed on Windows and Ubuntu. This
> is why I used bitnami as a last resort.
>
> On 5 February 2015 at 01:33, John <[hidden email]> wrote:
>
> > Odds are bitnami broke something.
> >
> > Many Linux distributions provide MediaWiki in a packaged format for that
> > distro. These packages typically contain obsolete & unsupported versions
> of
> > MediaWiki; they also like to move around & change files, & do other
> > super-counterproductive things. You'll get the best support here if you
> > install MediaWiki directly from one of our tarballs -
> > https://www.mediawiki.org/ - or Git
> > https://www.mediawiki.org/wiki/Download_from_Git
> >
> > On Wed, Feb 4, 2015 at 8:50 AM, Brenton Horne <[hidden email]>
> > wrote:
> >
> > > Hi,
> > >
> > > I'm presently running Ubuntu 14.04 32 bit and I installed MediaWiki
> > 1.24.1
> > > via bitnami and it worked fine until I restarted my PC and now, even
> with
> > > my servers (Apache & MySQL, respectively) running (which I checked were
> > > running by running the manager-linux.run file in the MediaWiki
> > directory. I
> > > even restarted them both manually) whenever I open up
> > > http://localhost:8080/mediawiki/ I get a blank page. Going to
> > > http://localhost:8080/ or http://localhost:8080/phpmyadmin works fine
> > and
> > > these pages load perfectly.
> > >
> > > Thanks for your time,
> > > Brenton
> > > _______________________________________________
> > > MediaWiki-l mailing list
> > > To unsubscribe, go to:
> > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> > >
> > _______________________________________________
> > MediaWiki-l mailing list
> > To unsubscribe, go to:
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki is not running

chris tharp-2
In reply to this post by Brenton Horne
Hi Brenton,

I use Bitnami, via the Amazon cloud, and have it found it to be the way to
go. I suggest you switch to the Amazon cloud, it's free for the first year,
as I recall, if you're small. Bitnami has a great and easy to use interface
that you can turn on, off, clone, and create backups of your server on the
Amazon cloud. To deploy an application, like Mediawiki, it's a GUI button
interface that takes all of a few minutes. Since it's on the cloud you can
turn off the server when you're not working on designing your new wiki. The
only pain you'll have, like everyone else, is when you need to do an
update, but that shouldn't be an issue for a while.

On Wed, Feb 4, 2015 at 7:53 AM, Brenton Horne <[hidden email]>
wrote:

> I'd love to but every time I've installed it from the tarballs in the past
> I end up failing miserably. I installed LAMP, I followed all the
> instructions online I could find but I failed on Windows and Ubuntu. This
> is why I used bitnami as a last resort.
>
> On 5 February 2015 at 01:33, John <[hidden email]> wrote:
>
> > Odds are bitnami broke something.
> >
> > Many Linux distributions provide MediaWiki in a packaged format for that
> > distro. These packages typically contain obsolete & unsupported versions
> of
> > MediaWiki; they also like to move around & change files, & do other
> > super-counterproductive things. You'll get the best support here if you
> > install MediaWiki directly from one of our tarballs -
> > https://www.mediawiki.org/ - or Git
> > https://www.mediawiki.org/wiki/Download_from_Git
> >
> > On Wed, Feb 4, 2015 at 8:50 AM, Brenton Horne <[hidden email]>
> > wrote:
> >
> > > Hi,
> > >
> > > I'm presently running Ubuntu 14.04 32 bit and I installed MediaWiki
> > 1.24.1
> > > via bitnami and it worked fine until I restarted my PC and now, even
> with
> > > my servers (Apache & MySQL, respectively) running (which I checked were
> > > running by running the manager-linux.run file in the MediaWiki
> > directory. I
> > > even restarted them both manually) whenever I open up
> > > http://localhost:8080/mediawiki/ I get a blank page. Going to
> > > http://localhost:8080/ or http://localhost:8080/phpmyadmin works fine
> > and
> > > these pages load perfectly.
> > >
> > > Thanks for your time,
> > > Brenton
> > > _______________________________________________
> > > MediaWiki-l mailing list
> > > To unsubscribe, go to:
> > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> > >
> > _______________________________________________
> > MediaWiki-l mailing list
> > To unsubscribe, go to:
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki is not running

Brenton Horne
In reply to this post by John Doe-27
@ John um where's the URL of this convo? I'd like to chime in but I'm not
familiar with IRC.

On 5 February 2015 at 02:09, John <[hidden email]> wrote:

> I am currently walking someone thru the install process if you want to hop
> on to  irc://freenode/mediawiki
>
> On Wed, Feb 4, 2015 at 10:53 AM, Brenton Horne <[hidden email]>
> wrote:
>
> > I'd love to but every time I've installed it from the tarballs in the
> past
> > I end up failing miserably. I installed LAMP, I followed all the
> > instructions online I could find but I failed on Windows and Ubuntu. This
> > is why I used bitnami as a last resort.
> >
> > On 5 February 2015 at 01:33, John <[hidden email]> wrote:
> >
> > > Odds are bitnami broke something.
> > >
> > > Many Linux distributions provide MediaWiki in a packaged format for
> that
> > > distro. These packages typically contain obsolete & unsupported
> versions
> > of
> > > MediaWiki; they also like to move around & change files, & do other
> > > super-counterproductive things. You'll get the best support here if you
> > > install MediaWiki directly from one of our tarballs -
> > > https://www.mediawiki.org/ - or Git
> > > https://www.mediawiki.org/wiki/Download_from_Git
> > >
> > > On Wed, Feb 4, 2015 at 8:50 AM, Brenton Horne <
> [hidden email]>
> > > wrote:
> > >
> > > > Hi,
> > > >
> > > > I'm presently running Ubuntu 14.04 32 bit and I installed MediaWiki
> > > 1.24.1
> > > > via bitnami and it worked fine until I restarted my PC and now, even
> > with
> > > > my servers (Apache & MySQL, respectively) running (which I checked
> were
> > > > running by running the manager-linux.run file in the MediaWiki
> > > directory. I
> > > > even restarted them both manually) whenever I open up
> > > > http://localhost:8080/mediawiki/ I get a blank page. Going to
> > > > http://localhost:8080/ or http://localhost:8080/phpmyadmin works
> fine
> > > and
> > > > these pages load perfectly.
> > > >
> > > > Thanks for your time,
> > > > Brenton
> > > > _______________________________________________
> > > > MediaWiki-l mailing list
> > > > To unsubscribe, go to:
> > > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> > > >
> > > _______________________________________________
> > > MediaWiki-l mailing list
> > > To unsubscribe, go to:
> > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> > >
> > _______________________________________________
> > MediaWiki-l mailing list
> > To unsubscribe, go to:
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki is not running

Brenton Horne
@Chris for me the prospect of having to pay after the first year is a
deterrent I'd like a system that is free and will remain free.

On 5 February 2015 at 02:18, Brenton Horne <[hidden email]> wrote:

> @ John um where's the URL of this convo? I'd like to chime in but I'm not
> familiar with IRC.
>
> On 5 February 2015 at 02:09, John <[hidden email]> wrote:
>
>> I am currently walking someone thru the install process if you want to hop
>> on to  irc://freenode/mediawiki
>>
>> On Wed, Feb 4, 2015 at 10:53 AM, Brenton Horne <[hidden email]>
>> wrote:
>>
>> > I'd love to but every time I've installed it from the tarballs in the
>> past
>> > I end up failing miserably. I installed LAMP, I followed all the
>> > instructions online I could find but I failed on Windows and Ubuntu.
>> This
>> > is why I used bitnami as a last resort.
>> >
>> > On 5 February 2015 at 01:33, John <[hidden email]> wrote:
>> >
>> > > Odds are bitnami broke something.
>> > >
>> > > Many Linux distributions provide MediaWiki in a packaged format for
>> that
>> > > distro. These packages typically contain obsolete & unsupported
>> versions
>> > of
>> > > MediaWiki; they also like to move around & change files, & do other
>> > > super-counterproductive things. You'll get the best support here if
>> you
>> > > install MediaWiki directly from one of our tarballs -
>> > > https://www.mediawiki.org/ - or Git
>> > > https://www.mediawiki.org/wiki/Download_from_Git
>> > >
>> > > On Wed, Feb 4, 2015 at 8:50 AM, Brenton Horne <
>> [hidden email]>
>> > > wrote:
>> > >
>> > > > Hi,
>> > > >
>> > > > I'm presently running Ubuntu 14.04 32 bit and I installed MediaWiki
>> > > 1.24.1
>> > > > via bitnami and it worked fine until I restarted my PC and now, even
>> > with
>> > > > my servers (Apache & MySQL, respectively) running (which I checked
>> were
>> > > > running by running the manager-linux.run file in the MediaWiki
>> > > directory. I
>> > > > even restarted them both manually) whenever I open up
>> > > > http://localhost:8080/mediawiki/ I get a blank page. Going to
>> > > > http://localhost:8080/ or http://localhost:8080/phpmyadmin works
>> fine
>> > > and
>> > > > these pages load perfectly.
>> > > >
>> > > > Thanks for your time,
>> > > > Brenton
>> > > > _______________________________________________
>> > > > MediaWiki-l mailing list
>> > > > To unsubscribe, go to:
>> > > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>> > > >
>> > > _______________________________________________
>> > > MediaWiki-l mailing list
>> > > To unsubscribe, go to:
>> > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>> > >
>> > _______________________________________________
>> > MediaWiki-l mailing list
>> > To unsubscribe, go to:
>> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>> >
>> _______________________________________________
>> MediaWiki-l mailing list
>> To unsubscribe, go to:
>> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>>
>
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki is not running

John Doe-27
https://webchat.freenode.net/ use the channel #mediawiki

On Wed, Feb 4, 2015 at 11:19 AM, Brenton Horne <[hidden email]>
wrote:

> @Chris for me the prospect of having to pay after the first year is a
> deterrent I'd like a system that is free and will remain free.
>
> On 5 February 2015 at 02:18, Brenton Horne <[hidden email]>
> wrote:
>
> > @ John um where's the URL of this convo? I'd like to chime in but I'm not
> > familiar with IRC.
> >
> > On 5 February 2015 at 02:09, John <[hidden email]> wrote:
> >
> >> I am currently walking someone thru the install process if you want to
> hop
> >> on to  irc://freenode/mediawiki
> >>
> >> On Wed, Feb 4, 2015 at 10:53 AM, Brenton Horne <
> [hidden email]>
> >> wrote:
> >>
> >> > I'd love to but every time I've installed it from the tarballs in the
> >> past
> >> > I end up failing miserably. I installed LAMP, I followed all the
> >> > instructions online I could find but I failed on Windows and Ubuntu.
> >> This
> >> > is why I used bitnami as a last resort.
> >> >
> >> > On 5 February 2015 at 01:33, John <[hidden email]> wrote:
> >> >
> >> > > Odds are bitnami broke something.
> >> > >
> >> > > Many Linux distributions provide MediaWiki in a packaged format for
> >> that
> >> > > distro. These packages typically contain obsolete & unsupported
> >> versions
> >> > of
> >> > > MediaWiki; they also like to move around & change files, & do other
> >> > > super-counterproductive things. You'll get the best support here if
> >> you
> >> > > install MediaWiki directly from one of our tarballs -
> >> > > https://www.mediawiki.org/ - or Git
> >> > > https://www.mediawiki.org/wiki/Download_from_Git
> >> > >
> >> > > On Wed, Feb 4, 2015 at 8:50 AM, Brenton Horne <
> >> [hidden email]>
> >> > > wrote:
> >> > >
> >> > > > Hi,
> >> > > >
> >> > > > I'm presently running Ubuntu 14.04 32 bit and I installed
> MediaWiki
> >> > > 1.24.1
> >> > > > via bitnami and it worked fine until I restarted my PC and now,
> even
> >> > with
> >> > > > my servers (Apache & MySQL, respectively) running (which I checked
> >> were
> >> > > > running by running the manager-linux.run file in the MediaWiki
> >> > > directory. I
> >> > > > even restarted them both manually) whenever I open up
> >> > > > http://localhost:8080/mediawiki/ I get a blank page. Going to
> >> > > > http://localhost:8080/ or http://localhost:8080/phpmyadmin works
> >> fine
> >> > > and
> >> > > > these pages load perfectly.
> >> > > >
> >> > > > Thanks for your time,
> >> > > > Brenton
> >> > > > _______________________________________________
> >> > > > MediaWiki-l mailing list
> >> > > > To unsubscribe, go to:
> >> > > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >> > > >
> >> > > _______________________________________________
> >> > > MediaWiki-l mailing list
> >> > > To unsubscribe, go to:
> >> > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >> > >
> >> > _______________________________________________
> >> > MediaWiki-l mailing list
> >> > To unsubscribe, go to:
> >> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >> >
> >> _______________________________________________
> >> MediaWiki-l mailing list
> >> To unsubscribe, go to:
> >> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >>
> >
> >
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: MediaWiki is not running

Jan Steinman
In reply to this post by John Doe-27
> From: Jonathan Aquilina <[hidden email]>
>
> ... the reason you have to put in a port number
> is that the default port 80 is used your web browser and if I am not
> mistaken you wont be able to do any day to day browsing.

Not so. Ports below 1024 are reserved for well-known services. Your web browser uses an arbitrary open port with four or more digits. You can easily run both a server and a browser on the same machine.

:::: It’s fair to say that human beings, like yeast, respond to increased access to energy with increased reproduction. -- John Michael Greer
:::: Jan Steinman, EcoReality Co-op ::::


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l