[MediaWiki-l] PHP errors on 1.27

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] PHP errors on 1.27

Milov Patel
Getting the following errors as shown in the apache log, when trying to
access the php file from the url its throwing a 500 error

PHP Fatal error: Interface 'LocalisationUpdate\\Reader' not found
PHP Fatal error: Class 'ApiBase' not found

ProductVersion
MediaWiki <https://www.mediawiki.org/> 1.27.0
PHP <https://php.net/> 5.5.9-1ubuntu4.17 (apache2handler)
MySQL <https://www.mysql.com/> 5.5.49-0ubuntu0.14.04.1
ICU <http://site.icu-project.org/> 52.1
Lua <http://www.lua.org/> 5.1.5
Any ideas on what could be driving this?
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: PHP errors on 1.27

Brian Wolff
It sounds like something is seriously messed up with class autoloading
or maybe some of your MediaWiki files are missing.

LocalisationUpdate\\Reader is part of the LocalisationUpdate
extension. ApiBase (includes/api/ApiBase.php) is part of MediaWiki
core.

I would suggest re-installing MediaWiki (in a fresh directory) and
seeing if that fixes it (If you need to keep the data in your current
install, be sure to copy over the LocalSettings.php file, the images
subdirectory and maybe the extensions subdirectory).

Also, I would note that MediaWiki 1.27.0 is rather outdated and has
publically known security issues. 1.27.4 is the latest release of the
1.27 series.

--
Brian

On Fri, Apr 20, 2018 at 1:54 AM, Milov Patel <[hidden email]> wrote:

> Getting the following errors as shown in the apache log, when trying to
> access the php file from the url its throwing a 500 error
>
> PHP Fatal error: Interface 'LocalisationUpdate\\Reader' not found
> PHP Fatal error: Class 'ApiBase' not found
>
> ProductVersion
> MediaWiki <https://www.mediawiki.org/> 1.27.0
> PHP <https://php.net/> 5.5.9-1ubuntu4.17 (apache2handler)
> MySQL <https://www.mysql.com/> 5.5.49-0ubuntu0.14.04.1
> ICU <http://site.icu-project.org/> 52.1
> Lua <http://www.lua.org/> 5.1.5
> Any ideas on what could be driving this?
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l