[MediaWiki-l] Please lower MySQL requirements in next release

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Please lower MySQL requirements in next release

Jeffrey Walton
We use CentOS 7. Red Hat supplies antique software. It offers Media
wiki 1.21, if I recall correctly. It is what it is. We had to take on
maintenance of Mediawiki because we wanted to offer newer features
users. Skins and extensions sometimes need something newer than what
the platform provides.

We've managed to update Apache, Python and PHP using SCL
(https://wiki.centos.org/AdditionalResources/Repositories/SCL).
However, we cannot get the MySQL update to work. We are stuck at MySQL
5.5.60. MySQL 5.5.60 was released April 2018.

We can't upgrade to to MW 1.31 due to CentOS's MySQL. We tried to
install MW 1.31 but maintenance/update.sh died when trying to update
the database. We had to go to backup and restore the installation.

It is not just CentOS. Other OSes, like Ubuntu 14 LTS, are boxing
users. For example Ubuntu 14 provides MySQL 5.5.62
(https://packages.ubuntu.com/search?keywords=mysql-server). MySQL
5.5.62 was released October 2018.

Earlier I said "We've managed to update Apache, Python and PHP...".
SCL does not offer Composer. Composer is an entirely new set of
hardships. SCL probably does not offer Composer because dev tools have
no business being on a production server. While you may think
'composer update' is easy, it took us a day and a half to work around
all the problems and exceptions.

Please consider lowering the MySQL requirements. Most helpful would be
to lower and freeze all requirements for the next 3 or 5 years. A
requirements freeze would allow us (and other users) to upgrade
Mediawiki without the hassles and aggravations.

Thanks in advance.

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Please lower MySQL requirements in next release

John Doe-27
I hate to be a downer (I’m normally the one complaining about said updates
breaking stuf$ but realistically major version bumps are needed. Ubuntu
14.04 is almost 5 years old and only has 4 more months of support. MySQL
5.5.x went EOL 3 years ago. You want to push support past that? CentOS to
my knowledge is the only major distro with issues supporting newer versions
of mediawiki. Mediawiki provides support for their LTS releases for 3
years, and releases them about every two years. Forcing mediawiki devs to
keep the same requirements for 6+ years is not reasonable. I will also note
that if CentOS is shipping with mediawiki 1.21 they are doing it wrong that
branch is 6+ years old.

On Sat, Dec 22, 2018 at 11:17 AM Jeffrey Walton <[hidden email]> wrote:

> We use CentOS 7. Red Hat supplies antique software. It offers Media
> wiki 1.21, if I recall correctly. It is what it is. We had to take on
> maintenance of Mediawiki because we wanted to offer newer features
> users. Skins and extensions sometimes need something newer than what
> the platform provides.
>
> We've managed to update Apache, Python and PHP using SCL
> (https://wiki.centos.org/AdditionalResources/Repositories/SCL).
> However, we cannot get the MySQL update to work. We are stuck at MySQL
> 5.5.60. MySQL 5.5.60 was released April 2018.
>
> We can't upgrade to to MW 1.31 due to CentOS's MySQL. We tried to
> install MW 1.31 but maintenance/update.sh died when trying to update
> the database. We had to go to backup and restore the installation.
>
> It is not just CentOS. Other OSes, like Ubuntu 14 LTS, are boxing
> users. For example Ubuntu 14 provides MySQL 5.5.62
> (https://packages.ubuntu.com/search?keywords=mysql-server). MySQL
> 5.5.62 was released October 2018.
>
> Earlier I said "We've managed to update Apache, Python and PHP...".
> SCL does not offer Composer. Composer is an entirely new set of
> hardships. SCL probably does not offer Composer because dev tools have
> no business being on a production server. While you may think
> 'composer update' is easy, it took us a day and a half to work around
> all the problems and exceptions.
>
> Please consider lowering the MySQL requirements. Most helpful would be
> to lower and freeze all requirements for the next 3 or 5 years. A
> requirements freeze would allow us (and other users) to upgrade
> Mediawiki without the hassles and aggravations.
>
> Thanks in advance.
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Please lower MySQL requirements in next release

Ryan Schmidt-76
Try installing MariaDB instead of MySQL. It is a drop-in replacement and the version available in CentOS 7 is recent enough to run modern MediaWiki once you enable the MariaDB yum repo.

> On Dec 22, 2018, at 9:44 AM, John <[hidden email]> wrote:
>
> I hate to be a downer (I’m normally the one complaining about said updates
> breaking stuf$ but realistically major version bumps are needed. Ubuntu
> 14.04 is almost 5 years old and only has 4 more months of support. MySQL
> 5.5.x went EOL 3 years ago. You want to push support past that? CentOS to
> my knowledge is the only major distro with issues supporting newer versions
> of mediawiki. Mediawiki provides support for their LTS releases for 3
> years, and releases them about every two years. Forcing mediawiki devs to
> keep the same requirements for 6+ years is not reasonable. I will also note
> that if CentOS is shipping with mediawiki 1.21 they are doing it wrong that
> branch is 6+ years old.
>
>> On Sat, Dec 22, 2018 at 11:17 AM Jeffrey Walton <[hidden email]> wrote:
>>
>> We use CentOS 7. Red Hat supplies antique software. It offers Media
>> wiki 1.21, if I recall correctly. It is what it is. We had to take on
>> maintenance of Mediawiki because we wanted to offer newer features
>> users. Skins and extensions sometimes need something newer than what
>> the platform provides.
>>
>> We've managed to update Apache, Python and PHP using SCL
>> (https://wiki.centos.org/AdditionalResources/Repositories/SCL).
>> However, we cannot get the MySQL update to work. We are stuck at MySQL
>> 5.5.60. MySQL 5.5.60 was released April 2018.
>>
>> We can't upgrade to to MW 1.31 due to CentOS's MySQL. We tried to
>> install MW 1.31 but maintenance/update.sh died when trying to update
>> the database. We had to go to backup and restore the installation.
>>
>> It is not just CentOS. Other OSes, like Ubuntu 14 LTS, are boxing
>> users. For example Ubuntu 14 provides MySQL 5.5.62
>> (https://packages.ubuntu.com/search?keywords=mysql-server). MySQL
>> 5.5.62 was released October 2018.
>>
>> Earlier I said "We've managed to update Apache, Python and PHP...".
>> SCL does not offer Composer. Composer is an entirely new set of
>> hardships. SCL probably does not offer Composer because dev tools have
>> no business being on a production server. While you may think
>> 'composer update' is easy, it took us a day and a half to work around
>> all the problems and exceptions.
>>
>> Please consider lowering the MySQL requirements. Most helpful would be
>> to lower and freeze all requirements for the next 3 or 5 years. A
>> requirements freeze would allow us (and other users) to upgrade
>> Mediawiki without the hassles and aggravations.
>>
>> Thanks in advance.
>>
>> _______________________________________________
>> MediaWiki-l mailing list
>> To unsubscribe, go to:
>> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Please lower MySQL requirements in next release

Jeffrey Walton
On Sat, Dec 22, 2018 at 12:59 PM Ryan Schmidt <[hidden email]> wrote:
>
> Try installing MariaDB instead of MySQL. It is a drop-in replacement and the version available in CentOS 7 is recent enough to run modern MediaWiki once you enable the MariaDB yum repo.

Let me ask this... CentOS provides Postgres 9.2, which meets minimum
requirements:

Available Packages
Name        : postgresql-server
Arch        : x86_64
Version     : 9.2.24
Release     : 1.el7_5

The question is, has anyone had success with a Wiki MySQL to Postgres
conversion like at
https://wiki.postgresql.org/wiki/Converting_from_other_Databases_to_PostgreSQL
?

I personally like Postgres but I am not a hard core database or web
guy. I have not hit the painpoints real database and web guys know.

Postgres also  makes fewer appearances on Bugtraq than MySQL.

Jeff

Jeff

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Please lower MySQL requirements in next release

jaquilina
If you guys require newer db versions for centos usually you can find other repos like EPEL or others that will have the newer versions and get the newer versions uploaded to them.

https://dev.mysql.com/downloads/repo/yum/

Regards,
Jonathan

-----Original Message-----
From: MediaWiki-l <[hidden email]> On Behalf Of Jeffrey Walton
Sent: 22 December 2018 19:18
To: MediaWiki announcements and site admin list <[hidden email]>
Subject: Re: [MediaWiki-l] Please lower MySQL requirements in next release

On Sat, Dec 22, 2018 at 12:59 PM Ryan Schmidt <[hidden email]> wrote:
>
> Try installing MariaDB instead of MySQL. It is a drop-in replacement and the version available in CentOS 7 is recent enough to run modern MediaWiki once you enable the MariaDB yum repo.

Let me ask this... CentOS provides Postgres 9.2, which meets minimum
requirements:

Available Packages
Name        : postgresql-server
Arch        : x86_64
Version     : 9.2.24
Release     : 1.el7_5

The question is, has anyone had success with a Wiki MySQL to Postgres conversion like at https://wiki.postgresql.org/wiki/Converting_from_other_Databases_to_PostgreSQL
?

I personally like Postgres but I am not a hard core database or web guy. I have not hit the painpoints real database and web guys know.

Postgres also  makes fewer appearances on Bugtraq than MySQL.

Jeff

Jeff

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Please lower MySQL requirements in next release

David Gerard-2
In reply to this post by Jeffrey Walton
I'd always recommend MySQL or a highly compatible variant such as
MariaDB - Postgres is great, but Wikimedia runs MariaDB so I do too.


- d.


On Sat, 22 Dec 2018 at 18:18, Jeffrey Walton <[hidden email]> wrote:

>
> On Sat, Dec 22, 2018 at 12:59 PM Ryan Schmidt <[hidden email]> wrote:
> >
> > Try installing MariaDB instead of MySQL. It is a drop-in replacement and the version available in CentOS 7 is recent enough to run modern MediaWiki once you enable the MariaDB yum repo.
>
> Let me ask this... CentOS provides Postgres 9.2, which meets minimum
> requirements:
>
> Available Packages
> Name        : postgresql-server
> Arch        : x86_64
> Version     : 9.2.24
> Release     : 1.el7_5
>
> The question is, has anyone had success with a Wiki MySQL to Postgres
> conversion like at
> https://wiki.postgresql.org/wiki/Converting_from_other_Databases_to_PostgreSQL
> ?
>
> I personally like Postgres but I am not a hard core database or web
> guy. I have not hit the painpoints real database and web guys know.
>
> Postgres also  makes fewer appearances on Bugtraq than MySQL.
>
> Jeff
>
> Jeff
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Please lower MySQL requirements in next release

Brian Wolff
In reply to this post by Jeffrey Walton
On Sat, Dec 22, 2018 at 4:17 PM Jeffrey Walton <[hidden email]> wrote:

>
> We use CentOS 7. Red Hat supplies antique software. It offers Media
> wiki 1.21, if I recall correctly. It is what it is. We had to take on
> maintenance of Mediawiki because we wanted to offer newer features
> users. Skins and extensions sometimes need something newer than what
> the platform provides.
>
> We've managed to update Apache, Python and PHP using SCL
> (https://wiki.centos.org/AdditionalResources/Repositories/SCL).
> However, we cannot get the MySQL update to work. We are stuck at MySQL
> 5.5.60. MySQL 5.5.60 was released April 2018.

MediaWiki requires MySQL 5.5.8 or greater. Well its not obvious, these
version numbers are not "decimal". i.e. 5.5.8 < 5.5.60, so 5.5.60
should work fine

If you encounter problems installing on mysql 5.5.60, it is a bug,
please tell us the errors you get (unless it was the error from your
other post).


> We can't upgrade to to MW 1.31 due to CentOS's MySQL. We tried to
> install MW 1.31 but maintenance/update.sh died when trying to update
> the database. We had to go to backup and restore the installation.
>
> It is not just CentOS. Other OSes, like Ubuntu 14 LTS, are boxing
> users. For example Ubuntu 14 provides MySQL 5.5.62
> (https://packages.ubuntu.com/search?keywords=mysql-server). MySQL
> 5.5.62 was released October 2018.
>
> Earlier I said "We've managed to update Apache, Python and PHP...".
> SCL does not offer Composer. Composer is an entirely new set of
> hardships. SCL probably does not offer Composer because dev tools have
> no business being on a production server. While you may think
> 'composer update' is easy, it took us a day and a half to work around
> all the problems and exceptions.

Composer is part of the build process. You only need it if installing
from git. If downloading the official tarball release you don't need
composer (Some skins & extensions like to use composer, but most
don't).

Generally you probably don't want composer on your production server.
Typically people (who are using a git install) would use composer to
generate the dependencies on a staging server and copy them over to
production. For example, Wikimedia uses a git repo of the composer
dependencies ( https://gerrit.wikimedia.org/g/mediawiki/vendor ) for
its production servers.

> Please consider lowering the MySQL requirements. Most helpful would be
to lower and freeze all requirements for the next 3 or 5 years.

Mysql 5.5.8 was released in 2010.

--
Brian

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l