[MediaWiki-l] Translated Interface only working when logged in

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Translated Interface only working when logged in

Dustin Phillips
I am working on a wiki family with several languages. The problem that I am
running into is that the interface is not reflecting the setting. For
example, I have the Persian Site using $wgLanguageCode = "fa"; but the
interface is still in English and still LTR. However, when I log in, the UI
suddenly appears in Persian. These results have been replicated by Persian
speakers in Iran, so it should not be an issue of browser settings or
anything like that.

Are there other settings that could possibly be overriding the $
wgLanguageCode?

Dustin Phillips  .  Co-Executive Director, ICANNWiki  .  M +13605801923  .
E  [hidden email]  .  W  icannwiki.org <http:/icannwiki.org>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Translated Interface only working when logged in

Brian Wolff
If $wgLanguageCode was just recently switched, then you may be
encountering caching issues (either browser, filecache, or
varnish/squid cache depending on config).

--
Brian

On Wed, May 17, 2017 at 3:34 PM, Dustin Phillips <[hidden email]> wrote:

> I am working on a wiki family with several languages. The problem that I am
> running into is that the interface is not reflecting the setting. For
> example, I have the Persian Site using $wgLanguageCode = "fa"; but the
> interface is still in English and still LTR. However, when I log in, the UI
> suddenly appears in Persian. These results have been replicated by Persian
> speakers in Iran, so it should not be an issue of browser settings or
> anything like that.
>
> Are there other settings that could possibly be overriding the $
> wgLanguageCode?
>
> Dustin Phillips  .  Co-Executive Director, ICANNWiki  .  M +13605801923  .
> E  [hidden email]  .  W  icannwiki.org <http:/icannwiki.org>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Translated Interface only working when logged in

Dustin Phillips
Unfortunately, I don't think that is it. It's used that language code since
it was installed. The same happens with Arabic as well.

Dustin Phillips  .  Co-Executive Director, ICANNWiki  .  M +13605801923  .
E  [hidden email]  .  W  icannwiki.org <http:/icannwiki.org>

On Wed, May 17, 2017 at 3:40 PM, Brian Wolff <[hidden email]> wrote:

> If $wgLanguageCode was just recently switched, then you may be
> encountering caching issues (either browser, filecache, or
> varnish/squid cache depending on config).
>
> --
> Brian
>
> On Wed, May 17, 2017 at 3:34 PM, Dustin Phillips <[hidden email]>
> wrote:
> > I am working on a wiki family with several languages. The problem that I
> am
> > running into is that the interface is not reflecting the setting. For
> > example, I have the Persian Site using $wgLanguageCode = "fa"; but the
> > interface is still in English and still LTR. However, when I log in, the
> UI
> > suddenly appears in Persian. These results have been replicated by
> Persian
> > speakers in Iran, so it should not be an issue of browser settings or
> > anything like that.
> >
> > Are there other settings that could possibly be overriding the $
> > wgLanguageCode?
> >
> > Dustin Phillips  .  Co-Executive Director, ICANNWiki  .  M +13605801923
> .
> > E  [hidden email]  .  W  icannwiki.org <http:/icannwiki.org>
> > _______________________________________________
> > MediaWiki-l mailing list
> > To unsubscribe, go to:
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Translated Interface only working when logged in

Hubert Patrick (NHQ-AC)
Could be as simple as the URL.
 
Both of my wiki are under the same Apache directory, something like this:
Apache_htdocs/English_wiki/...
Apache_htdocs/French_wiki/...

I could access the Main page as follow with the proper interface:
https://Apache_htdocs/English_wiki/index.php/Main_Page 
https://Apache_htdocs/French_wiki/index.php/Accueil 

But I could also access them in the wrong interface:
https://Apache_htdocs/English_wiki/index.php/Accueil (english interface, french page)
https://Apache_htdocs/French_wiki/index.php/Main_Page (french interface, english page)

Note that I'm only using 1 Database to store both Wikis.
Pat

-----Original Message-----
From: MediaWiki-l [mailto:[hidden email]] On Behalf Of Dustin Phillips
Sent: 17 mai 2017 15:47
To: MediaWiki announcements and site admin list
Subject: Re: [MediaWiki-l] Translated Interface only working when logged in

Unfortunately, I don't think that is it. It's used that language code since it was installed. The same happens with Arabic as well.

Dustin Phillips  .  Co-Executive Director, ICANNWiki  .  M +13605801923  .
E  [hidden email]  .  W  icannwiki.org <http:/icannwiki.org>

On Wed, May 17, 2017 at 3:40 PM, Brian Wolff <[hidden email]> wrote:

> If $wgLanguageCode was just recently switched, then you may be
> encountering caching issues (either browser, filecache, or
> varnish/squid cache depending on config).
>
> --
> Brian
>
> On Wed, May 17, 2017 at 3:34 PM, Dustin Phillips
> <[hidden email]>
> wrote:
> > I am working on a wiki family with several languages. The problem
> > that I
> am
> > running into is that the interface is not reflecting the setting.
> > For example, I have the Persian Site using $wgLanguageCode = "fa";
> > but the interface is still in English and still LTR. However, when I
> > log in, the
> UI
> > suddenly appears in Persian. These results have been replicated by
> Persian
> > speakers in Iran, so it should not be an issue of browser settings
> > or anything like that.
> >
> > Are there other settings that could possibly be overriding the $
> > wgLanguageCode?
> >
> > Dustin Phillips  .  Co-Executive Director, ICANNWiki  .  M
> > +13605801923
> .
> > E  [hidden email]  .  W  icannwiki.org <http:/icannwiki.org>
> > _______________________________________________
> > MediaWiki-l mailing list
> > To unsubscribe, go to:
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Translated Interface only working when logged in

Dustin Phillips
Thanks for the input. I discovered that the UniversalLanguageSelector
extension was overriding my site specific language settings.

Dustin Phillips  .  Co-Executive Director, ICANNWiki  .  M +13605801923  .
E  [hidden email]  .  W  icannwiki.org <http:/icannwiki.org>

On Wed, May 17, 2017 at 4:23 PM, Hubert Patrick (NHQ-AC) <
[hidden email]> wrote:

> Could be as simple as the URL.
>
> Both of my wiki are under the same Apache directory, something like this:
> Apache_htdocs/English_wiki/...
> Apache_htdocs/French_wiki/...
>
> I could access the Main page as follow with the proper interface:
> https://Apache_htdocs/English_wiki/index.php/Main_Page
> https://Apache_htdocs/French_wiki/index.php/Accueil
>
> But I could also access them in the wrong interface:
> https://Apache_htdocs/English_wiki/index.php/Accueil (english interface,
> french page)
> https://Apache_htdocs/French_wiki/index.php/Main_Page (french interface,
> english page)
>
> Note that I'm only using 1 Database to store both Wikis.
> Pat
>
> -----Original Message-----
> From: MediaWiki-l [mailto:[hidden email]] On
> Behalf Of Dustin Phillips
> Sent: 17 mai 2017 15:47
> To: MediaWiki announcements and site admin list
> Subject: Re: [MediaWiki-l] Translated Interface only working when logged in
>
> Unfortunately, I don't think that is it. It's used that language code
> since it was installed. The same happens with Arabic as well.
>
> Dustin Phillips  .  Co-Executive Director, ICANNWiki  .  M +13605801923  .
> E  [hidden email]  .  W  icannwiki.org <http:/icannwiki.org>
>
> On Wed, May 17, 2017 at 3:40 PM, Brian Wolff <[hidden email]> wrote:
>
> > If $wgLanguageCode was just recently switched, then you may be
> > encountering caching issues (either browser, filecache, or
> > varnish/squid cache depending on config).
> >
> > --
> > Brian
> >
> > On Wed, May 17, 2017 at 3:34 PM, Dustin Phillips
> > <[hidden email]>
> > wrote:
> > > I am working on a wiki family with several languages. The problem
> > > that I
> > am
> > > running into is that the interface is not reflecting the setting.
> > > For example, I have the Persian Site using $wgLanguageCode = "fa";
> > > but the interface is still in English and still LTR. However, when I
> > > log in, the
> > UI
> > > suddenly appears in Persian. These results have been replicated by
> > Persian
> > > speakers in Iran, so it should not be an issue of browser settings
> > > or anything like that.
> > >
> > > Are there other settings that could possibly be overriding the $
> > > wgLanguageCode?
> > >
> > > Dustin Phillips  .  Co-Executive Director, ICANNWiki  .  M
> > > +13605801923
> > .
> > > E  [hidden email]  .  W  icannwiki.org <http:/icannwiki.org>
> > > _______________________________________________
> > > MediaWiki-l mailing list
> > > To unsubscribe, go to:
> > > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> > _______________________________________________
> > MediaWiki-l mailing list
> > To unsubscribe, go to:
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l