[MediaWiki-l] Upgrade MediaWiki

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Upgrade MediaWiki

Eric Fetzer
Hi,


I'm moving an old MediaWiki on to a new server, so I'm going through the
MediaWIki Upgrade procedure (https://www.mediawiki.org/wiki/Manual:Upgrading).
I'm trying to do the alternate install so that our patch process keeps it
up to date but I'm not finding mediawiki when listing. I set up EPEL so I
can see the packages:


rpm -Uvh
https://download.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm


But then I look for the mediawiki packages like this, but nothing shows:


# yum list 'mediawiki*'

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos,
subscription-manager

This system is receiving updates from RHN Classic or Red Hat Satellite.

Error: No matching Packages to list


All I see is this:

# yum list '*mediawiki*'

Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos,
subscription-manager

This system is receiving updates from RHN Classic or Red Hat Satellite.

Installed Packages

drupal7-mediawiki_api.noarch
 1.0-0.14.rc1.el7                              @epel

libmediawiki.x86_64                                        4.10.0-7.el7
                              @epel

libmediawiki-devel.x86_64                                  4.10.0-7.el7
                              @epel

python-simplemediawiki.noarch
1.2.0-0.3.b2.el7                              @epel


What am I doing wrong?


Thanks,

Eric
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
eQT
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade MediaWiki

eQT
MediaWiki is not a package for yum.

You want to download MediaWiki from here:
https://www.mediawiki.org/wiki/Download

eQuality Technology

*Let's work together*

https://equality-tech.com
follow us: https://twitter.com/eQualityTech
*creators of https://QualityBox.us <https://QualityBox.us> *


On Thu, Sep 12, 2019 at 3:01 PM Eric Fetzer <[hidden email]> wrote:

> Hi,
>
>
> I'm moving an old MediaWiki on to a new server, so I'm going through the
> MediaWIki Upgrade procedure (
> https://www.mediawiki.org/wiki/Manual:Upgrading).
> I'm trying to do the alternate install so that our patch process keeps it
> up to date but I'm not finding mediawiki when listing. I set up EPEL so I
> can see the packages:
>
>
> rpm -Uvh
>
> https://download.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
>
>
> But then I look for the mediawiki packages like this, but nothing shows:
>
>
> # yum list 'mediawiki*'
>
> Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos,
> subscription-manager
>
> This system is receiving updates from RHN Classic or Red Hat Satellite.
>
> Error: No matching Packages to list
>
>
> All I see is this:
>
> # yum list '*mediawiki*'
>
> Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos,
> subscription-manager
>
> This system is receiving updates from RHN Classic or Red Hat Satellite.
>
> Installed Packages
>
> drupal7-mediawiki_api.noarch
>  1.0-0.14.rc1.el7                              @epel
>
> libmediawiki.x86_64                                        4.10.0-7.el7
>                               @epel
>
> libmediawiki-devel.x86_64                                  4.10.0-7.el7
>                               @epel
>
> python-simplemediawiki.noarch
> 1.2.0-0.3.b2.el7                              @epel
>
>
> What am I doing wrong?
>
>
> Thanks,
>
> Eric
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade MediaWiki

Eric Fetzer
From:
https://www.mediawiki.org/wiki/Manual:Running_MediaWiki_on_Red_Hat_Linux

(alternative) Install MediaWiki as an RPM from EPEL[edit

> <https://www.mediawiki.org/w/index.php?title=Manual:Running_MediaWiki_on_Red_Hat_Linux&action=edit&section=8>
> ]
>
> As an alternative to the above *recommended* install, EPEL maintains a
> pre-built package (.rpm file). The repository is located here: Fedora
> Project Extra Packages for Enterprise Linux (EPEL)
> <https://fedoraproject.org/wiki/EPEL>. This package may be one or more
> versions behind the current stable MediaWiki branch. However, many RHEL and
> CentOS users find EPEL is a good source for packages not included in the
> base system.
>
> First, configure your Red Hat (CentOS) installation to recognize the EPEL
> package repository, following these instructions: add the EPEL repository
> <https://fedoraproject.org/wiki/EPEL/FAQ#How_can_I_install_the_packages_from_the_EPEL_software_repository.3F> as
> a source for your package manager.
>
> List the available EPEL MediaWiki packages:
>
> yum list 'mediawiki*'
>
> or, if you want descriptions of each package
>
> yum info 'mediawiki*'
>
> Then install those that you choose with a command like
>
> yum install *packagenames go here, blank separated*
>
>
Is this documentation invalid?  It's not working for me.

Thanks,
Eric

On Thu, Sep 12, 2019 at 5:27 PM eQuality Technology <[hidden email]>
wrote:

> MediaWiki is not a package for yum.
>
> You want to download MediaWiki from here:
> https://www.mediawiki.org/wiki/Download
>
> eQuality Technology
>
> *Let's work together*
>
> https://equality-tech.com
> follow us: https://twitter.com/eQualityTech
> *creators of https://QualityBox.us <https://QualityBox.us> *
>
>
> On Thu, Sep 12, 2019 at 3:01 PM Eric Fetzer <[hidden email]> wrote:
>
> > Hi,
> >
> >
> > I'm moving an old MediaWiki on to a new server, so I'm going through the
> > MediaWIki Upgrade procedure (
> > https://www.mediawiki.org/wiki/Manual:Upgrading).
> > I'm trying to do the alternate install so that our patch process keeps it
> > up to date but I'm not finding mediawiki when listing. I set up EPEL so I
> > can see the packages:
> >
> >
> > rpm -Uvh
> >
> >
> https://download.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
> >
> >
> > But then I look for the mediawiki packages like this, but nothing shows:
> >
> >
> > # yum list 'mediawiki*'
> >
> > Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos,
> > subscription-manager
> >
> > This system is receiving updates from RHN Classic or Red Hat Satellite.
> >
> > Error: No matching Packages to list
> >
> >
> > All I see is this:
> >
> > # yum list '*mediawiki*'
> >
> > Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos,
> > subscription-manager
> >
> > This system is receiving updates from RHN Classic or Red Hat Satellite.
> >
> > Installed Packages
> >
> > drupal7-mediawiki_api.noarch
> >  1.0-0.14.rc1.el7                              @epel
> >
> > libmediawiki.x86_64                                        4.10.0-7.el7
> >                               @epel
> >
> > libmediawiki-devel.x86_64                                  4.10.0-7.el7
> >                               @epel
> >
> > python-simplemediawiki.noarch
> > 1.2.0-0.3.b2.el7                              @epel
> >
> >
> > What am I doing wrong?
> >
> >
> > Thanks,
> >
> > Eric
> > _______________________________________________
> > MediaWiki-l mailing list
> > To unsubscribe, go to:
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade MediaWiki

Andre Klapper-2
On Fri, 2019-09-13 at 13:37 -0600, Eric Fetzer wrote:
> Is this documentation invalid?  It's not working for me.

The steps in the documentation are correct: If there is no MediaWiki
package for your distribution anymore, then your query for the [non-
existing] MediaWiki package will correctly show no results.
See https://bugzilla.redhat.com/show_bug.cgi?id=1579121#c2

Please feel free to enhance the documentation to be clearer.

Cheers,
andre
--
Andre Klapper (he/him) | Bugwrangler / Developer Advocate
https://blogs.gnome.org/aklapper/


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l