[MediaWiki-l] Why is MW 1.28 obsolete?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] Why is MW 1.28 obsolete?

rkevans
Can anyone say simply why 1.28 is obsolete and 1.27 is still supported? I'm not looking for anything too technical. I'm just curious as to what went wrong. Sounds like there must be an interesting story there.

-Rich

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Why is MW 1.28 obsolete?

Chad
1.27 is a Long-Term-Support (LTS) release. It means we make a stronger
effort to backport fixes and support it for a longer period. 1.28 was not
such a release.

If you have a look at the history of MediaWiki versions from 1.19 onward,
you'll see the pattern: https://www.mediawiki.org/wiki/Version_lifecycle.
That page also has a lot more generally useful information as well.

Hope this answers your question!

-Chad

On Tue, Jan 23, 2018 at 11:36 AM Evans, Richard K. (GRC-H000) <
[hidden email]> wrote:

> Can anyone say simply why 1.28 is obsolete and 1.27 is still supported?
> I'm not looking for anything too technical. I'm just curious as to what
> went wrong. Sounds like there must be an interesting story there.
>
> -Rich
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Why is MW 1.28 obsolete?

Ryan Schmidt-76
In reply to this post by rkevans
Nothing special or wrong going on there. Every 4 versions there is a Long Term Support (LTS) release. 1.27 is LTS, the next LTS will be 1.31, and so on.

See https://www.mediawiki.org/wiki/Version_lifecycle for more info, including exact months when versions reach EOL.

> On Jan 23, 2018, at 12:36 PM, Evans, Richard K. (GRC-H000) <[hidden email]> wrote:
>
> Can anyone say simply why 1.28 is obsolete and 1.27 is still supported? I'm not looking for anything too technical. I'm just curious as to what went wrong. Sounds like there must be an interesting story there.
>
> -Rich
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Why is MW 1.28 obsolete?

Kunal Mehta
In reply to this post by rkevans
Please see
<https://www.mediawiki.org/wiki/Version_lifecycle#Release_policy>, which
explains that 1.27 is an LTS release, and will be supported for a longer
period than the normal releases.

-- Legoktm

On 01/23/2018 11:36 AM, Evans, Richard K. (GRC-H000) wrote:
> Can anyone say simply why 1.28 is obsolete and 1.27 is still supported? I'm not looking for anything too technical. I'm just curious as to what went wrong. Sounds like there must be an interesting story there.
>
> -Rich
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

signature.asc (883 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Why is MW 1.28 obsolete?

rkevans
In reply to this post by Ryan Schmidt-76
>
> Nothing special or wrong going on there. Every 4 versions there is a Long Term Support (LTS) release. 1.27 is LTS, the next LTS will be 1.31, and so on.
>
> See https://www.mediawiki.org/wiki/Version_lifecycle for more info, including exact months when versions reach EOL.

Ah! Gotcha. Thanks .. I guess that says something about me that I assumed there was something scandalous going on, lol.

-Rich
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l