[MediaWiki-l] no thumbnails after uploading an image

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] no thumbnails after uploading an image

Jingyi C. Shi
Hi,

I uploaded a png image but no thumbnails created in the File page. As a
result, I cannot use the image in my articles. Could someone help me with
this issue?

Thanks,
Jingyi
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: no thumbnails after uploading an image

Jasmine Smith
Do you have ImageMagic (or MagicImage, I can't remember the order) installed?

> On 28 Jul 2016, at 06:18 pm, "Jingyi C. Shi" <[hidden email]> wrote:
>
> Hi,
>
> I uploaded a png image but no thumbnails created in the File page. As a
> result, I cannot use the image in my articles. Could someone help me with
> this issue?
>
> Thanks,
> Jingyi
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: no thumbnails after uploading an image

Jingyi C. Shi

Yes, I have ImageMagick installed. Thumbnails work when I upload small pictures (say 500kb) but failed when uploading large and high resolution ones.

Thanks,
Jingyi


------------------------
Sent from my iPhone

> On Jul 29, 2016, at 8:00 AM, [hidden email] wrote:
>
> Send MediaWiki-l mailing list submissions to
>    [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>    https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> or, via email, send a message with subject or body 'help' to
>    [hidden email]
>
> You can reach the person managing the list at
>    [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of MediaWiki-l digest..."
>
>
> Today's Topics:
>
>   1. no thumbnails after uploading an image (Jingyi C. Shi)
>   2. Re: no thumbnails after uploading an image (Jasmine Smith)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Thu, 28 Jul 2016 13:17:38 -0400
> From: "Jingyi C. Shi" <[hidden email]>
> To: [hidden email]
> Subject: [MediaWiki-l] no thumbnails after uploading an image
> Message-ID:
>    <[hidden email]>
> Content-Type: text/plain; charset=UTF-8
>
> Hi,
>
> I uploaded a png image but no thumbnails created in the File page. As a
> result, I cannot use the image in my articles. Could someone help me with
> this issue?
>
> Thanks,
> Jingyi
>
>
> ------------------------------
>
> Message: 2
> Date: Thu, 28 Jul 2016 17:20:27 +0000
> From: Jasmine Smith <[hidden email]>
> To: MediaWiki announcements and site admin list
>    <[hidden email]>
> Subject: Re: [MediaWiki-l] no thumbnails after uploading an image
> Message-ID:
>    <[hidden email]>
>    
> Content-Type: text/plain; charset="us-ascii"
>
> Do you have ImageMagic (or MagicImage, I can't remember the order) installed?
>
>> On 28 Jul 2016, at 06:18 pm, "Jingyi C. Shi" <[hidden email]> wrote:
>>
>> Hi,
>>
>> I uploaded a png image but no thumbnails created in the File page. As a
>> result, I cannot use the image in my articles. Could someone help me with
>> this issue?
>>
>> Thanks,
>> Jingyi
>> _______________________________________________
>> MediaWiki-l mailing list
>> To unsubscribe, go to:
>> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> MediaWiki-l mailing list
> [hidden email]
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
>
> ------------------------------
>
> End of MediaWiki-l Digest, Vol 154, Issue 13
> ********************************************

_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: no thumbnails after uploading an image

John Doe-27
Check the thumb directory permission

On Fri, Jul 29, 2016 at 10:34 AM, <[hidden email]> wrote:

>
> Yes, I have ImageMagick installed. Thumbnails work when I upload small
> pictures (say 500kb) but failed when uploading large and high resolution
> ones.
>
> Thanks,
> Jingyi
>
>
> ------------------------
> Sent from my iPhone
>
> > On Jul 29, 2016, at 8:00 AM, [hidden email]
> wrote:
> >
> > Send MediaWiki-l mailing list submissions to
> >    [hidden email]
> >
> > To subscribe or unsubscribe via the World Wide Web, visit
> >    https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> > or, via email, send a message with subject or body 'help' to
> >    [hidden email]
> >
> > You can reach the person managing the list at
> >    [hidden email]
> >
> > When replying, please edit your Subject line so it is more specific
> > than "Re: Contents of MediaWiki-l digest..."
> >
> >
> > Today's Topics:
> >
> >   1. no thumbnails after uploading an image (Jingyi C. Shi)
> >   2. Re: no thumbnails after uploading an image (Jasmine Smith)
> >
> >
> > ----------------------------------------------------------------------
> >
> > Message: 1
> > Date: Thu, 28 Jul 2016 13:17:38 -0400
> > From: "Jingyi C. Shi" <[hidden email]>
> > To: [hidden email]
> > Subject: [MediaWiki-l] no thumbnails after uploading an image
> > Message-ID:
> >    <[hidden email]>
> > Content-Type: text/plain; charset=UTF-8
> >
> > Hi,
> >
> > I uploaded a png image but no thumbnails created in the File page. As a
> > result, I cannot use the image in my articles. Could someone help me with
> > this issue?
> >
> > Thanks,
> > Jingyi
> >
> >
> > ------------------------------
> >
> > Message: 2
> > Date: Thu, 28 Jul 2016 17:20:27 +0000
> > From: Jasmine Smith <[hidden email]>
> > To: MediaWiki announcements and site admin list
> >    <[hidden email]>
> > Subject: Re: [MediaWiki-l] no thumbnails after uploading an image
> > Message-ID:
> >    <
> [hidden email]
> >
> >
> > Content-Type: text/plain; charset="us-ascii"
> >
> > Do you have ImageMagic (or MagicImage, I can't remember the order)
> installed?
> >
> >> On 28 Jul 2016, at 06:18 pm, "Jingyi C. Shi" <[hidden email]>
> wrote:
> >>
> >> Hi,
> >>
> >> I uploaded a png image but no thumbnails created in the File page. As a
> >> result, I cannot use the image in my articles. Could someone help me
> with
> >> this issue?
> >>
> >> Thanks,
> >> Jingyi
> >> _______________________________________________
> >> MediaWiki-l mailing list
> >> To unsubscribe, go to:
> >> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> >
> >
> > ------------------------------
> >
> > Subject: Digest Footer
> >
> > _______________________________________________
> > MediaWiki-l mailing list
> > [hidden email]
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> >
> > ------------------------------
> >
> > End of MediaWiki-l Digest, Vol 154, Issue 13
> > ********************************************
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: no thumbnails after uploading an image

Greg Rundlett (freephile)
In reply to this post by Jingyi C. Shi
You're running out of memory... Check the $wgMaxShellMemory
<https://www.mediawiki.org/wiki/Manual:$wgMaxShellMemory> in
LocalSettings.php

Try something like this:

//increase thumbnailing memory
$wgMaxShellMemory = 307200; # 300MB



Greg Rundlett
https://eQuality-Tech.com
https://freephile.org

On Fri, Jul 29, 2016 at 10:34 AM, <[hidden email]> wrote:

>
> Yes, I have ImageMagick installed. Thumbnails work when I upload small
> pictures (say 500kb) but failed when uploading large and high resolution
> ones.
>
> Thanks,
> Jingyi
>
>
> ------------------------
> Sent from my iPhone
>
> > On Jul 29, 2016, at 8:00 AM, [hidden email]
> wrote:
> >
> > Send MediaWiki-l mailing list submissions to
> >    [hidden email]
> >
> > To subscribe or unsubscribe via the World Wide Web, visit
> >    https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> > or, via email, send a message with subject or body 'help' to
> >    [hidden email]
> >
> > You can reach the person managing the list at
> >    [hidden email]
> >
> > When replying, please edit your Subject line so it is more specific
> > than "Re: Contents of MediaWiki-l digest..."
> >
> >
> > Today's Topics:
> >
> >   1. no thumbnails after uploading an image (Jingyi C. Shi)
> >   2. Re: no thumbnails after uploading an image (Jasmine Smith)
> >
> >
> > ----------------------------------------------------------------------
> >
> > Message: 1
> > Date: Thu, 28 Jul 2016 13:17:38 -0400
> > From: "Jingyi C. Shi" <[hidden email]>
> > To: [hidden email]
> > Subject: [MediaWiki-l] no thumbnails after uploading an image
> > Message-ID:
> >    <[hidden email]>
> > Content-Type: text/plain; charset=UTF-8
> >
> > Hi,
> >
> > I uploaded a png image but no thumbnails created in the File page. As a
> > result, I cannot use the image in my articles. Could someone help me with
> > this issue?
> >
> > Thanks,
> > Jingyi
> >
> >
> > ------------------------------
> >
> > Message: 2
> > Date: Thu, 28 Jul 2016 17:20:27 +0000
> > From: Jasmine Smith <[hidden email]>
> > To: MediaWiki announcements and site admin list
> >    <[hidden email]>
> > Subject: Re: [MediaWiki-l] no thumbnails after uploading an image
> > Message-ID:
> >    <
> [hidden email]
> >
> >
> > Content-Type: text/plain; charset="us-ascii"
> >
> > Do you have ImageMagic (or MagicImage, I can't remember the order)
> installed?
> >
> >> On 28 Jul 2016, at 06:18 pm, "Jingyi C. Shi" <[hidden email]>
> wrote:
> >>
> >> Hi,
> >>
> >> I uploaded a png image but no thumbnails created in the File page. As a
> >> result, I cannot use the image in my articles. Could someone help me
> with
> >> this issue?
> >>
> >> Thanks,
> >> Jingyi
> >> _______________________________________________
> >> MediaWiki-l mailing list
> >> To unsubscribe, go to:
> >> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> >
> >
> > ------------------------------
> >
> > Subject: Digest Footer
> >
> > _______________________________________________
> > MediaWiki-l mailing list
> > [hidden email]
> > https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
> >
> >
> > ------------------------------
> >
> > End of MediaWiki-l Digest, Vol 154, Issue 13
> > ********************************************
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: no thumbnails after uploading an image

Jan Steinman-2
In reply to this post by Jasmine Smith
> From: "Jingyi C. Shi" <[hidden email]>
>
> I uploaded a png image but no thumbnails created in the File page. As a
> result, I cannot use the image in my articles.

Just went through something similar, but I did see thumbs on the File page in my case — just not where I was using them!

In my case, I had uploaded a bunch of arbitrary files, keeping their file names. Then I typed in the names to use via <randomimage> and <gallery>.

It turns out that half the images were named with “.jpg” and the others were named with “.JPG”, and I use a case-sensitive file system! I had referred to them all as “.jpg”, which caused the upper-case ones to be invisible.

So this particular gotcha might not apply to you.

You could try appending “?action=purge” to the URL, which *should* cause the thumbs to be re-generated. I think.

You can also go to your thumbs directory via your file system, and see if the thumbs are indeed there. They will be in “YourWikiRoot/images/thumbs”. Check the permissions on this directory to make sure thumbs can be read by your web server.

:::: We don't have an energy crisis; we have a consumption crisis. -- Ozzie Zehner <http://www.lmgtfy.com/?q=Ozzie+Zehner>
:::: Jan Steinman, EcoReality Co-op <http://www.ecoreality.org/> ::::


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: no thumbnails after uploading an image

Tom Hutchison
In reply to this post by Jingyi C. Shi
You will have to allow a higher memory consumption on your server so the resources needed to do the image conversion are available and can complete. Remember, image manipulation is a memory and CPU intensive task even on a personal computer.

Tom

> On Jul 29, 2016, at 10:34 AM, [hidden email] wrote:
>
>
> Yes, I have ImageMagick installed. Thumbnails work when I upload small pictures (say 500kb) but failed when uploading large and high resolution ones.
>
> Thanks,
> Jingyi
>
>
> ------------------------
> Sent from my iPhone
>
>> On Jul 29, 2016, at 8:00 AM, [hidden email] wrote:
>>
>> Send MediaWiki-l mailing list submissions to
>>   [hidden email]
>>
>> To subscribe or unsubscribe via the World Wide Web, visit
>>   https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>> or, via email, send a message with subject or body 'help' to
>>   [hidden email]
>>
>> You can reach the person managing the list at
>>   [hidden email]
>>
>> When replying, please edit your Subject line so it is more specific
>> than "Re: Contents of MediaWiki-l digest..."
>>
>>
>> Today's Topics:
>>
>>  1. no thumbnails after uploading an image (Jingyi C. Shi)
>>  2. Re: no thumbnails after uploading an image (Jasmine Smith)
>>
>>
>> ----------------------------------------------------------------------
>>
>> Message: 1
>> Date: Thu, 28 Jul 2016 13:17:38 -0400
>> From: "Jingyi C. Shi" <[hidden email]>
>> To: [hidden email]
>> Subject: [MediaWiki-l] no thumbnails after uploading an image
>> Message-ID:
>>   <[hidden email]>
>> Content-Type: text/plain; charset=UTF-8
>>
>> Hi,
>>
>> I uploaded a png image but no thumbnails created in the File page. As a
>> result, I cannot use the image in my articles. Could someone help me with
>> this issue?
>>
>> Thanks,
>> Jingyi
>>
>>
>> ------------------------------
>>
>> Message: 2
>> Date: Thu, 28 Jul 2016 17:20:27 +0000
>> From: Jasmine Smith <[hidden email]>
>> To: MediaWiki announcements and site admin list
>>   <[hidden email]>
>> Subject: Re: [MediaWiki-l] no thumbnails after uploading an image
>> Message-ID:
>>   <[hidden email]>
>>
>> Content-Type: text/plain; charset="us-ascii"
>>
>> Do you have ImageMagic (or MagicImage, I can't remember the order) installed?
>>
>>> On 28 Jul 2016, at 06:18 pm, "Jingyi C. Shi" <[hidden email]> wrote:
>>>
>>> Hi,
>>>
>>> I uploaded a png image but no thumbnails created in the File page. As a
>>> result, I cannot use the image in my articles. Could someone help me with
>>> this issue?
>>>
>>> Thanks,
>>> Jingyi
>>> _______________________________________________
>>> MediaWiki-l mailing list
>>> To unsubscribe, go to:
>>> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>>
>>
>>
>> ------------------------------
>>
>> Subject: Digest Footer
>>
>> _______________________________________________
>> MediaWiki-l mailing list
>> [hidden email]
>> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>>
>>
>> ------------------------------
>>
>> End of MediaWiki-l Digest, Vol 154, Issue 13
>> ********************************************
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l


_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l