[MediaWiki-l] problems with the wgDBadminuser account

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[MediaWiki-l] problems with the wgDBadminuser account

Jasmin Hannemann
Hi,

I have a little problem with my adminuser of the wiki database. I create
a new mysql user called wikiadmin in this way:

GRANT ALL PRIVILEGES ON *.* TO 'wikiadmin'@'localhost' IDENTIFIED BY 'XXX'


This settings I wrote in my AdminSettings.php, which looks like this

<?php
/**
 * This file should be copied to AdminSettings.php, and modified
 * to reflect local settings. It is required for the maintenance
 * scripts which run on the command line, as an extra security
 * measure to allow using a separate user account with higher
 * privileges to do maintenance work.
 *
 * Developers: Do not check AdminSettings.php into CVS!
 *
 * @package MediaWiki
 */

$wgDBadminuser      = 'wikiadmin';
$wgDBadminpassword  = 'XXX';

/*
 * Whether to enable the profileinfo.php script.
 */
$wgEnableProfileInfo = false;
?>

My AdminSettings.php is in the folder mediawiki-1.5.5 like my
LocalSettings.php.

Now, if I run the rebuildtextindex.php, I will get error message, that
the wikiadmin@localhost cannot connect to the database. But if I add the
lines for the adminuser from the Adminsettings to the
rebuildtextindex.php, all will be fine. I think, this is not a good
solution.

The rights for the Adminsettings.php are

-rwxrwxr--  1 www-data www-data   817 2006-04-11 09:55 AdminSettings.php

 



Has anybody an idea, what my failure is?

Cheers,
Jasmin
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l