Mediawiki doesn't run with apache-ssl/php4

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Mediawiki doesn't run with apache-ssl/php4

MediaWiki-l.20.stefan817
Hi,

I tried something but php4 + https is still not working together.
I believe the php4 mod is loaded and the package installed.

Here my /etc/apache-ssl/modules.conf:

# Autogenerated file - do not edit!
# This file is maintained by the apache-ssl package.
# To update it, run the command:
#    /usr/sbin/apache-modconf apache-ssl
ClearModuleList
AddModule mod_so.c
AddModule mod_macro.c
LoadModule config_log_module /usr/lib/apache/1.3/mod_log_config_ssl.so
LoadModule mime_magic_module /usr/lib/apache/1.3/mod_mime_magic.so
LoadModule mime_module /usr/lib/apache/1.3/mod_mime_ssl.so
LoadModule negotiation_module /usr/lib/apache/1.3/mod_negotiation.so
LoadModule status_module /usr/lib/apache/1.3/mod_status.so
LoadModule autoindex_module /usr/lib/apache/1.3/mod_autoindex.so
LoadModule dir_module /usr/lib/apache/1.3/mod_dir.so
LoadModule cgi_module /usr/lib/apache/1.3/mod_cgi.so
LoadModule userdir_module /usr/lib/apache/1.3/mod_userdir.so
LoadModule alias_module /usr/lib/apache/1.3/mod_alias.so
LoadModule rewrite_module /usr/lib/apache/1.3/mod_rewrite.so
LoadModule access_module /usr/lib/apache/1.3/mod_access.so
LoadModule expires_module /usr/lib/apache/1.3/mod_expires.so
LoadModule setenvif_module /usr/lib/apache/1.3/mod_setenvif.so
LoadModule apache_ssl_module /usr/lib/apache/1.3/libssl.so
LoadModule auth_module /usr/lib/apache/1.3/mod_auth_ssl.so
LoadModule php4_module /usr/lib/apache/1.3/libphp4.so

Even the module is libapache-mod-php4 installed.

Here is a overview of the installed LAMP-modules (dpkg --list).

ii  apache         1.3.33-6sarge1 versatile, high-performance HTTP server
ii  apache-common  1.3.33-6sarge1 support files for all Apache webservers
ii  apache-ssl     1.3.33-6sarge1 versatile, high-performance HTTP server
with
ii  apache2-utils  2.0.54-5       utility programs for webservers
ii  libapache-mod- 4.3.10-16      server-side, HTML-embedded scripting
languag
ii  libssl0.9.7    0.9.7e-3sarge1 SSL shared libraries
ii  mysql-client   4.0.24-10sarge mysql database client binaries
ii  mysql-common   4.0.24-10sarge mysql database common files (e.g.
/etc/mysql
ii  mysql-server   4.0.24-10sarge mysql database server binaries
ii  openssl        0.9.7e-3sarge1 Secure Socket Layer (SSL) binary and
related
ii  perl           5.8.4-8sarge3  Larry Wall's Practical Extraction and
Report
ii  perl-base      5.8.4-8sarge3  The Pathologically Eclectic Rubbish Lister
ii  perl-modules   5.8.4-8sarge3  Core Perl modules
ii  php4           4.3.10-16      server-side, HTML-embedded scripting
languag
ii  php4-common    4.3.10-16      Common files for packages built from the
php
ii  php4-imagick   0.9.11-0.2     ImageMagick module for php4
ii  php4-mysql     4.3.10-16      MySQL module for php4
ii  phpmyadmin     2.6.2-3sarge1  set of PHP-scripts to administrate MySQL
ove
ii  python         2.3.5-2        An interactive high-level object-oriented
la
ii  python-newt    0.51.6-20      A NEWT module for Python
ii  python2.3      2.3.5-3sarge1  An interactive high-level object-oriented
la


Any other ideas?

Stefan

Pedro Flores pflores at mcs.anl.gov wrote:

> I believe you need to install the libapache-mod-php4 package and make
>  sure apache is loading the php4 modules.


Willy, Andrew AWilly at eSMIL.net wrote:

> Did you add php4 to the modules.conf for apache ssl?


>> MediaWiki-l.20.stefan817 at spamgourmet.liecom wrote:
>> Hi,
>> I run a mediawiki 1.5.6 on debian-LAMP in an intranet and everything
works

>> fine.
>> Now I want to do the same with https and an apache-ssl-server.
>> *Every* page should be displayed using https and the apache-ssl.
>> The apache-ssl itself works fine, too.
>> But phpinfo is not parsed by it...
>> Where is the main-trigger for running PHP4 with apache-ssl?
>> Or what else have I to do? Perhaps I forgot to install something?
>> My config: apache 1.3.33, php4.3.10-16, MySQL 4.0.24, debian 3.1
>> Cheerio
>> Stefan
--
"Feel free" mit GMX FreeMail!
Monat für Monat 10 FreeSMS inklusive! http://www.gmx.net

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l