New install only showing blank page

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

New install only showing blank page

Anders Schneiderman
 I just installed a new version of MediaWiki on a RH Linux box.  The
install went fine.  I copied Local Settings.php to the main directory,
deleted the config directory, and set $wgserver to our test server's IP
address.   It's now running, but all I'm getting is a blank page.  In
other words, if I go to:
 
http:/ouripaddress/mediawiki/index.php/Main_Page

Or

http:/ouripaddress/mediawiki/index.php
 
I get nada.  No errors -- but view source shows nothing there.
 
Just to make sure, I also put a test HML page in the directory:

http:/ouripaddress/mediawiki/test.html

And it works fine.  Any idea what I'm doing wrong?  If there is
documentation that explains what to do next, just point in the right
direction -- I didn't see anything.

Thanks,
Anders Schneiderman

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: New install only showing blank page

Christian Voelker

Am 02.05.2006 um 18:53 schrieb Anders Schneiderman:

> if I go to:
>
> http:/ouripaddress/mediawiki/index.php/Main_Page
>
> I get nada.  No errors -- but view source shows nothing there.
>
> Just to make sure, I also put a test HML page in the directory:
>
> http:/ouripaddress/mediawiki/test.html
>
> And it works fine.

There is another step in between you might check next:
Is PHP working properly? You might want to drop a page
with phpinfo command in your webroot or enable php
error reporting in your php.ini temporarily. If there
is nothing wrong there, next step would probably be to
make sure that mysql is running and the wiki database
was created properly. You can check all of this in one
step if you have phpmyadmin installed. Then, what about
the apache error log? Are there ownership issues with
your mediawiki files not being readable by the user
running apache?

Yours, Christian

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l