Problems creating User Groups (Bump)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems creating User Groups (Bump)

a@kid
I am having problems setting up custom User Groups.

I have added a new User Group to LocalSettings.php.  The new user  
group shows up on Special:Userrights and i can assign it to a user.  
However, after i have assigned a user to this new custom group, the  
new privileges don't become active for that user.

Is there anything else besides:
  $wgGroupPermissions['ninja']['delete'] = true;
that needs to be added to LocalSettings to enable a new user group?

(I am bit confused by the documentation at  http://meta.wikimedia.org/ 
wiki/Help:User_levels
At one point it says you need sheel acccess to the server to create  
new groups, and then a few lines down it says that new groups can be  
added in LocalSettings.php as i mentioned above.)

thanks


_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Problems creating User Groups (Bump)

Brion Vibber
a@kid wrote:
> I have added a new User Group to LocalSettings.php.  The new user  
> group shows up on Special:Userrights and i can assign it to a user.  
> However, after i have assigned a user to this new custom group, the  
> new privileges don't become active for that user.
>
> Is there anything else besides:
>   $wgGroupPermissions['ninja']['delete'] = true;
> that needs to be added to LocalSettings to enable a new user group?

No, nothing else is needed. I can confirm this works correctly in 1.6.5 and
current trunk code. What are you not seeing that you're expecting?

(Keep in mind that pages are cached, and your change to LocalSettings.php
doesn't automatically invalidate the cache unless it was created from a 1.6
installer. Make sure you've done a complete reload of the page if you're just
looking for a "delete" tab on one particular page.)

-- brion vibber (brion @ pobox.com)


_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l

signature.asc (257 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problems creating User Groups (Bump)

a@kid
In reply to this post by a@kid

Thanks Brian ... you were right ... it was just a caching issue.

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l