Problems getting images wap.

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems getting images wap.

javi bueno
Hi guys! I am trying to use project hawpedia using the mediawiki API. In this way, I can get a page with all images from wikipedia. When I am trying to change the API which I want to use from wikipedia API to a mediawiki API, I cannot see the images. I don't Know if the links to the images are bad, if there is a problem in API mediawiki ... It would be very grateful if someone could tell me something about it.
 
Thanks, Javier.


Sigue los principales acontecimientos deportivos en directo. MSN Motor
_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: Problems getting images wap.

Platonides
javi bueno escribió:
> Hi guys! I am trying to use project hawpedia using the mediawiki API. In
> this way, I can get a page with all images from wikipedia. When I am
> trying to change the API which I want to use from wikipedia API to a
> mediawiki API, I cannot see the images. I don't Know if the links to the
> images are bad, if there is a problem in API mediawiki ... It would be
> very grateful if someone could tell me something about it.
>  
> Thanks, Javier.

Hola Javier,
Wikipedia uses full urls for the images, while the default on mediawiki
installs is not to. So you'll probably need to add the domain to the
images url in order to visualize them.

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: Problems getting images wap.

javi bueno
Thanks Platonides. I had to make other changes in the code ( mime is not supported by mediawiki API ), but you were right with the images url.
 
Regards,
 
Javier.



> Date: Thu, 10 Jul 2008 13:44:00 +0200

> To: [hidden email]
> From: [hidden email]
> Subject: Re: [Mediawiki-api] Problems getting images wap.
>
> javi bueno escribió:
> > Hi guys! I am trying to use project hawpedia using the mediawiki API. In
> > this way, I can get a page with all images from wikipedia. When I am
> > trying to change the API which I want to use from wikipedia API to a
> > mediawiki API, I cannot see the images. I don't Know if the links to the
> > images are bad, if there is a problem in API mediawiki ... It would be
> > very grateful if someone could tell me something about it.
> >
> > Thanks, Javier.
>
> Hola Javier,
> Wikipedia uses full urls for the images, while the default on mediawiki
> installs is not to. So you'll probably need to add the domain to the
> images url in order to visualize them.
>
> _______________________________________________
> Mediawiki-api mailing list
> [hidden email]
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-api



¿Quieres los emoticonos y guiños más divertidos? Descárgate Internet Explorer 7, y consigue contenidos exclusivos cada semana. ¡Gratis! ¿Quieres los emoticonos y guiños más divertidos?
_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: Problems getting images wap.

Roan Kattouw
javi bueno schreef:
> Thanks Platonides. I had to make other changes in the code ( mime is
> not supported by mediawiki API ), but you were right with the images url.
MIME *is* supported, at least in 1.13 which is due to be released in the
weeks to come (don't know about 1.12). You can get an image's mime type
with iiprop=mime .

Roan Kattouw (Catrope)

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api