Problems with Wiki on Windows 2003 Server & IIS

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with Wiki on Windows 2003 Server & IIS

Graham Wager
Hi guys,

Having a bit of trouble with a wiki at the moment, wondered if any of you have any ideas what might be causing my problems.

Running on Windows 2003 Server SP-1, PHP 5.1.1, MySQL 5.0.18, IIS 6.

The install went fine, but I'm having some strange problems since then. If I login, it confirms that I've logged in, then reverts to using my IP address as though the session data has been lost. The cookies are being set properly, as I've checked them in FireFox. Are there any PHP settings I may have missed? I've tried clearing all the cookies, but this hasn't helped.

My other issue is that if I try and access any page in the wiki with IE, it will take about 5 minutes to load, and all the images won't appear. I've tried wiping my cache and cookies, but to no avail.

Any ideas would be appreciated; the site is currently password protected, but if one of you would like to look I can grant you temporary access. Nothing's been added yet, so there's nothing for me to lose!

Regards,

Graham Wager
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Problems with Wiki on Windows 2003 Server & IIS

Brion Vibber
Graham Wager wrote:
> The install went fine, but I'm having some strange problems since then. If I
> login, it confirms that I've logged in, then reverts to using my IP address
> as though the session data has been lost. The cookies are being set properly,
> as I've checked them in FireFox. Are there any PHP settings I may have
> missed? I've tried clearing all the cookies, but this hasn't helped.

Check the session.save_path in php.ini; this is bogus in the default
installation of PHP on Windows.

-- brion vibber (brion @ pobox.com)


_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l

signature.asc (257 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RE: Problems with Wiki on Windows 2003 Server & IIS

Isaac Gonzalez
I set mine to the following:

session.save_path= C:\PHP\sessiondata

and gave this directory modify permission for the internet guest account.

works fine....same config..win2k3/iis6

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]]On Behalf Of Brion Vibber
Sent: Saturday, January 07, 2006 3:09 PM
To: MediaWiki announcements and site admin list
Subject: Re: [Mediawiki-l] Problems with Wiki on Windows 2003 Server &
IIS


Graham Wager wrote:
> The install went fine, but I'm having some strange problems since then. If
I
> login, it confirms that I've logged in, then reverts to using my IP
address
> as though the session data has been lost. The cookies are being set
properly,
> as I've checked them in FireFox. Are there any PHP settings I may have
> missed? I've tried clearing all the cookies, but this hasn't helped.

Check the session.save_path in php.ini; this is bogus in the default
installation of PHP on Windows.

-- brion vibber (brion @ pobox.com)


_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l