Re: Cannot change content of navigation bar because $wgUseDatabaseMessages=false

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Cannot change content of navigation bar because $wgUseDatabaseMessages=false

Heinz-Josef Lücking-2
Jan Vanoverpelt schrieb:

> Dear,
>
> After installation of the Mediawiki-software, I changed the default
> "English" language into Dutch by changing $wgLanguageCode in
> localsettings.php AND by setting $wgUseDatabaseMessages=false in
> defaultsettings.php (the latter had to be done in order to see the changes,
> like is indicated in the Mediawiki-FAQ).
>
> My problem is that because $wgUseDatabaseMessages=false, I cannot display
> the page "special:allmessages" anymore, neither can I change the content of
> the navigation bar. As a solution for this problem, the FAQ-answer proposes
> to run the script rebuildMessages.php in the maintenance-folder. I did this
> by running an FTP-program, selecting the remote file and pressing "execute"
> but without any results.
>
> Does anyone know how I can fix this problem so I am allowed to see the page
> special:allmessages and change the content of the navigation bar while I
> still have my wiki-site in the Dutch language?
>
> thanks in advance!
Have a look on http://en.giswiki.de I made use of

http://meta.wikimedia.org/wiki/MediaWiki_FAQ#Using_a_wikipage_as_a_source_for_a_navigation_bar

http://meta.wikimedia.org/wiki/

-> MediaWiki_FAQ#Using_a_wikipage_as_a_source_for_a_navigation_bar

_______________________________________________
Wikitech-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/wikitech-l
Reply | Threaded
Open this post in threaded view
|

Re: Re: Cannot change content of navigation bar because $wgUseDatabaseMessages=false

Rob Church
The FAQ is wrong. The "correct" procedure, having changed the language
code, is to run the rebuildMessages maintenance script to update the
MediaWiki namespace. I'll correct that now...


Rob Church

On 17/01/06, Heinz <[hidden email]> wrote:

> Jan Vanoverpelt schrieb:
> > Dear,
> >
> > After installation of the Mediawiki-software, I changed the default
> > "English" language into Dutch by changing $wgLanguageCode in
> > localsettings.php AND by setting $wgUseDatabaseMessages=false in
> > defaultsettings.php (the latter had to be done in order to see the changes,
> > like is indicated in the Mediawiki-FAQ).
> >
> > My problem is that because $wgUseDatabaseMessages=false, I cannot display
> > the page "special:allmessages" anymore, neither can I change the content of
> > the navigation bar. As a solution for this problem, the FAQ-answer proposes
> > to run the script rebuildMessages.php in the maintenance-folder. I did this
> > by running an FTP-program, selecting the remote file and pressing "execute"
> > but without any results.
> >
> > Does anyone know how I can fix this problem so I am allowed to see the page
> > special:allmessages and change the content of the navigation bar while I
> > still have my wiki-site in the Dutch language?
> >
> > thanks in advance!
> Have a look on http://en.giswiki.de I made use of
>
> http://meta.wikimedia.org/wiki/MediaWiki_FAQ#Using_a_wikipage_as_a_source_for_a_navigation_bar
>
> http://meta.wikimedia.org/wiki/
>
> -> MediaWiki_FAQ#Using_a_wikipage_as_a_source_for_a_navigation_bar
>
> _______________________________________________
> Wikitech-l mailing list
> [hidden email]
> http://mail.wikipedia.org/mailman/listinfo/wikitech-l
>
_______________________________________________
Wikitech-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/wikitech-l