SMW—Concept outputs double entries and deleted entries

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

SMW—Concept outputs double entries and deleted entries

André Fincato-2
Hi,

I recently upgraded SMW to the latest version (2.5.3) from ~2.4. At first I had some problems but then the upgrade went well.

The only problem left is that all the concept pages of the wiki displays the correct pages in the wiki’s Concept page, but when I’m fetching that page through json, I get the correct page and a double of each page with title like ‘Concept:Activities# QUERYd64f49fa6b3fd3a2d4c7eda437e49e88’, wherein the original is only ‘Concept:Activities’.

These ‘QUERY’ appended pages are nowhere to be found in the wiki, and act like ghosts.

Moreover, I deleted some old pages containing redirects, that were concept pages and I now see them only in the json call (but not in the wiki’s Concept page).

I tried to fix the problem by running several times SMW's `rebuildData.php`, by using all the tools in the `Special:SemanticMediaWiki` page, upgrading composer and all the dependencies, and running the `update.php` script in `/mediawiki/maintenance`.

I also tried to ‘move’ every Concept page to a new name without leaving a redirect, then delete them. Then create them from scratch. I also tried to update and clean SMW Concept’s cache.

Still the same.

How would I fix this? As of now I am filtering out these pages from the final output, but it’s merely a quick fix.

My impression is that during the first upgrade that went bad, the process messed up the SMW database. But then I rebuild/upgrade the database several times and these ghost pages were never found.


Thanks,
André
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Loading...