Save Page Button -> Server Timeout?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Save Page Button -> Server Timeout?

mog404
Yesterday I noticed that after a page edit,  the "Save Page" and "Show Preview" buttons result in a server timeout. Everything else functions normally and prior to yesterday I had not noticed anything wrong.

What is even more strange is that I am able to save changes after "Edit with Form" tab, including manual edits in the Free Text box. Pressing the "Save Page" button appears to the generate the same URL ending with action=submit, whether I initially enter with the "Edit" or "Edit with Form" tab.

I have not changed configurations or attempted recent updates. Same behavior on Windows/Mac, Safari/Firefox/Explorer and with Admin/normal logins. Tried rebooting, bumping up memory in LocalSettings, SELinux Disable, and running update.php.

Glancing at httpd/error_log showed errors like the following, but they were generated when browsing rather than editing, so I don't think they are leading anywhere.
   "" is not a valid magic thingie for "explode"
   "" is not a valid magic thingie for "urldecode"

I have been developing this internally-hosted semantic wiki for the past several years, without any basic problems. Can't get this VM to update so stuck at MediaWiki: 1.16.5 and  Semantic MediaWiki: 1.5.1.1, with lots of extensions. Will probably let this VM pass into the night and roll out my VM with current versions (running locally, LOVE units conversion). Would like to understand the problem in case it happens on the new setup.

Anyone seen this before?

Thanks,
Rodger
Reply | Threaded
Open this post in threaded view
|

Re: Save Page Button -> Server Timeout?

Yaron Koren-2
Hi Rodger,

It sounds like what you're saying is, you're using the Semantic Forms
extension and for certain pages, trying to save or preview the page with
the form leads to a timeout. I've seen that happen before: the issue is
most likely that your form is just too large/complex to get fully processed
during the allotted time. Upgrading the software might help, but so would
minimizing the form in one way or another.

-Yaron


On Tue, Apr 16, 2013 at 2:26 PM, mog404 <[hidden email]> wrote:

> Yesterday I noticed that after a page edit,  the "Save Page" and "Show
> Preview" buttons result in a server timeout. Everything else functions
> normally and prior to yesterday I had not noticed anything wrong.
>
> What is even more strange is that I am able to save changes after "Edit
> with
> Form" tab, including manual edits in the Free Text box. Pressing the "Save
> Page" button appears to the generate the same URL ending with
> action=submit,
> whether I initially enter with the "Edit" or "Edit with Form" tab.
>
> I have not changed configurations or attempted recent updates. Same
> behavior
> on Windows/Mac, Safari/Firefox/Explorer and with Admin/normal logins. Tried
> rebooting, bumping up memory in LocalSettings, SELinux Disable, and running
> update.php.
>
> Glancing at httpd/error_log showed errors like the following, but they were
> generated when browsing rather than editing, so I don't think they are
> leading anywhere.
>    "" is not a valid magic thingie for "explode"
>    "" is not a valid magic thingie for "urldecode"
>
> I have been developing this internally-hosted semantic wiki for the past
> several years, without any basic problems. Can't get this VM to update so
> stuck at MediaWiki: 1.16.5 and  Semantic MediaWiki: 1.5.1.1, with lots of
> extensions. Will probably let this VM pass into the night and roll out my
> VM
> with current versions (running locally, LOVE units conversion). Would like
> to understand the problem in case it happens on the new setup.
>
> Anyone seen this before?
>
> Thanks,
> Rodger
>
>
>
> --
> View this message in context:
> http://wikimedia.7.x6.nabble.com/Save-Page-Button-Server-Timeout-tp5002177.html
> Sent from the Semantic Mediawiki - User mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Precog is a next-generation analytics platform capable of advanced
> analytics on semi-structured data. The platform includes APIs for building
> apps and a phenomenal toolset for data science. Developers can use
> our toolset for easy data analysis & visualization. Get a free account!
> http://www2.precog.com/precogplatform/slashdotnewsletter
> _______________________________________________
> Semediawiki-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/semediawiki-user
>



--
WikiWorks · MediaWiki Consulting · http://wikiworks.com
------------------------------------------------------------------------------
Precog is a next-generation analytics platform capable of advanced
analytics on semi-structured data. The platform includes APIs for building
apps and a phenomenal toolset for data science. Developers can use
our toolset for easy data analysis & visualization. Get a free account!
http://www2.precog.com/precogplatform/slashdotnewsletter
_______________________________________________
Semediawiki-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Reply | Threaded
Open this post in threaded view
|

Re: Save Page Button -> Server Timeout?

mog404
Strangely, it is exactly the opposite. Save works with forms but not without. Additional observations.

* Won't create a plain text page.
* Special:CreateTemplate saves, as does Semantic Forms
* Creating a template by hand fails on save.
* Delete (logged in as admin) fails.

It makes no sense. Maybe a file or DB is corrupt or has bad privileges.