Setting up email on Windows

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Setting up email on Windows

Dave Sigafoos
I found information in the defaultsettings.php for setting up email.  As
normally I should be able to cut/paste and uncomment.  Right?  (I put my
guesses for my replacements in uppercase)

/**
 * SMTP Mode
 * For using a direct (authenticated) SMTP server connection.
 * Default to false or fill an array :
 * <code>
 * "host" => 'SMTP domain',                    FOOBAR.COM
 * "IDHost" => 'domain for MessageID',         FOOBAR.COM
 * "port" => "25",                             25
 * "auth" => true/false,                       FALSE
 * "username" => user,                         ''
 * "password" => password                      ''
 * </code>
 *
 * @global mixed $wgSMTP
 */
$wgSMTP = false;         TRUE



Now this appears to be setting for an array but the array does not
appear to be defined in the code.  

What am I missing?  

Basically I want to be able to send 'notifications' when the page
changes.  I tested first on the 'create user' confirmation and that is
when I got errors.


DSig
David Tod Sigafoos | SANMAR Corporation
PICK Guy
206-770-5585
[hidden email]

 



_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Setting up email on Windows

Fernando Correia
I'm not sure if being on Windows affect mail settings.

Anyway I'm using Windows and these are my settings:

$wgEnableEmail      = true;
$wgEnableUserEmail  = true;
$wgEmergencyContact = "Company name <[hidden email]>";
$wgPasswordSender = $wgEmergencyContact;
$wgSMTP = array(
 'host'     => "mail.company.com",
 'IDHost'   => "company.com",
 'port'     => 25,
 'auth'     => false,
 'username' => "mailusername",
 'password' => "mailuserpassword"
);
$wgEmailAuthentication = true;

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Setting up email on Windows

Dave Sigafoos
It was the $wgSMTP = array( that was missing from the defaultsettings
<sigh>

Thanks for that .. at least now I only get ..

*------------------------------

Warning: require_once(Mail.php) [function.require-once]: failed to open
stream: No such file or directory in C:\Program Files\Apache Software
Foundation\Apache2.2\htdocs\wikiSanMar\includes\UserMailer.php on line
87

Fatal error: require_once() [function.require]: Failed opening required
'Mail.php' (include_path='C:\Program Files\Apache Software
Foundation\Apache2.2\htdocs\wikiSanMar;C:\Program Files\Apache Software
Foundation\Apache2.2\htdocs\wikiSanMar/includes;C:\Program Files\Apache
Software
Foundation\Apache2.2\htdocs\wikiSanMar/languages;.;c:\php\includes') in
C:\Program Files\Apache Software
Foundation\Apache2.2\htdocs\wikiSanMar\includes\UserMailer.php on line
87
*------------------------------

Any ideas about mail.php?

DSig
David Tod Sigafoos | SANMAR Corporation
PICK Guy
206-770-5585
[hidden email]

 


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Fernando
Correia
Sent: Friday, March 30, 2007 10:51
To: MediaWiki announcements and site admin list
Subject: Re: [Mediawiki-l] Setting up email on Windows

I'm not sure if being on Windows affect mail settings.

Anyway I'm using Windows and these are my settings:

$wgEnableEmail      = true;
$wgEnableUserEmail  = true;
$wgEmergencyContact = "Company name <[hidden email]>";
$wgPasswordSender = $wgEmergencyContact;
$wgSMTP = array(
 'host'     => "mail.company.com",
 'IDHost'   => "company.com",
 'port'     => 25,
 'auth'     => false,
 'username' => "mailusername",
 'password' => "mailuserpassword"
);
$wgEmailAuthentication = true;

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Setting up email on Windows

Ian Smith-10

Dave Sigafoos:
> Warning: require_once(Mail.php) ... UserMailer.php
>
> [snip]
>
> Any ideas about mail.php?

For info on $wgSMTP, see:

        http://www.mediawiki.org/wiki/Manual:%24wgSMTP

As it says, you'll need to install the PEAR Mail package.  You'll
probably need to install PEAR first, then use it to install Mail.  It's
not too tricky, though.  See:

        http://pear.php.net/

The "documentation" tab will walk you through the process.

BTW, you can theoretically leave $wgSMTP unset to use the PHP built-in
mailer, which doesn't require this extension.  However, with my Wiki
server on Windows, this didn't work for me, and I never found out why;
emails to certain types of address seemed to get sent but got lost later
in the Microsoft mail handling stuff in our servers.  Switching to using
$wgSMTP fixed it for me.

Ian

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Setting up email on Windows

Dave Sigafoos
Thanks very much.  I forgot to mention that I had been checking out the
old mediatech postings and had found some about missing pear and paths
and OH MY <g>.

Pear is all new to me (still stuck in php 3.x myself <G>).

Thanks again.  I just have to learn this stuff faster

DSig
David Tod Sigafoos | SANMAR Corporation
PICK Guy
206-770-5585
[hidden email]

 


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Ian Smith
Sent: Friday, March 30, 2007 11:29
To: MediaWiki announcements and site admin list
Subject: Re: [Mediawiki-l] Setting up email on Windows


Dave Sigafoos:
> Warning: require_once(Mail.php) ... UserMailer.php
>
> [snip]
>
> Any ideas about mail.php?

For info on $wgSMTP, see:

        http://www.mediawiki.org/wiki/Manual:%24wgSMTP

As it says, you'll need to install the PEAR Mail package.  You'll
probably need to install PEAR first, then use it to install Mail.  It's
not too tricky, though.  See:

        http://pear.php.net/

The "documentation" tab will walk you through the process.

BTW, you can theoretically leave $wgSMTP unset to use the PHP built-in
mailer, which doesn't require this extension.  However, with my Wiki
server on Windows, this didn't work for me, and I never found out why;
emails to certain types of address seemed to get sent but got lost later
in the Microsoft mail handling stuff in our servers.  Switching to using
$wgSMTP fixed it for me.

Ian

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Setting up email on Windows

Fernando Correia
I installed PEAR and the mail extension on Windows. Even though I
didn't know anything about this before, I was able to do it by
following the recipes on MediaWiki and Meta documentation pages.

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://lists.wikimedia.org/mailman/listinfo/mediawiki-l