Thumbnail generating problem with large PNG files

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Thumbnail generating problem with large PNG files

Юрий Страшнов
We have a problem with generating thumbnails for large PNG files (10300
x 6000 and so on) in our intranet installation of MW 1.17.0. I've got a
"Error creating thumbnail: Invalid thumbnail parameters" error.

Generation of JPG thumbs for big files works fine, generation of medium
PNG files (2550 x 3510) works well too.

$wgMaxShellMemory and $wgMaxShellFileSize are set to "unlimited".

How can we find a bottleneck?

--
Best regards, Juriy Strashnov

Ryazan State University
IT Department

Tel. +7 (4912) 460-708 ext. 2188
Fax. +7 (4912) 281-435
Mob. +7 (953) 742-1550
E-mail: [hidden email]


_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Thumbnail generating problem with large PNG files

Benjamin Lees
2011/12/16 Юрий Страшнов <[hidden email]>:
> $wgMaxShellMemory and $wgMaxShellFileSize are set to "unlimited".

How about $wgMaxImageArea?

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Thumbnail generating problem with large PNG files

Юрий Страшнов
In reply to this post by Юрий Страшнов

On 17.12.2011, at 5:57, [hidden email] wrote:

> Message: 11
> Date: Fri, 16 Dec 2011 04:18:39 -0500
> From: Benjamin Lees <[hidden email]>
> Subject: Re: [Mediawiki-l] Thumbnail generating problem with large PNG
> files
> To: MediaWiki announcements and site admin list
> <[hidden email]>
> Message-ID:
> <[hidden email]>
> Content-Type: text/plain; charset=UTF-8
>
> 2011/12/16 ???? ???????? <[hidden email]>:
>> $wgMaxShellMemory and $wgMaxShellFileSize are set to "unlimited".
>
> How about $wgMaxImageArea?


Thanks for the right suggestion! Increasing $wgMaxImageArea to 1.25e8 solved the problem. Thanks a lot!

Best regards, Juriy Strashnov

Ryazan State University
IT Department

Tel. +7 (4912) 460-708 ext. 2188
Fax. +7 (4912) 281-435
Mob. +7 (953) 742-1550
E-mail: [hidden email]


_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l