Toolserver blocked/ignored on WMF servers?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Toolserver blocked/ignored on WMF servers?

Danny B.
Trying to wget some stuff from Wikipedia. It has been working for many years - cron was doing it 4 times a day. Now it no longer works either if ran from nightshade or from willow, either by cron or from commandline.

When running wget with defaults, it requests IPv6, the result is ERROR 504: Gateway Time-out.
When running wget with -4 switch, it requests IPv4, the result is ERROR 503: Service Unavailable.

Problem occurs since November 11th. I just realized it today... :-/

I thought it might be wget issue, so I tried "links" and "curl". No luck as well.

Anybody knows, what's going on?

Thanks.


Danny B.

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Toolserver blocked/ignored on WMF servers?

John Doe-27
Are you sending a user agent?

On Mon, Nov 25, 2013 at 10:34 AM, Danny B. <[hidden email]> wrote:
Trying to wget some stuff from Wikipedia. It has been working for many years - cron was doing it 4 times a day. Now it no longer works either if ran from nightshade or from willow, either by cron or from commandline.

When running wget with defaults, it requests IPv6, the result is ERROR 504: Gateway Time-out.
When running wget with -4 switch, it requests IPv4, the result is ERROR 503: Service Unavailable.

Problem occurs since November 11th. I just realized it today... :-/

I thought it might be wget issue, so I tried "links" and "curl". No luck as well.

Anybody knows, what's going on?

Thanks.


Danny B.

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette


_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Toolserver blocked/ignored on WMF servers?

Danny B.

Are you sending a user agent?


Nope. It is not necessary. It never was and I was sending the default one for many years (IIRC, Toolserver has been whitelisted).

Anyway, I of course tried even changing of the UA string and it did not help. Also, please mind that links is text browser and it did not work as well. Neither lynx did.


Danny B.

_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette
Reply | Threaded
Open this post in threaded view
|

Re: Toolserver blocked/ignored on WMF servers?

Max Semenik
UA is only required for API requests, and wget has one. What kind of
requests are you making?

On 25.11.2013, 19:51 Danny wrote:


> Are you sending a user agent?

> Nope. It is not necessary. It never was and I was sending the
> default one for many years (IIRC, Toolserver has been whitelisted).

> Anyway, I of course tried even changing of the UA string and it did
> not help. Also, please mind that links is text browser and it did
> not work as well. Neither lynx did.



--
Best regards,
  Max Semenik ([[User:MaxSem]])


_______________________________________________
Toolserver-l mailing list ([hidden email])
https://lists.wikimedia.org/mailman/listinfo/toolserver-l
Posting guidelines for this list: https://wiki.toolserver.org/view/Mailing_list_etiquette