Unable to upgrade from v1.5.7 to v1.6.5

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to upgrade from v1.5.7 to v1.6.5

Jakob Breivik Grimstveit-2
I am trying to upgrade from v1.5.7 to v1.6.5, but it fails, and I'm unable to
find the solution myself.

I have tried this with earlier versions of MediaWiki v1.6.x as well,
but it has never worked. Perhaps you can tell me what is wrong here?

> /opt/php/bin/php update.php
MediaWiki 1.6.5 Updater

Going to run database updates for stardocdb
Depending on the size of your database this may take a while!
Abort with control-c in the next five seconds...0
...hitcounter table already exists.
...querycache table already exists.
...objectcache table already exists.
...categorylinks table already exists.
...logging table already exists.
...validate table already exists.
...user_newtalk table already exists.
...transcache table already exists.
...trackbacks table already exists.
...externallinks table already exists.
Creating job table...Query "CREATE TABLE `stardoc_job` (
job_id int(9) unsigned NOT NULL auto_increment,
job_cmd varchar(255) NOT NULL default '',
job_namespace int NOT NULL,
job_title varchar(255) binary NOT NULL,
job_params blob NOT NULL default '',
PRIMARY KEY job_id (job_id),
KEY (job_cmd, job_namespace, job_title)
) TYPE=InnoDB
" failed with error code "Specified key was too long. Max key length
is 500 (localhost)".

$ mysql --version
mysql  Ver 12.22 Distrib 4.0.18, for suse-linux (i686)

$ /opt/php/bin/php -v
PHP 5.1.2 (cli) (built: Feb 21 2006 21:39:07)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

$ cat /etc/issue | grep Kernel
Welcome to SUSE LINUX Enterprise Server 9 (i586) - Kernel \r (\l).

$ uname -a
Linux bgnl1-2 2.6.5-7.252-smp #1 SMP Tue Feb 14 11:11:04 UTC 2006 i686
i686 i386 GNU/Linux

Any clue what this might imply? Have read quite a few posts about this
being related to MySQL and it's handling of UTF8, but I don't see how
I can resolve this.

Tried both v1.6.2, v1.6.3 and v1.6.5, same problem occured.

How can I fix this so MediaWiki accepts the database? I have Googled a
lot about this, but have not found the definitive answer yet, so now
I'm turning to you.

I would love to upgrade to the v1.6 series, is this not possible in my
situation?

Thanks in advance for any help on this!


--
Jakob Breivik Grimstveit - http://www.grimstveit.no/jakob - +47 48298152
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Unable to upgrade from v1.5.7 to v1.6.5

Rob Church
On 05/05/06, Jakob B. Grimstveit <[hidden email]> wrote:
> I am trying to upgrade from v1.5.7 to v1.6.5, but it fails, and I'm unable to
> find the solution myself.
>
> I have tried this with earlier versions of MediaWiki v1.6.x as well,
> but it has never worked. Perhaps you can tell me what is wrong here?
>
[snip]
> " failed with error code "Specified key was too long. Max key length
> is 500 (localhost)".

This is a known issue for some users, and various suggestions, advice
and workarounds are available at
http://bugzilla.wikimedia.org/show_bug.cgi?id=1322. I'd check to see
if one of these works.


Rob Church
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l