Upgrade and Problems with Images

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade and Problems with Images

Jonathan Boivin
Hi
 
I recently transferred my wiki from one web server to another before upgrading my mediawiki software from 1.4.. to 1.6.8. The first problem I encoutered is that the JPG and PNG files that were uploaded to the images folder by editors using Mediawiki seem to be corrupted ; when I download them using my FTP access to my computer or if I try to upload them to my new web server, I cannot open them or they do not display as they should. However, when I view them in the original wiki or if I ask my browser to display the URL of an image on the web, the images are ok (???). I don't understand why this problem happens, and do you have a less tedious way of solving it than taking the images from my browser one by one and right-clicking to save them on my computer before uploading them (there are 1200 images to fix) ?
 
Second, version 1.4 seems to place all the uploaded images directly in the images folder while 1.6.8 creates subdirectories with numbers or letters. As a consequence of that none of my images can be viewed because the new version can't find them, and I would have to upload each of them again ! Can I disable this subdirectories feature, or what determines the location where a particular image will be saved when uploaded ?
 
Thank you.
Jonathan Boivin
_________________________________________________________________
Soyez le premier de votre quartier à découvrir le futur Hotmail : essayez Windows Live Mail Beta
http://ideas.live.com/programpage.aspx?versionId=5d21c51a-b161-4314-9b0e-4911fb2b2e6d
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade and Problems with Images

Rob Church
On 05/06/06, Jonathan Boivin <[hidden email]> wrote:
> Second, version 1.4 seems to place all the uploaded images directly in the images folder while 1.6.8 creates subdirectories with numbers or letters. As a consequence of that none of my images can be viewed because the new version can't find them, and I would have to upload each of them again ! Can I disable this subdirectories feature, or what determines the location where a particular image will be saved when uploaded ?

Set $wgHashedUploadDirectory = false; in LocalSettings.php.


Rob Church
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l