Upgrade to 1.18

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade to 1.18

Gordon Joly


I have Mediawiki installation went from 1.17 through 1.18 RC1 and to
1.18 - no problems.

But another Mediawiki has had some problems going direct from 1.17 to
1.18 - I took out Recaptcha and now see this:


*Fatal error*: Cannot redeclare wfprofilein() (previously declared in
/xxxxxxxx/public_html/includes/profiler/Profiler.php:14) in
*/xxxxx/public_html/includes/ProfilerStub.php* on line *25*

Not sure why...

Gordo

--

Gordon Joly
[hidden email]
http://www.joly.org.uk/
Don't Leave Space To The Professionals!

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Jeffrey T. Darlington
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 11/29/2011 11:58 AM, Gordon Joly wrote:
> *Fatal error*: Cannot redeclare wfprofilein() (previously declared in
> /xxxxxxxx/public_html/includes/profiler/Profiler.php:14) in
> */xxxxx/public_html/includes/ProfilerStub.php* on line *25*

I'm getting lots of similar errors about redeclaring wfprofilein():

[Tue Nov 29 11:49:01 2011] [error] [client {my-IP}] PHP Fatal error:
Cannot redeclare wfprofilein() in
{path-to-wiki}/includes/ProfilerStub.php on line 19, referer:
{domain-name}/wiki/Special:SpecialPages
[Tue Nov 29 11:49:04 2011] [error] [client {my-IP}] PHP Fatal error:
Cannot redeclare wfprofilein() in
{path-to-wiki}/includes/ProfilerStub.php on line 19, referer:
{domain-name}/wiki/Special:SpecialPages
[Tue Nov 29 11:49:10 2011] [error] [client {my-IP}] PHP Fatal error:
Cannot redeclare wfprofilein() in
{path-to-wiki}/includes/ProfilerStub.php on line 19

I had to roll back to 1.17.1; all my 1.18.0 wiki pages are 500-ing.

- --

Jeff Darlington
General Protection Fault
{domain-name}/

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk7VEjEACgkQVNMIBILmfwE3UACgwhBQkn0IRBp5y42R2ICj1nIc
sLMAn1O0kftYxLg4iOJFsew5T/pU1Sm0
=FrG8
-----END PGP SIGNATURE-----

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Support Simpsonspedia
In reply to this post by Gordon Joly

hello,
i had the same problem if i rewrite the files. so i deleted all files und
uploaded the new files separatly.

best regards
s.net



-----Ursprüngliche Nachricht-----
From: Gordon Joly
Sent: Tuesday, November 29, 2011 5:58 PM
To: MediaWiki announcements and site admin list
Subject: [Mediawiki-l] Upgrade to 1.18



I have Mediawiki installation went from 1.17 through 1.18 RC1 and to
1.18 - no problems.

But another Mediawiki has had some problems going direct from 1.17 to
1.18 - I took out Recaptcha and now see this:


*Fatal error*: Cannot redeclare wfprofilein() (previously declared in
/xxxxxxxx/public_html/includes/profiler/Profiler.php:14) in
*/xxxxx/public_html/includes/ProfilerStub.php* on line *25*

Not sure why...

Gordo

--

Gordon Joly
[hidden email]
http://www.joly.org.uk/
Don't Leave Space To The Professionals!

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l



_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Daniel Friesen-4
In reply to this post by Gordon Joly
On Tue, 29 Nov 2011 08:58:09 -0800, Gordon Joly <[hidden email]>  
wrote:

>
>
> I have Mediawiki installation went from 1.17 through 1.18 RC1 and to
> 1.18 - no problems.
>
> But another Mediawiki has had some problems going direct from 1.17 to
> 1.18 - I took out Recaptcha and now see this:
>
>
> *Fatal error*: Cannot redeclare wfprofilein() (previously declared in
> /xxxxxxxx/public_html/includes/profiler/Profiler.php:14) in
> */xxxxx/public_html/includes/ProfilerStub.php* on line *25*
>
> Not sure why...
>
> Gordo
>

Sounds like you upgraded MediaWiki by extracting 1.18 on top of 1.17  
instead of extracting 1.18 to a new directory then moving the config and  
other stuff to the new directory. And have an old StartProfiler.php.

includes/ProfilerStub.php was moved to includes/profiler/Profiler.php and  
includes/profiler/ProfilerStub.php in 1.18

Basically what it looks like is happening is that you have a  
includes/ProfilerStub.php file from 1.17 and includes/profiler/ from 1.18.
Because your StartProfiler.php likely uses the old method of a  
require_once (instead of autoloading as I believe we now do) MediaWiki is  
loading the 1.18 profiler code from includes/profiler/Profiler.php and  
then when it require your StartProfiler.php that old require_once is  
requiring the old 1.17 code from includes/ProfilerStub.php causing a fatal  
error as the old code tries to redefine the same method.

If you don't need the profiler I recommend you delete your  
StartProfiler.php. If you do you should probably delete the require_once  
line.
You'd also probably be better off clearing out all the outdated files of  
1.17 code that were left behind since you extracted 1.18 over top of 1.17.  
Though the easiest way to do that is to just re-untar 1.18 in another  
directory, and move your actual LocalSettings, extensions, images/, etc...  
to there.


--
~Daniel Friesen (Dantman, Nadir-Seen-Fire) [http://daniel.friesen.name]

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Jeffrey T. Darlington
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 11/29/2011 12:31 PM, Daniel Friesen wrote:
> Sounds like you upgraded MediaWiki by extracting 1.18 on top of 1.17  
> instead of extracting 1.18 to a new directory then moving the config and  
> other stuff to the new directory. And have an old StartProfiler.php.

I can't speak for Gordon, but that is indeed what I did:  I extracted
the 1.18 tarball on top of the existing 1.17 directory.  This has
usually worked well enough for me in the past, so I tried to repeat what
worked before.

Unfortunately, I'm still having terrible luck.  I extracted 1.18 into a
clean directory, copied over LocalSettings.php and my images folder (I
have no extensions installed so I skipped that), and recreated my
customized MonoBook skin.  (For the skin, I copied the core MonoBook
class file and made my tweaks to insert ads, AddThis, etc.  For the
monobook resource folder, I use symbolic links to all the files except
the main.css, which I copied over and made one tweak to the background
image.)  However, my wiki is still white-screening with the following
errors in the Apache log:

[Tue Nov 29 13:09:09 2011] [error] [client {my-ip}] "" is not a valid
magic word for "canonicalurl", referer:
{domain-name}/wiki/Special:SpecialPages
[Tue Nov 29 13:09:09 2011] [error] [client {my-ip}] "" is not a valid
magic word for "canonicalurle", referer:
{domain-name}/wiki/Special:SpecialPages
[Tue Nov 29 13:09:09 2011] [error] [client {my-ip}] PHP Fatal error:
Call to a member function getGroup() on a non-object in
{path-to-wiki}/includes/OutputPage.php on line 2958, referer:
{domain-name}/wiki/Special:SpecialPages
[Tue Nov 29 13:10:07 2011] [error] [client {my-ip}] "" is not a valid
magic word for "canonicalurl"
[Tue Nov 29 13:10:07 2011] [error] [client {my-ip}] "" is not a valid
magic word for "canonicalurle"
[Tue Nov 29 13:10:07 2011] [error] [client {my-ip}] PHP Fatal error:
Call to a member function getGroup() on a non-object in
{path-to-wiki}/includes/OutputPage.php on line 2958

I'm not sure if this is relevant, but I use the "short URLs" setup using
Apache mod_rewrite.  The relative URL /wiki/Special:SpecialPages worked
well enough under 1.17.1 and below.

I have *NEVER* had this much trouble upgrading MediaWiki.  At this
point, I'm probably going to throw in the towel.  I can get 1.17.1 to
work fine, so I'm reverting back to that.  As much as I'd like to have
the latest version installed, I can't afford this much down-time, or the
time I've spent on this upgrade that I really need to be working on
other projects.

- --

Jeff Darlington
General Protection Fault
http://www.gpf-comics.com/

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk7VI6oACgkQVNMIBILmfwEirQCggQinqu40zcyckpMEV/Xq82Yh
GpUAoJkMxX3YG6SFJHyAw/m3h8ySIlTa
=oNgA
-----END PGP SIGNATURE-----

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Upgrade to 1.18 + float

Support Simpsonspedia
In reply to this post by Daniel Friesen-4
hallo,
after upgrade 1.17.0 to 1.18.0 float doesn't work. http://simpsonspedia.net/index.php?title=Simpsonspedia

<code>

[[Datei:Startseitenbild.png|left|link=Simpsonspedia:Galerie]]„[[The Simpsons]]” bzw. im Deutschen „<strong>Die Simpsons</strong>” ist mehr als nur eine Zeichentrickserie. Die '''Simpsonspedia''' wurde ins Leben gerufen, um Wissenswertes über die Kult-Fernsehsendung der gelbe Familie zusammenzutragen. Sie soll dem suchenden Simpsons-Fan alle möglichen Informationen bereithalten.

Wie auch eine Episode der Simpsons nicht von einer Person erstellt wird, so wächst das Simpsons-Wiki nur durch die Gemeinschaft der Simpsons-Begeisterten. An dieser Stelle geht der Appell an alle Fans der Simpsons, aktiv an dem Projekt mitzuarbeiten, damit sich der Simpsons-Wissensspeicher füllt. Nur zusammen ist es möglich, die Simpsonspedia zu vervollständigen, um so sehr viele Fragen von Fans und Interessierten beantworten zu können. Auf diese Art und Weise sind so bisher '''[[Spezial:Alle_Seiten|{{NUMBEROFARTICLES}} Artikel]]''' entstanden, welche durch '''[[Spezial:Aktive_Benutzer|{{NUMBEROFACTIVEUSERS}} aktive User]]''' betreut werden.

</code>

1.17.0 = image left, text right
1.18.0 = image top, text bottom

what’s going wrong?

best regards
s.net
_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18 + float

nakohdo
> after upgrade 1.17.0 to 1.18.0 float doesn't work. http://simpsonspedia.net/index.php?title=Simpsonspedia

> 1.17.0 = image left, text right
> 1.18.0 = image top, text bottom

> what’s going wrong?

Actually the "float: left;" is missing from the .float-left class in the CSS. You should be able to add it to your monobook CSS.

hth
Frank

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Olivier Beaton
In reply to this post by Jeffrey T. Darlington
It should be noted that the MediaWiki docs recommend doing the following
for an upgrade (after your backups):

tar xvzf mediawiki-1.18.0.tar.gz -C /path/to/your/wiki/ --strip-components=1

https://www.mediawiki.org/wiki/Manual:Upgrading#Unpack_the_new_files

If this is out of date or will cause problems for 1.18, it should
definitely be changed to reflect that. The users posting about profiler
errors followed our instructions.

On Tue, Nov 29, 2011 at 1:25 PM, Jeffrey T. Darlington
<[hidden email]>wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> On 11/29/2011 12:31 PM, Daniel Friesen wrote:
> > Sounds like you upgraded MediaWiki by extracting 1.18 on top of 1.17
> > instead of extracting 1.18 to a new directory then moving the config and
> > other stuff to the new directory. And have an old StartProfiler.php.
>
> I can't speak for Gordon, but that is indeed what I did:  I extracted
> the 1.18 tarball on top of the existing 1.17 directory.  This has
> usually worked well enough for me in the past, so I tried to repeat what
> worked before.
>
> Unfortunately, I'm still having terrible luck.  I extracted 1.18 into a
> clean directory, copied over LocalSettings.php and my images folder (I
> have no extensions installed so I skipped that), and recreated my
> customized MonoBook skin.  (For the skin, I copied the core MonoBook
> class file and made my tweaks to insert ads, AddThis, etc.  For the
> monobook resource folder, I use symbolic links to all the files except
> the main.css, which I copied over and made one tweak to the background
> image.)  However, my wiki is still white-screening with the following
> errors in the Apache log:
>
> [Tue Nov 29 13:09:09 2011] [error] [client {my-ip}] "" is not a valid
> magic word for "canonicalurl", referer:
> {domain-name}/wiki/Special:SpecialPages
> [Tue Nov 29 13:09:09 2011] [error] [client {my-ip}] "" is not a valid
> magic word for "canonicalurle", referer:
> {domain-name}/wiki/Special:SpecialPages
> [Tue Nov 29 13:09:09 2011] [error] [client {my-ip}] PHP Fatal error:
> Call to a member function getGroup() on a non-object in
> {path-to-wiki}/includes/OutputPage.php on line 2958, referer:
> {domain-name}/wiki/Special:SpecialPages
> [Tue Nov 29 13:10:07 2011] [error] [client {my-ip}] "" is not a valid
> magic word for "canonicalurl"
> [Tue Nov 29 13:10:07 2011] [error] [client {my-ip}] "" is not a valid
> magic word for "canonicalurle"
> [Tue Nov 29 13:10:07 2011] [error] [client {my-ip}] PHP Fatal error:
> Call to a member function getGroup() on a non-object in
> {path-to-wiki}/includes/OutputPage.php on line 2958
>
> I'm not sure if this is relevant, but I use the "short URLs" setup using
> Apache mod_rewrite.  The relative URL /wiki/Special:SpecialPages worked
> well enough under 1.17.1 and below.
>
> I have *NEVER* had this much trouble upgrading MediaWiki.  At this
> point, I'm probably going to throw in the towel.  I can get 1.17.1 to
> work fine, so I'm reverting back to that.  As much as I'd like to have
> the latest version installed, I can't afford this much down-time, or the
> time I've spent on this upgrade that I really need to be working on
> other projects.
>
> - --
>
> Jeff Darlington
> General Protection Fault
> http://www.gpf-comics.com/
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2.0.17 (MingW32)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iEYEARECAAYFAk7VI6oACgkQVNMIBILmfwEirQCggQinqu40zcyckpMEV/Xq82Yh
> GpUAoJkMxX3YG6SFJHyAw/m3h8ySIlTa
> =oNgA
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> MediaWiki-l mailing list
> [hidden email]
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18 + float + list element

Support Simpsonspedia
In reply to this post by nakohdo
i think i fixed all float values

but now i see, that the new id "mw-normal-catlinks" also doesn't exist.
http://simpsonspedia.net/index.php?title=Stefane_August
look at category



f***ing new faulty main.css



-----Ursprüngliche Nachricht-----
From: Frank Ralf
Sent: Tuesday, November 29, 2011 7:47 PM
To: [hidden email]
Subject: Re: [Mediawiki-l] Upgrade to 1.18 + float

> after upgrade 1.17.0 to 1.18.0 float doesn't work.
> http://simpsonspedia.net/index.php?title=Simpsonspedia

> 1.17.0 = image left, text right
> 1.18.0 = image top, text bottom

> what’s going wrong?

Actually the "float: left;" is missing from the .float-left class in the
CSS. You should be able to add it to your monobook CSS.

hth
Frank

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l



_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18 + float + list element

Dave butlerdi
f***ing new faulty main.css

+1

On 29 November 2011 23:21, Support Simpsonspedia
<[hidden email]>wrote:

> i think i fixed all float values
>
> but now i see, that the new id "mw-normal-catlinks" also doesn't exist.
> http://simpsonspedia.net/index.php?title=Stefane_August
> look at category
>
>
>
> f***ing new faulty main.css
>
>
>
> -----Ursprüngliche Nachricht-----
> From: Frank Ralf
> Sent: Tuesday, November 29, 2011 7:47 PM
> To: [hidden email]
> Subject: Re: [Mediawiki-l] Upgrade to 1.18 + float
>
> > after upgrade 1.17.0 to 1.18.0 float doesn't work.
> > http://simpsonspedia.net/index.php?title=Simpsonspedia
>
> > 1.17.0 = image left, text right
> > 1.18.0 = image top, text bottom
>
> > what’s going wrong?
>
> Actually the "float: left;" is missing from the .float-left class in the
> CSS. You should be able to add it to your monobook CSS.
>
> hth
> Frank
>
> _______________________________________________
> MediaWiki-l mailing list
> [hidden email]
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
>
>
> _______________________________________________
> MediaWiki-l mailing list
> [hidden email]
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>



--
Regards

Dave Butler
butlerdi-at-pharm2phork-dot-org

Also on Skype as pharm2phork

Get Skype here http://www.skype.com/download.html


**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

www.mimesweeper.com
**********************************************************************
_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
OQ
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18 + float + list element

OQ
On Tue, Nov 29, 2011 at 4:28 PM, Dave butlerdi <[hidden email]> wrote:
> f***ing new faulty main.css
>
> +1
>

Compare your skins/common/shared.css with what you should have:

http://simpsonspedia.net/skins/common/shared.css

http://svn.wikimedia.org/viewvc/mediawiki/tags/REL1_18_0/phase3/skins/common/shared.css?view=co&revision=104511&content-type=text%2Fplain

You're missing all kinds of stuff from it.  I'd double check to make
sure you upgraded properly.

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Mark A. Hershberger
In reply to this post by Jeffrey T. Darlington
"Jeffrey T. Darlington" <[hidden email]> writes:

> [Tue Nov 29 13:09:09 2011] [error] [client {my-ip}] "" is not a valid
> magic word for "canonicalurl", referer:

Have you filed a bug for this?  I haven't seen one if you have.  Please
file one at http://bugzilla.wikimedia.org/ or, if you have already filed
one, please point me to it.

Mark.

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Mark A. Hershberger
In reply to this post by Gordon Joly
Gordon Joly <[hidden email]> writes:

> *Fatal error*: Cannot redeclare wfprofilein() (previously declared in
> /xxxxxxxx/public_html/includes/profiler/Profiler.php:14) in
> */xxxxx/public_html/includes/ProfilerStub.php* on line *25*

I filed a bug (https://bugzilla.wikimedia.org/32760) and CC'd you and
Jeff Darlington on it.  We'll cover it in the triage tomorrow (see
http://thread.gmane.org/gmane.science.linguistics.wikipedia.technical/57017).

Please join us.

Mark.

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Mark A. Hershberger
In reply to this post by Mark A. Hershberger
[hidden email] (Mark A. Hershberger) writes:

> "Jeffrey T. Darlington" <[hidden email]> writes:
>
>> [Tue Nov 29 13:09:09 2011] [error] [client {my-ip}] "" is not a valid
>> magic word for "canonicalurl", referer:
>
> Have you filed a bug for this?

I filed one for you now: https://bugzilla.wikimedia.org/32762

Please join us in Friday's bug triage if you can:
http://thread.gmane.org/gmane.science.linguistics.wikipedia.technical/57017

Thanks!

Mark.

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Jeffrey T. Darlington
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

[hidden email] wrote:
>> Have you filed a bug for this?
>
>I filed one for you now: https://bugzilla.wikimedia.org/32762

Thanks for filing the bug. I hadn't done so mostly because I didn't know about the Bugzilla site. (That's why I joined here.)

- --

Jeff Darlington
General Protection Fault
http://www.gpf-comics.com/
-----BEGIN PGP SIGNATURE-----
Version: APG v1.0.8

iIAEAREIAEAFAk7YJZ05HEplZmZyZXkgVC4gRGFybGluZ3RvbiAoR1BGIENvbWlj
cykgPGplZmZAZ3BmLWNvbWljcy5jb20+AAoJEFTTCASC5n8BSbIAoMkiHjocTsP6
AA9zsMFd36ZHeqbjAJ92pqk+9yxxuOStbBTpWi64COdD0Q==
=hlph
-----END PGP SIGNATURE-----


_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade to 1.18

Gordon Joly
In reply to this post by Gordon Joly
Gordon Joly <gordon.joly <at> pobox.com> writes:

>
>
> I have Mediawiki installation went from 1.17 through 1.18 RC1 and to
> 1.18 - no problems.
>
> But another Mediawiki has had some problems going direct from 1.17 to
> 1.18 - I took out Recaptcha and now see this:
>
> *Fatal error*: Cannot redeclare wfprofilein() (previously declared in
> /xxxxxxxx/public_html/includes/profiler/Profiler.php:14) in
> */xxxxx/public_html/includes/ProfilerStub.php* on line *25*
>
> Not sure why...
>
> Gordo
>


This a feature of the standard upgrade process, as recommended by the
maintainers. That is to unpack a tar image over the working directory.

But since some code has moved, older versions of the code remain and are
executed. It appears that this is the "profiler" code, which has moved into
/includes/profiler/ from /includes/

Deleting the old versions, and the file StartProfiler.php at the top level fixes
this.

Other files in /includes/ in 1.17 (which have to be deleted) are


Profiler.php        ProfilerSimpleText.php   ProfilerSimpleUDP.php
ProtectionForm.php  UserRightsProxy.php
ProfilerSimple.php  ProfilerSimpleTrace.php  ProfilerStub.php      
ProxyTools.php        

Gordo



_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l