Upload dir "not writable" under XAMPP setup - How to make writable??

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Upload dir "not writable" under XAMPP setup - How to make writable??

David Reimer
I am running mediawiki as a localhost setup for development/learning.
The environment is XAMPP (so, Apache, MySQL, PhP, etc.) in WinXP.
Everything is going well ... except for "uploads".

I have read this, and everything else I can find on enabling uploads.
For some reason I keep getting this error message:

"The upload directory ($/images) is not writable by the webserver."

I have checked the apache aliases (none), I have set the flag in the
mediawiki configuration, checked the directory names/path, checked the
directory properties in Windoze, etc. I still cannot get past that
error message. I tried simply copying a .PNG to the /images directory,
but of course that can't be found by mediawiki.

I have read the information at
http://meta.wikimedia.org/wiki/Running_MediaWiki_on_Windows and it is
(more than?) likely that something needs set in my Apache's httpd.conf
file, but I can't work out the options (have looked here:
http://httpd.apache.org/docs/2.2/mod/core.html#options)

Can anyone help me to get past this one?! Thanks! David.
--
David Reimer
Edinburgh, UK
[hidden email]
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upload dir "not writable" under XAMPP setup - How to make writable??

Bugzilla from sy1234@gmail.com
On 5/31/06, David Reimer <[hidden email]> wrote:
> "The upload directory ($/images) is not writable by the webserver."

I wonder if there is a requirement to have windows-style paths in the
LocalSettings.php .. and somehow MediaWiki is trying to use a
nonexistant directory.

Have you tried setting the full image folder's path in LocalSettings.php?
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upload dir "not writable" under XAMPP setup - How to make writable??

David Reimer
In reply to this post by David Reimer
Thanks for that! Good idea, but it doesn't seem to have done the
trick. It results in variations on the error message:

"The upload directory ([whatever dir spec I put in LocalSettings.php])
is not writable by the webserver."

I tried changing both path and dir, in various combinations. :(
Everything else in the installation seems to be working beautifully
(and I have a couple of CMSs purring away, too). It's just the upload
option in MW that seems to be sticky.....

Any other suggestions gratefully received!
David.

> Date: Wed, 31 May 2006 11:04:44 -0500
> From: "Sy Ali" <sy1234@...>

 On 5/31/06, Sy Ali wrote:
>
> I wonder if there is a requirement to have windows-style paths in the
> LocalSettings.php .. and somehow MediaWiki is trying to use a
> nonexistant directory.
>
> Have you tried setting the full image folder's path in LocalSettings.php?
--
David Reimer
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Upload dir "not writable" under XAMPP setup - How to make writable??

David Reimer
In reply to this post by David Reimer
I had asked back on Wed May 31 13:25:55 UTC 2006 about this problem:

[quote]
I am running mediawiki as a localhost setup for development/learning.
The environment is XAMPP (so, Apache, MySQL, PhP, etc.) in WinXP.
Everything is going well ... except for "uploads".

I have read this, and everything else I can find on enabling uploads.
For some reason I keep getting this error message:

"The upload directory ($/images) is not writable by the webserver."
[/quote]

Sy Ali replied suggesting I hard-code the path, which didn't work but
got me thinking.

I posted the solution on the mwuser's forum, but thought I should note
it here, too.

In LocalSettings.php, you remove the "$/" from the $wgUploadDirectory
setting, so it reads:

$wgUploadDirectory = "images";

and then the uploads work fine in WinXP+WAMPP setup ... at least for me!  :)

David.
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l