Use of $wgUseLatin1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Use of $wgUseLatin1

Jeff Lane
We're currently upgrading one of our 1.4.12 installations up to 1.5.8,
before we upgrade to 1.6.5.
 
Under 1.4.12, we have the setting "$wgUseLatin1 = false;" in
LocalSettings.php, which the help page
<http://www.mediawiki.org/wiki/Help:$wgUseLatin1>  (very) briefly
describes as "Enable ISO-8859-1 compatibility mode".
 
Is this still necessary under 1.5.8? The help page says it's still in
use, but it was not in the default 1.5 LocalSettings.php file.
 
Thanks,
-Jeff
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: Use of $wgUseLatin1

Brion Vibber
Jeff Lane wrote:

> We're currently upgrading one of our 1.4.12 installations up to 1.5.8,
> before we upgrade to 1.6.5.
>  
> Under 1.4.12, we have the setting "$wgUseLatin1 = false;" in
> LocalSettings.php, which the help page
> <http://www.mediawiki.org/wiki/Help:$wgUseLatin1>  (very) briefly
> describes as "Enable ISO-8859-1 compatibility mode".
>  
> Is this still necessary under 1.5.8? The help page says it's still in
> use, but it was not in the default 1.5 LocalSettings.php file.
This is obsolete, and is used only by the alternate 1.4->1.5 partial upgrader
which includes some limited ability to automatically convert old database entries.

MediaWiki 1.5 and above use UTF-8 only.

-- brion vibber (brion @ pobox.com)


_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l

signature.asc (257 bytes) Download Attachment