Warning to all bot users!

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Warning to all bot users!

Andre Engels
In edit 1.921 of wikipedia.py, it was tried to avoid some edit
conflicts. Unfortunately, this was done by always claiming we had seen
the last version of the page, and thus throwing away the intermediate
edits. This version and subsequent versions of wikipedia.py will
revert the other party's edits in case of an edit conflict!!!!

Because of this, everyone who currently has version 1.921 to 1.926 of
wikipedia.py is very strongly advised to stop any bots (at least if it
will be saving pages) and first download wikipedia.py 1.927 (or newer)
and family.py 1.248 (or newer) before restarting them (the latter is
necessary because it contains an extension that this newest version of
wikipedia.py uses).

--
Andre Engels, [hidden email]
ICQ: 6260644  --  Skype: a_engels

_______________________________________________
Wikibots-l mailing list
[hidden email]
http://lists.wikimedia.org/mailman/listinfo/wikibots-l
Reply | Threaded
Open this post in threaded view
|

Re: Warning to all bot users!

Andre Engels
2007/6/19, Andre Engels <[hidden email]>:

> Because of this, everyone who currently has version 1.921 to 1.926 of
> wikipedia.py is very strongly advised to stop any bots (at least if it
> will be saving pages) and first download wikipedia.py 1.927 (or newer)
> and family.py 1.248 (or newer) before restarting them (the latter is
> necessary because it contains an extension that this newest version of
> wikipedia.py uses).

Instead of 1.927, please use 1.928 - 1.927 has an irritating bug.

--
Andre Engels, [hidden email]
ICQ: 6260644  --  Skype: a_engels

_______________________________________________
Wikibots-l mailing list
[hidden email]
http://lists.wikimedia.org/mailman/listinfo/wikibots-l