about requiring PHP 5.2

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

about requiring PHP 5.2

Antoine Musso-3
Hello,

Looking at INSTALL it seems we are still supporting PHP version 5.1
which is 5 years old in a couple of weeks.  This is getting old and
prevents developers from using some new features.

Ideally we could raise it to 5.3 to get Namespace support, closures but
that might be to early since most webhost probably still use 5.2.x.

Would it be possible to consider raising the requirement to at least
5.2.0 ?  This would give us native JSON support and most probably the
filter extension enabled by default.  The later can be used to speed up
the input validation.

cheers,

--
Ashar Voultoiz


_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: about requiring PHP 5.2

Curulan Angelicos
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 28-Sep-10 15:39, Ashar Voultoiz wrote:
> Would it be possible to consider raising the requirement to at least
> 5.2.0 ?  This would give us native JSON support and most probably
> the filter extension enabled by default.  The later can be used to
> speed up the input validation.

This brings up an interesting point. I recently updated to 1.17 and had
a hell of a time, because apparently the version of PHP in my host's ssh
was still using 5.0.4. I couldn't run any of the maintenance scripts and
I had to fully reinstall using the web interface (which was running 5.2.x).
- --
Curulan Angelicos
Leader, Clan Titan
OpenPG KeyID: 0x7ACEBA53

Clan Website: http://clantitan.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJMr4f7AAoJEJpTIX56zrpTo2gP/0s1mwHq9uVMkMI5ROcg6/Y/
XdRWOFsNgZP+Hhi1ztqgsod1cvQmSp4ZOEjo8zoe7JfO0Jnnw6BILcKUYhY8iFrt
WDU/N/hW4p1qDtJMbzoKn83ZtD1IdaT0qLfe7SrgdVeJYnxKJLkPlfkhnkSieWJP
WirEYFAX8ixdJIj4c2wK45VmLgdL0rbRpM9qe3Oko3BqawVegDCwt3Onn2CuS6Qu
d07xH14HUEZLxwfczeTm90qEc04eosKZvBFQ9FDPC6vLbk9RdYeUn1VjeG2BnbOj
Ilp8zc4q9ysa5cVD5LG3H5bU8OCjkxvb+Kh3/fu8y37j0KC7EEpK02cRBYTN8Nw8
MZjboxd2PFkeCOsO4j92nctSOI3Mb576VvWLBgF5gcKF9rIMhW41+PDEZUNY/4EZ
NIjrlblyJ82SMclci8i9Y+V9Ug02Eec+78UK540eMDebOKI5SLwRaIphcYePmm/g
mV7O+BM87dBdn8z4k4imyXu2HzUBlTwYYYgco/Piz2bsN6dPQWwBpeXKivybW7qZ
+nj3zzr0EiI3Y0TppQoCHLFU3J5+PkPz//h4plBRm6E3/5rhC9ne4y4B8hvSZ4MA
IYNwtKfppQEb8bsezoCCncphTXDORuR809Q9iCvGZjxGHwbTVj158KS3CegdH4gC
b27iZK24HEpRQCBDKyqB
=E604
-----END PGP SIGNATURE-----

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Fwd: about requiring PHP 5.2

Chad
In reply to this post by Antoine Musso-3
Forwarding to wikitech-l, needs more audience.

I've no love for outdated software, so I'm firmly in
the +1 camp.

-Chad

---------- Forwarded message ----------
From: Ashar Voultoiz <[hidden email]>
Date: Tue, Sep 28, 2010 at 3:39 PM
Subject: [Mediawiki-l] about requiring PHP 5.2
To: [hidden email]


Hello,

Looking at INSTALL it seems we are still supporting PHP version 5.1
which is 5 years old in a couple of weeks.  This is getting old and
prevents developers from using some new features.

Ideally we could raise it to 5.3 to get Namespace support, closures but
that might be to early since most webhost probably still use 5.2.x.

Would it be possible to consider raising the requirement to at least
5.2.0 ?  This would give us native JSON support and most probably the
filter extension enabled by default.  The later can be used to speed up
the input validation.

cheers,

--
Ashar Voultoiz


_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: about requiring PHP 5.2

David Gerard-2
In reply to this post by Antoine Musso-3
On 28 September 2010 20:39, Ashar Voultoiz <[hidden email]> wrote:

> Looking at INSTALL it seems we are still supporting PHP version 5.1
> which is 5 years old in a couple of weeks.  This is getting old and
> prevents developers from using some new features.


5.1 doesn't actually work. I recently tried installing 1.15.4 from the
tarball onto RHEL 5 and it refused to actually work with the system
PHP 5.1. I had to install 5.3.


- d.

_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: about requiring PHP 5.2

Daniel Barrett-3
We use PHP 5.1.6 (standard with CentOS) and MW 1.16 just fine.
DanB

-----Original Message-----
5.1 doesn't actually work. I recently tried installing 1.15.4 from the
tarball onto RHEL 5 and it refused to actually work with the system
PHP 5.1. I had to install 5.3.
_______________________________________________
MediaWiki-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l