bug in UPGRADE and maintenance/upgrade1_5.php upgrading from 1.4rc1 to 1.5.5 using php 4.4.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

bug in UPGRADE and maintenance/upgrade1_5.php upgrading from 1.4rc1 to 1.5.5 using php 4.4.0

Tobias Bengtsson
Hi

When I run maintenance/upgrade1_5.php to convert iso8859-1 to UTF-8 as
told in UPGRADE I get these errors.

Fatal error: Cannot instantiate non-existent class:  specialpage in
/home/www/sites/tobbe.nu/mediawiki-1.5.5/includes/SpecialPage.php on line 72
Fatal error: Cannot instantiate non-existent class:  unlistedspecialpage
in /home/www/sites/tobbe.nu/mediawiki-1.5.5/includes/SpecialPage.php on
line 396

linenumbers could be bogus as I changed the file to get it to work.
The issue is that you need to put the classes at the top of the file
SpecialPage.php. I did that and the upgrade works.

another issue is in UPGRADE, you need to tell folks to change $IP and
not just to copy LocalSettings.php, otherwise no upgrade works..

thanks for a great product.

kind regards Tobias
_______________________________________________
Wikitech-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/wikitech-l
Reply | Threaded
Open this post in threaded view
|

Re: bug in UPGRADE and maintenance/upgrade1_5.php upgrading from 1.4rc1 to 1.5.5 using php 4.4.0

Brion Vibber
Tobias Bengtsson wrote:

> When I run maintenance/upgrade1_5.php to convert iso8859-1 to UTF-8 as
> told in UPGRADE I get these errors.
>
> Fatal error: Cannot instantiate non-existent class:  specialpage in
> /home/www/sites/tobbe.nu/mediawiki-1.5.5/includes/SpecialPage.php on
> line 72
> Fatal error: Cannot instantiate non-existent class:  unlistedspecialpage
> in /home/www/sites/tobbe.nu/mediawiki-1.5.5/includes/SpecialPage.php on
> line 396
>
> linenumbers could be bogus as I changed the file to get it to work.
> The issue is that you need to put the classes at the top of the file
> SpecialPage.php. I did that and the upgrade works.
I just tested on an upgrade from a fresh install of 1.4.13 to 1.5.5, running
upgrade1_5.php, with PHP 4.4.1, no custom configuration to MediaWiki.

There was no problem at all; the program ran through to the end.

> another issue is in UPGRADE, you need to tell folks to change $IP and
> not just to copy LocalSettings.php, otherwise no upgrade works..

If they change the directory, obviously they need to change the path reference.
If they don't, they don't.

-- brion vibber (brion @ pobox.com)


_______________________________________________
Wikitech-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/wikitech-l

signature.asc (257 bytes) Download Attachment