removing 1.5 upgrader

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

removing 1.5 upgrader

Antoine Musso-3
Hello,

We still have a the 1.4 -> 1.5 upgrader in trunk. It was used to handle
both the schema changes and the encoding changes that occurred in 1.5.

According to code review on r72865 [1], it is broken since r22580 [2]
from May 2007.

Can we please remove it for 1.17 ? I am not sure we still have to
support an upgrade from 1.4 which is like 5 years old and probably not
used anywhere nowadays.


[1] http://www.mediawiki.org/wiki/Special:Code/MediaWiki/72865
[2] http://www.mediawiki.org/wiki/Special:Code/MediaWiki/22580

--
Ashar Voultoiz


_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l
Reply | Threaded
Open this post in threaded view
|

Re: removing 1.5 upgrader

Chad
On Sun, Oct 31, 2010 at 12:17 PM, Ashar Voultoiz <[hidden email]> wrote:
> Can we please remove it for 1.17 ? I am not sure we still have to
> support an upgrade from 1.4 which is like 5 years old and probably not
> used anywhere nowadays.
>

We should still support such upgrades, but upgrade1_5 shouldn't be
necessary. See bug 25398.

-Chad

_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l
Reply | Threaded
Open this post in threaded view
|

Re: removing 1.5 upgrader

IAlex
In reply to this post by Antoine Musso-3
Hi,

Just a quick note: I already opened bug 25398 [1] to discuss about this.

[1] https://bugzilla.wikimedia.org/show_bug.cgi?id=25398

Cheers,
Alexandre Emsenhuber (ialex)

Le 31 oct. 2010 à 17:17, Ashar Voultoiz a écrit :

> Hello,
>
> We still have a the 1.4 -> 1.5 upgrader in trunk. It was used to handle
> both the schema changes and the encoding changes that occurred in 1.5.
>
> According to code review on r72865 [1], it is broken since r22580 [2]
> from May 2007.
>
> Can we please remove it for 1.17 ? I am not sure we still have to
> support an upgrade from 1.4 which is like 5 years old and probably not
> used anywhere nowadays.
>
>
> [1] http://www.mediawiki.org/wiki/Special:Code/MediaWiki/72865
> [2] http://www.mediawiki.org/wiki/Special:Code/MediaWiki/22580
>
> --
> Ashar Voultoiz
>
>
> _______________________________________________
> Wikitech-l mailing list
> [hidden email]
> https://lists.wikimedia.org/mailman/listinfo/wikitech-l


_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l
Reply | Threaded
Open this post in threaded view
|

Re: removing 1.5 upgrader

Max Semenik
In reply to this post by Antoine Musso-3
On 31.10.2010, 19:17 Ashar wrote:

> Hello,

> We still have a the 1.4 -> 1.5 upgrader in trunk. It was used to handle
> both the schema changes and the encoding changes that occurred in 1.5.

> According to code review on r72865 [1], it is broken since r22580 [2]
> from May 2007.

> Can we please remove it for 1.17 ? I am not sure we still have to
> support an upgrade from 1.4 which is like 5 years old and probably not
> used anywhere nowadays.

I remember people asking about upgrades from pre-1.5 on IRC as late as
this month. Suppose, we need to keep the encoding conversion too,
because people who don't upgrade from 1.3 or so are usually the same
people who will have problems with manual conversion.


--
Best regards,
  Max Semenik ([[User:MaxSem]])


_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l
Reply | Threaded
Open this post in threaded view
|

Re: removing 1.5 upgrader

Aryeh Gregor
On Sun, Oct 31, 2010 at 12:29 PM, Max Semenik <[hidden email]> wrote:
> I remember people asking about upgrades from pre-1.5 on IRC as late as
> this month. Suppose, we need to keep the encoding conversion too,
> because people who don't upgrade from 1.3 or so are usually the same
> people who will have problems with manual conversion.

It would always be possible to tell them to upgrade to 1.16 first,
then 1.17 or later.  If the pre-1.5 upgrade process is really too much
trouble to maintain, I think that would be okay.  Certainly better
than keeping it around but not testing it enough so that it doesn't
work reliably in practice.

_______________________________________________
Wikitech-l mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/wikitech-l