using a newer version of API with older Mediawiki install?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

using a newer version of API with older Mediawiki install?

Synerynx
Hi all,
I haven't found an answer to this elsewhere, so I'm posing the question here. 

Is it possible to use a newer version of the mediawiki api (perhaps by copying api.php from a newer version) with an older MW installation?  I am on MW 1.12 and would like to use the edit feature introduced in MW 1.13, but without the effort of upgrading our entire wiki.  Is this possible?

Thanks for your help.
Matthew

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: using a newer version of API with older Mediawiki install?

Bryan Tong Minh
On Tue, Oct 28, 2008 at 7:07 PM, . . <[hidden email]> wrote:

> Hi all,
> I haven't found an answer to this elsewhere, so I'm posing the question
> here.
>
> Is it possible to use a newer version of the mediawiki api (perhaps by
> copying api.php from a newer version) with an older MW installation?  I am
> on MW 1.12 and would like to use the edit feature introduced in MW 1.13, but
> without the effort of upgrading our entire wiki.  Is this possible?
>
> Thanks for your help.
> Matthew
>
> _______________________________________________
> Mediawiki-api mailing list
> [hidden email]
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
>
>

Probably not. There were some backend changes necessary for the edit
api to work. That said, you can always try to copy EditPage.php along
as well.


Bryan

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: using a newer version of API with older Mediawiki install?

Roan Kattouw
Bryan Tong Minh schreef:

> On Tue, Oct 28, 2008 at 7:07 PM, . . <[hidden email]> wrote:
>  
>> Hi all,
>> I haven't found an answer to this elsewhere, so I'm posing the question
>> here.
>>
>> Is it possible to use a newer version of the mediawiki api (perhaps by
>> copying api.php from a newer version) with an older MW installation?  I am
>> on MW 1.12 and would like to use the edit feature introduced in MW 1.13, but
>> without the effort of upgrading our entire wiki.  Is this possible?
>>
>> Thanks for your help.
>> Matthew
>>
>> _______________________________________________
>> Mediawiki-api mailing list
>> [hidden email]
>> https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
>>
>>
>>    
>
> Probably not. There were some backend changes necessary for the edit
> api to work. That said, you can always try to copy EditPage.php along
> as well.
I very, VERY strongly recommend against this. You would at the very
least have to copy the entire includes/api directory and EditPage.php,
but there's probably lots of other changes in core causing
incompatibility between the 1.13 API and the 1.12 core. This kind of
selective upgrading is really just asking for trouble.

Upgrading MediaWiki is not that much trouble. All you need to do is
overwrite the old files with the new ones and run update.php from the
command line. For the upgrading manual, see [1].

Roan Kattouw (Catrope)

[1] http://www.mediawiki.org/wiki/Manual:Upgrading

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
Reply | Threaded
Open this post in threaded view
|

Re: using a newer version of API with older Mediawiki install?

Synerynx
Thanks for your help. I will go the upgrade route.
Regards,
Matthew

On Tue, Oct 28, 2008 at 1:43 PM, Roan Kattouw <[hidden email]> wrote:
Bryan Tong Minh schreef:
> On Tue, Oct 28, 2008 at 7:07 PM, . . <[hidden email]> wrote:
>
>> Hi all,
>> I haven't found an answer to this elsewhere, so I'm posing the question
>> here.
>>
>> Is it possible to use a newer version of the mediawiki api (perhaps by
>> copying api.php from a newer version) with an older MW installation?  I am
>> on MW 1.12 and would like to use the edit feature introduced in MW 1.13, but
>> without the effort of upgrading our entire wiki.  Is this possible?
>>
>> Thanks for your help.
>> Matthew
>>
>> _______________________________________________
>> Mediawiki-api mailing list
>> [hidden email]
>> https://lists.wikimedia.org/mailman/listinfo/mediawiki-api
>>
>>
>>
>
> Probably not. There were some backend changes necessary for the edit
> api to work. That said, you can always try to copy EditPage.php along
> as well.
I very, VERY strongly recommend against this. You would at the very
least have to copy the entire includes/api directory and EditPage.php,
but there's probably lots of other changes in core causing
incompatibility between the 1.13 API and the 1.12 core. This kind of
selective upgrading is really just asking for trouble.

Upgrading MediaWiki is not that much trouble. All you need to do is
overwrite the old files with the new ones and run update.php from the
command line. For the upgrading manual, see [1].

Roan Kattouw (Catrope)

[1] http://www.mediawiki.org/wiki/Manual:Upgrading

_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api


_______________________________________________
Mediawiki-api mailing list
[hidden email]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api