wmv video upload works for small, not big files. Large mp3's or swf files do work.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

wmv video upload works for small, not big files. Large mp3's or swf files do work.

Jonathan Andrew Wolter
I am not able to upload large windows media video (wmv) files to a MediaWiki
1.5.5 running on php 4.3.10-16 and MySQL 4.0.24_Debian-10sarge1-log.

 

In testing, I am able to upload small wmv files (<3meg).

When I try with large ones, I either (a) the page waits for a few minutes
(while status bar in IE slowly grows) and then appears to refresh with no
error (and no file uploaded) or (b) IE shows "this page cannot be displayed'

 

The uploads directory is writable.

I can upload other images, mp3 files (tested successfully 10 meg), swf or
fla flash files (tested >7megs) and these appear perfectly.

I've tried increasing the php.ini settings: memory_limit = 16M;
upload_max_filesize = 12M; post_max_size = 12M;  I have also increased the
time allowed for scripts to run and load.

 

I added to LocalSettings.php:

   $wgFileExtensions = array('gif', .. The others already there. 'wmv');

   $wgVerifyMimeType = false;

When I look at a small wmv (<3meg) file I successfully uploaded, the mime
type is text/plain (which seems odd, mp3 files are properly identified)

 

Any ideas? Could it be the codec I used to encode the wmv file? (I used
camtasia - this is for video based training in our internal company wiki).

 

Thanks!

 

Jonathan Andrew Wolter

 <http://www.tsgrp.com/> technology services group

Voice: 312.372.7777 x270

Fax: 815.425.1302

 

 

_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
Reply | Threaded
Open this post in threaded view
|

Re: wmv video upload works for small, not big files. Large mp3's or swf files do work.

Bugzilla from sy1234@gmail.com
On 1/31/06, Jonathan Andrew Wolter <[hidden email]> wrote:
> Any ideas? Could it be the codec I used to encode the wmv file? (I used
> camtasia - this is for video based training in our internal company wiki).

It's probably an issue with http uploading.. either a php limit on
maximum filesize or a problem with the timeout.
_______________________________________________
MediaWiki-l mailing list
[hidden email]
http://mail.wikipedia.org/mailman/listinfo/mediawiki-l